cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
518
Views
3
Helpful
3
Replies
Highlighted
Beginner

Provisioning a 3802i through PnP with Prime Infrastructure 3.1 / APIC-EM 1.4.2

Hi ,

I am trying to PnP provision a new 3802i AP (which I upgraded from 8.2 to 8.3 release in order to get PnP to function) with PI3.1.6 integrated with APIC-EM 1.4.2 with a new config. For some reason it's not properly getting through and stopping the process with an error. I cannot find any reference to the error. The json file which was generated looks perfectly fine to me. Is anyone having a clue on what the issue is?

TimestampEvent
2017-05-08 16:22:25 (W. Europe Standard Time)Received response from pnp agent for message correlatorId: Cisco-PnP-1.0-6-f21818bf-c94d-4g9d-9db7-73fe5453aef4-1 but with error code : ZTD_CMD_ERROR Response String: XSVC_ERROR:XSVC_ERROR_CONFIG_UPGRADE_INTERNAL:PnP - Config Apply failed. Invalid value in json or missing Primary WLC IP service log: null
2017-05-08 16:22:21 (W. Europe Standard Time)Hostname configured successfully
2017-05-08 16:22:20 (W. Europe Standard Time)Matched a pre-provisioned rule in site Test
2017-05-08 16:22:14 (W. Europe Standard Time)AP IP address successfully retrieved: 10.1.20.102
2017-05-08 16:18:59 (W. Europe Standard Time)Device first contact

Next I was expecting also to be able to set a FlexConnect Group as mentioned here Cisco Prime Infrastructure 3.1 User Guide - Configuring Plug and Play [Cisco Prime Infrastructure] - Cisco under Plug and Play profiles. But it seems not be be in the Prime GUI yet.

thanks,

Richard

3 REPLIES 3
Highlighted
Cisco Employee

can you share the json file you are using.  Please x.x.x.x the ip address, but i want to see the structure.

Highlighted

here it is, so this is how it has been injected from Prime Infra, but I also tried from APIC-EM directly - same result.

{"primaryWlcIP":"x.x.x.x","primaryWlcName":"xxxx","secondaryWlcIP":"y.y.y.y","secondaryWlcName":"yyyy","tertiaryWlcIP":"z.z.z.z","tertiaryWlcName":"zzzz","apGroup":"APG_Test","apMode":"FlexConnect"}

Highlighted

just a quick thought.  You are not falling victim to Microsoft smart quotes?

the above looks fine, but i have seen the smart quotes issue many times in the past.

Change curly quotes to straight quotes and vice versa - Office Support

This widget could not be displayed.