cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
Avisos
Developers-novedades

Integración CISCO HUAWEI Redistribución OSPF EIGRP

1726
Visitas
10
ÚTIL
2
Comentarios
MichelyLopez
Beginner

Hola a todos amantes de la tecnología, hoy aprenderemos nuevas habilidades y se trata de la Redistribución de protocolo para interconectar redes con equipos de infraestructura Huawei y Cisco, muchas veces surge la pregunta.

¿Por qué Redistribuir Rutas?

La redistribución de rutas nace para la conexión entre dominios de routing, en ospf un AS (Sistema Autónomo) es un dominio de procesos y para efectuar enrutamiento entre dominios de procesos, un ASBR (Router de Borde de Sistema Autónomo) ospf debe realizar una redistribución de rutas.

Cuando hablamos de eigrp nos vemos en la misma necesidad, normalmente una red con eigrp puede estar conformada en varios sistemas autónomos, hablar de un sistema autónomo en eigrp es como hablar de un dominio de procesos en ospf, es por esta razón que para encaminar todo el tráfico de un sistema autónomo a otro debemos hacerlo con redistribución de rutas mejor conocida como redistribución de sistemas autónomos.

En este post se realizara la redistribución de protocolo en un edificio con equipos de infraestructura Huawei donde estará operando un Router AR2200 conectado a un switch 3700 dicha red huawei estará conectada a una sucursal que utiliza como medio de interconexión de red equipos de infraestructura Cisco donde estará funcionando un Switch multicapa 3720 conectado a un switch capa 2, para ubicarse bien en esta breve explicación le invita a ver la imagen de topología presentada a continuación.

Esta simulación se realiza utilizando herramientas de software como eNSP y GNS3

 

Topologia

TOPOLOGIA.png

Configuración de red Huawei

Configuración de la interfaz del Router Huawei que conecta el enlace hacia la red Cisco

interface GigabitEthernet 0/0/1

ip address 10.10.10.1 255.255.255.252

description Huawei cisco

quit

Configuración de la Interfaz de Gateway que conecta la red LAN Huawei

interface GigabitEthernet 0/0/0

ip address 15.15.15.1 24

quit

Configuración de OSPF

ospf 1 router-id 1.1.1.1

area 0

network 10.10.10.0 0.0.0.3

network 15.15.15.0 0.0.0.255

return

 

Configuracion de red Cisco

Configuración de la interfaz del Router Cisco que conecta el enlace hacia la red Huawei

interface f0/0

ip address 10.10.10.2 255.255.255.252

description cisco huawei

exit

Configuración de la Interfaz de Gateway que conecta la red LAN Cisco

interface f0/1

ip address 20.20.20.1 255.255.255.0

exit

Configuración de EIGRP

router eigrp 1

eigrp router-id 2.2.2.2

network 20.20.20.0 0.0.0.255

exit

NOTA: En esta parte debo aclarar que se configura solo la dirección de red correspondiente a la LAN de Cisco ya que el enlace que comunica Cisco con Huawei está enrutado por OSPF, entonces EIGRP se utiliza como un protocolo de enrutamiento para rutas internas de modo que, todo el tráfico generado en la red LAN Cisco sea redistribuido a OSPF en el Router Cisco

Configuración de OSPF en Cisco

router ospf 1

router-id 2.2.2.2

network 10.10.10.0 0.0.0.3 area 0

exit

NOTA: como se mencionó en la nota anterior la red que se configurara en este router para OSPF es la red que conecta el enlace Cisco Huawei

LLEGO la Hora de Redistribuir Rutas

Configuración para decir a OSPF que Redistribuya EIGRP

router ospf 1

redistribute eigrp 1 subnets

exit

Configuración para decir a EIGRP que Redistribuya OSPF

router eigrp 1

redistribute ospf 1 metric 1 1 1 1 1

end

 

Enhorabuena ya tenemos una red con infraestructura Cisco y Huawei en total operatividad.

Para una información más detallada les invito a ver el siguiente video donde se realiza la configuración presentada en este post.

Redistribución OSPF EIGRP Cisco Huawei

 

@MichelyLopez 

2 Comentarios
Crear
Reconozca a un colega
Content for Community-Ad