annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 
cancel
Meddane
Rising star
Rising star

La redistribution de routes dans le domaine OSPF nécessite souvent l’ajout du mot clé « subnets », si on l’omet, seuls les réseaux par classe (/8, /16, /24) seront redistribués, par conséquent sans le mot clé « subnets », si nous avions par exemple une route 182.168.1.0 /29, elle ne serait pas redistribuée). Le scenario suivant montrera son effet lors de la redistribution.

Dans cette topologie nous avons deux domaines de routage composés d’OSPF et EIGRP, R2 est chargé d’injecter les routes provenant d’EIGRP dans OSPF.

OSPF1.PNG

Voici La configuration de la redistribution sur R2 sans le mot clé « subnets »:

R2(config-router)#router osp 1

R2(config-router)#redistribute eigrp 100

Ci-dessous R3 annoncera trois réseaux: 192.168.1.0/24, 172.16.0.0/16 et 10.0.0.0/8.

R3(config-if)#interface Lo0

R3(config-if)# ip address 192.168.1.1 255.255.255.0

R3(config)#interface Lo1

R3(config-if)#ip add 172.16.1.1 255.255.0.0

R3(config)#interface Lo2

R3(config-if)#ip add 10.0.0.1 255.0.0.0

R3(config)#router eigrp 100

R3(config-router)#network 23.0.0.0

R3(config-router)#network 10.0.0.0

R3(config-router)#network 172.16.0.0

R3(config-router)#network 192.168.1.0

R3(config-router)#no auto-summary

Constatons le résultat au niveau de la table de routage de R1. R1 a connaissance des routes externes:

OSPF2.PNG

 Maintenant, on supprime les adresses configurées précédemment sur Lo0, Lo1 et Lo2 et on les

          reconfigure avec respectivement les adresses IP 192.168.1.1/27, 172.16.1.1/24, 10.1.1.1/30 :

R3(config)#int range lo0-2

R3(config-if-range)#no ip add

R3(config)#int lo0

R3(config-if)#ip add 192.168.1.1 255.255.255.224

R3(config)#int lo1

R3(config-if)#ip add 172.16.1.1 255.255.255.0

R3(config)#int lo2

R3(config-if)#ip add 10.1.1.1 255.255.255.252

Voyons le résultat sur R1, il ne reçoit pas les réseaux externes :

OSPF3.PNGOSPF4.PNG

Vérifions la table de routage de R2, les routes vers 192.168.1.0/27, 172.16.1.0/24 et 10.0.0.0/30 sont bel et bien présentes mais il ne les injectera pas à cause de l’omission du mot clé « subnets »

OSPF5.PNG

Ajoutons le mot clé « subnets » dans la commande redistribute :

R2(config)#router ospf 1

R2(config-router)#redistribute eigrp 100 subnets

Puis vérifions la table de routage de R1, maintenant il a connaissance des routes externes :

OSPF6.PNG

 

 

Mise en Route
Bienvenue dans la Communauté !

La communauté est un hub pour vous connecter avec vos pairs et les spécialistes Cisco, pour demander de l'aide, partager votre expertise, développer votre réseau et évoluer professionnellement.
Vous êtes un nouvel arrivant ? Cliquez ici pour en savoir plus.

Nous voulons que votre navigation soit la meilleure, donc vous trouverez des liens pour vous aider à être rapidement familiarisé avec la Communauté Cisco :