cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
425
Views
2
Helpful
12
Replies
Beginner

TermConnActiveEv doesn´t fire when hold call

I have this scenario:

2 phones (A and B) from the same user with same DN in both phones

When receive a call, both ring and answer in phone A and hold call on A.

Until CUCM 7.1.5  after receive CallCtlTermConnHeldEv for phone A I receive TermConnActiveEv for Phone B.

For CUCM 8.6.2 and 10.0 I only receive CallCtlTermConnHeldEv for phone A.

Is this right or I'm missing some configuration?

I need TermConnActiveEv to complete transfer from phone A to B using an application.

I'm searching for a while and I don't find another way of doing such transfer, any ideas?

Thanks in advance

Nuno Magalhães

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: TermConnActiveEv doesn´t fire when hold call

Solved!

The problem was in privacy of phones, have to be turned off.

12 REPLIES 12
Contributor

Re: TermConnActiveEv doesn´t fire when hold call

Hi Nuno,

Pls make sure that both phones are added in CUCM application user configured for application.

Regards,

Umesh

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

yes, they are both associated with the application user.

Contributor

Re: TermConnActiveEv doesn´t fire when hold call

I am getting both event in my 8.6 setup, see below logs -

CallID: 17023/1 ::  Event: CallCtlTermConnHeldEv : Terminal: SEPB4A4E329391B :: CurrentCalledAddress: 2010 :: CurrentCallingAddress: 2000 :: No LastRedirectedPartyAddress :: Cause : CAUSE_NORMAL :: CallCtlCause: CAUSE_NORMAL :: CiscoCause: CAUSE_NOERROR :: CiscoFeatureReason: REASON_NORMAL :: CiscoEvent: No Cisco Event Found

CallID: 17023/1 ::  Event: TermConnActiveEvent : Terminal: SEP24B6FD238970 :: CurrentCalledAddress: 2010 :: CurrentCallingAddress: 2000 :: No LastRedirectedPartyAddress :: Cause : CAUSE_NORMAL :: No CalLCtlCause :: CiscoCause: CAUSE_NOERROR :: CiscoFeatureReason: REASON_NORMAL :: CiscoEvent: No Cisco Event Found

Regards,

Umesh

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

Umesh,

I'm using a simple jtapi application that only prints all the events and I don't receive TermConnActiveEv, its probably some configuration that is missing.

Where I can see the logs that you show on last post? to see if the event appears on these logs.

Contributor

Re: TermConnActiveEv doesn´t fire when hold call

Above logs I have collected using Cisco TestTool. You can download from Cisco developer site.

Regards,

Umesh

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

Can you please give me the link to the Cisco TestTool? i can't find the tool in Cisco developer site

Contributor

Re: TermConnActiveEv doesn´t fire when hold call

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

I receive the same events as you in the cisco test tool:

CallID: 26151/1 :: Event: CallCtlTermConnHeldEv : Terminal: SEP0019552CB942 :: CurrentCalledAddress: 1002 :: CurrentCallingAddress: 1000 :: No LastRedirectedPartyAddress :: Cause : CAUSE_NORMAL :: CallCtlCause: CAUSE_NORMAL :: CiscoCause: CAUSE_NOERROR :: CiscoFeatureReason: REASON_NORMAL :: CiscoEvent: No Cisco Event Found

CallID: 26151/1 :: Event: TermConnActiveEvent : Terminal: SEP0019E8925A09 :: CurrentCalledAddress: 1002 :: CurrentCallingAddress: 1000 :: No LastRedirectedPartyAddress :: Cause : CAUSE_NORMAL :: No CalLCtlCause :: CiscoCause: CAUSE_NOERROR :: CiscoFeatureReason: REASON_NORMAL :: CiscoEvent: No Cisco Event Found

CallID: 26151/1 :: Event: CallCtlTermConnHeldEv : Terminal: SEP0019E8925A09 :: CurrentCalledAddress: 1002 :: CurrentCallingAddress: 1000 :: No LastRedirectedPartyAddress :: Cause : CAUSE_NORMAL :: CallCtlCause: CAUSE_NORMAL :: CiscoCause: CAUSE_NOERROR :: CiscoFeatureReason: REASON_NORMAL :: CiscoEvent: No Cisco Event Found

But on the jtapi application I don't receive TermConnActiveEvent  for the second phone. I confirmed and I'm using the correct jtapi.jar, i can't understand what's wrong...

One more thing, if I use jtapi from cucm 7.1.5 I receive all the events

Highlighted
Contributor

Re: TermConnActiveEv doesn´t fire when hold call

I am getting same events in applications also

[Mon May 12 17:04:13.985 IST 2014][V][callChangedEvent][CallCtlTermConnHeldEv SEPB4A4E329391B]

[Mon May 12 17:04:13.991 IST 2014][V][callChangedEvent][TermConnActiveEv SEP24B6FD238970]

[Mon May 12 17:04:13.997 IST 2014][V][callChangedEvent][CallCtlTermConnHeldEv SEP24B6FD238970]

what kind of phone u r using SCCP/SIP and what type of groups u have added in ur CUCM app user?

there is no special impl in code for this.,

regards,

Umesh

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

I´m using SCCP Phones.

app user have this gruoups:

Standard CCM Super Users

Standard CTI Allow Call Monitoring

Standard CTI Allow Call Park monitoring

Standard CTI Allow Call Recording

Standard CTI Allow Control of All Devices

Standard CTI Enabled

Standard CTI Secure Connection

Standard EM Authentication Proxy Rights

but if I use jtapi from cucm 7.1.5 I receive all the events...

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

I tried with jtapi.jar that comes with Cisco TestTool for CUCM 8.6.1 and i received all events.

Is this a bug of jtapi that comes with CUCM 8.6.2?

Beginner

Re: TermConnActiveEv doesn´t fire when hold call

Solved!

The problem was in privacy of phones, have to be turned off.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards