cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
266
Views
5
Helpful
1
Replies
jcockburn
Beginner

2960X interfaces intermittent disconnects in stack - "no power efficient-ethernet"

Hi All,

We have this weird issue which I solved by using "no power efficient-ethernet" under the problematic interfaces.

 

Issue:

Interfaces in a 2960X stack keeps on disconnecting and connecting every (approx) 2 secs. Nothing else in the logs...

 

=====logs=====

010361: Jun 4 2020 11:03:34.189 NZST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/14, changed state to down
010362: Jun 4 2020 11:03:35.192 NZST: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/14, changed state to down
010363: Jun 4 2020 11:03:37.664 NZST: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/14, changed state to up
010364: Jun 4 2020 11:03:37.664 NZST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/14, changed state to up
=============

 

I played around with port-security - nothing...

Then I scratched around with power settings....and when I added "no power efficient-ethernet" under the interfaces, it stopped and users could connect as normal...

 

Weird things is:

- This only happened recently after about a month that we upgraded to 15.2(7)E0a.

- It only happened on switch #2 on a stack of 3 2960X's

- If you look at the output of the "show run all" command, which shows all the default values for the config as well, you do not see that command at all....on afterwards you see the "no" version added...

 

Anyways, hopefully this could help someone, or someone could comment if this is a bug or 'feature'...

 

Happy networking

1 ACCEPTED SOLUTION

Accepted Solutions
jcockburn
Beginner

Hi All,
update...this seems to be related to CSCus35889 as I suspected ;-)
Basically there is no fixed release and the way to get it fixed is to disable EEE under the interface:
switch-2960X(config-if)#no power efficient-ethernet

Hope this helps someone.
Ciao





View solution in original post

1 REPLY 1
jcockburn
Beginner

Hi All,
update...this seems to be related to CSCus35889 as I suspected ;-)
Basically there is no fixed release and the way to get it fixed is to disable EEE under the interface:
switch-2960X(config-if)#no power efficient-ethernet

Hope this helps someone.
Ciao





View solution in original post