cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
97
Views
0
Helpful
0
Replies
Highlighted
Beginner

CSCdp72526 - redistribute bgp routes showing in OSPF databse not showing in routing table

Hi,

I am having a weird Issue. Appreciate if someone could please help me out. I am using WS-C4500X.

Topology:

R3 has BGP peering with DC1SW1 in VRF -Orange

There are 3 VRF configured on DC1SW1 –

  1. Orange
  2. B1
  3. F1

There are 2 VRF configured on DC2SW1

  1. B1
  2. F1

B1 VRF between DC1SW1 and DC2SW2 connected via OSPF through link 1

F1 VRF between DCSW1 and DC2SW1 via bgp

Now the goal is to reach from R2 B1 VRF to Orange VRF prefix. I redistributed BGP route in ospf in DC1SW1 under ospf process and OSPF into BGP.

I can get the redistributed prefix into OSPF Database on both DC1SW1 and DC2SW2 but not in ospf routing table and ultimately cant reach any Orage prefix from DC2.

 

Configuration:

DC1SW1:

###############

###############

ip vrf F1

description F1

rd 2:1

route-target export 2:1

route-target import 2:1

route-target import 3:3

route-target import 3:1

!

ip vrf B1

description B1

rd 2:2

route-target export 2:2

route-target import 2:2

route-target import 3:3

route-target import 1:1

 

ip vrf Orange

rd 1:1

route-target export 1:1

route-target import 1:1

route-target import 2:1

route-target import 2:2

 

router bgp 2

bgp router-id 129.2.2.2

bgp log-neighbor-changes

!

address-family ipv4

bgp redistribute-internal

exit-address-family

!

address-family ipv4 vrf B1

redistribute connected route-map B1-con-pre

redistribute static route-map B1-adv-pre

redistribute ospf 2 match internal external 1 external 2 route-map O2B

exit-address-family

!

address-family ipv4 vrf F1

network 10.133.1.84 mask 255.255.255.255

network 129.9.4.0 mask 255.255.248.0

network 129.9.8.0 mask 255.255.252.0

network 1.5.1.0 mask 255.255.252.0

redistribute connected

neighbor 10.224.252.2 remote-as 3

neighbor 10.224.252.2 description DC2SW1 VRF F1

neighbor 10.224.252.2 update-source Vlan501

neighbor 10.224.252.2 activate

neighbor 10.224.252.2 soft-reconfiguration inbound

!

address-family ipv4 vrf Orange

redistribute connected

neighbor 10.240.9.1 remote-as 1

neighbor 10.240.9.1 update-source Vlan106

neighbor 10.240.9.1 activate

neighbor 10.240.9.1 soft-reconfiguration inbound

exit-address-family

 

 

 

route-map B2O permit 10

set tag 2

!

route-map O2B deny 10

match tag 2

!

route-map O2B permit 20

 

#######OSPF######

router ospf 2 vrf B1

 router-id 10.224.252.5

 redistribute static subnets

 redistribute bgp 2 subnets route-map B2O

 passive-interface default

 no passive-interface Vlan502

 network 10.224.252.4 0.0.0.3 area 0

 network 0.0.0.0 255.255.255.255 area 0

!

 

OSPF Output :

 

sh ip os 2 da

 

Link ID         ADV Router      Age         Seq#           Checksum           Tag

10.240.1.0     10.224.252.5    126         0x8000000C     0x00CC87     2

10.240.9.0     10.224.252.5    126         0x8000000C     0x0062EC     2

10.240.10.0     10.224.252.5    126         0x8000000C     0x0069E1     2

10.240.11.0     10.224.252.5    128         0x8000000C     0x005EEB     2

10.240.12.0     10.224.252.5    128         0x8000000C     0x0053F5     2

10.240.13.0     10.224.252.5    128         0x8000000C     0x0048FF     2

10.240.14.0     10.224.252.5    128         0x8000000C     0x003D0A     2

10.240.15.0     10.224.252.5    128         0x8000000C     0x003214     2

10.240.20.0     10.224.252.5    128         0x8000000C     0x00FA46     2

10.240.21.0     10.224.252.5    128         0x8000000C     0x00EF50     2

10.240.22.0     10.224.252.5    128         0x8000000C     0x00E45A     2

Redistributed prefix not in OSPF routes

sh ip rou vrf B1 os

 

      10.0.0.0/8 is variably subnetted, 37 subnets, 6 masks

O E2     10.115.249.80/28 [110/20] via 10.224.252.6, 16:41:52, Vlan502

O       10.115.249.96/28 [110/2] via 10.224.252.6, 16:41:52, Vlan502

O E2     10.224.200.0/23 [110/20] via 10.224.252.6, 16:41:52, Vlan502

 

DC1SW1# sh ip route vrf B1 10.240.1.0

 

Routing Table: boh

Routing entry for 10.240.1.0/24

  Known via "bgp 2", distance 20, metric 0

  Tag 31898, type external

  Redistributing via ospf 2

  Advertised by ospf 2 subnets route-map B2O

  Last update from 10.240.9.1 7w0d ago

  Routing Descriptor Blocks:

  * 10.240.9.1 (oci), from 10.240.9.1, 7w0d ago

      Route metric is 0, traffic share count is 1

      AS Hops 1

      Route tag 1

      MPLS label: none

 

 

DC2SW1:

###############

###############

router bgp 3

 bgp router-id 140.3.3.1

 bgp log-neighbor-changes

 !

 address-family ipv4 vrf F1

  network 10.133.1.84 mask 255.255.255.255

  redistribute connected

  neighbor 10.224.252.1 remote-as 2

  neighbor 10.224.252.1 description DC1SW1

  neighbor 10.224.252.1 update-source Vlan501

  neighbor 10.224.252.1 activate

  neighbor 10.224.252.1 soft-reconfiguration inbound

exit-address-family

 

router ospf 2 vrf B1

 router-id 10.224.252.6

 redistribute connected subnets

 redistribute static subnets

 passive-interface default

 no passive-interface Vlan502

 network 10.224.252.4 0.0.0.3 area 0

 network 0.0.0.0 255.255.255.255 area 0

!

DC2SW1

 

sh ip os 2 da

 

Link ID         ADV Router      Age         Seq#           Checksum     Tag

10.240.1.0     10.224.252.5    404         0x8000000C 0x00CC87     2

10.240.9.0     10.224.252.5    404         0x8000000C 0x0062EC     2

10.240.10.0     10.224.252.5    404         0x8000000C 0x0069E1     2

10.240.11.0     10.224.252.5    404         0x8000000C 0x005EEB     2

10.240.12.0     10.224.252.5    404         0x8000000C 0x0053F5     2

10.240.13.0     10.224.252.5    404         0x8000000C 0x0048FF     2

10.240.14.0     10.224.252.5    404         0x8000000C 0x003D0A     2

10.240.15.0     10.224.252.5    404         0x8000000C 0x003214     2

10.240.20.0     10.224.252.5    404         0x8000000C 0x00FA46     2

10.240.21.0     10.224.252.5    404         0x8000000C 0x00EF50     2

10.240.22.0     10.224.252.5    404         0x8000000C 0x00E45A     2

 

 

 

DC2SW2#sh ip rou vrf B1 10.240.1.0

 

Routing Table: B1

% Subnet not in table

 

Orange prefixs are in F1 vrf in DC2SW1 .  

Any idea why DC1SW1 not installing redistributed bgp routes into OSPF

 

Note: I truncated few outputs and Naming and prefixes for security reason  

Capture.PNG

 

 

 

This widget could not be displayed.