Showing results for 
Search instead for 
Did you mean: 

DNAC GUI not working

Level 1
Level 1

Hi !


We have installed a DNA center 2 years ago that has been working well since then. However, since a few days, GUI is not reachable anymore (timeout on my browser)


I can ping its IP address and there is no firewall between my source IP address and DNA center GUI IP address. When I try to telnet the IP address on port 443, it says that the connection is refused by remote host which means that the flows are not blocked by any firewall on the path for me.


We tried to reboot the appliance but it did not change anything.


I can connect to maglev CLI. What command should I use to check the health of DNAC GUI ?


Do you have any idea of what could be the cause of my problem ?

Thank you very much for your help !










5 Replies 5

VIP Alumni
VIP Alumni

I can connect to maglev CLI. What command should I use to check the health of DNAC GUI ?

-For starters are you able to run the following and get returned output with statuses?  $ magctl appstack status

Hi Mike !


Thank you for your answer. You will find attached the result of this command. I can see that the services are up since almost a year. They might not have reboot the right appliance...


What do you think we should do ?

Thank you !





Hello Mike,

For startes, thanks for replying.

I have the same problem but im not able to run the command mentioned:
"magctl appstack status"


I get the following back:
$ maglev appstack status
Invalid command 'appstack', run maglev --help

Do you have any idea`s?

Also forme, evrything worked fine when i used DNAC last week. Today i try to login and im not able to use the gui, but CLI works.
Checking acl`s en firewall rules i see that evrything is permitted

VIP Alumni
VIP Alumni

Interesting.  I honestly thought I would see some hung pods via that output based on your issue.  

FYSA: To check for hung pods & manually kill them:

$ magctl appstack status | grep 0/

*The hung terminating pod will be depicted as 'Null' in GUI OR 'terminating' via CLI. Pay attention to the unique ID string so you terminate the right one. Using this command/example:

$ magctl service kill kong-775f685fdb-8ccbz 


Once done after a couple of minutes there should no longer be hung pods.  To verify:
$ magctl appstack status | grep 0/ 


A few notes that may aide with future tshooting:

To halt the appliance, enter: $ sudo shutdown -h now
To initiate a warm restart, enter: $ sudo shutdown -r now


I would recommend working with TAC.  They will want a support bundle ($ sudo rca) uploaded to case.  Good luck.

Level 1
Level 1

I have had this issue multiple times and it stemmed from 2 different issues.

1. Update- We updated and there was a bug in the code that did not allow gui access, cisco had to install some root patch

2. BUG and memory issues- We had a memory bug as well as memory issues where it would consume all the memory and swap memory which resulted in us having to reboot the appliance. We did a couple of hard reboots from the CIMC to resolve the issue until we could work with TAC to resolve memory issues. When the appliance starts to have memory issues you will also see that commands don't function correctly in the cli using maglev.