cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
408
Views
0
Helpful
3
Replies

DNAC PnP provision new Cisco 9800-L WLC issue during claim process-P2

samteo
Level 1
Level 1

Dear all,

i have Cisco DNAC Center version running Version 2.3.5.4-70852 and continuing to provision new device via Plug and Play option in DNAC center.

 

After assigning new device (C9800-L)  to site and now able to enter information for.... Wireless management IP, subnet mask, gateway IP information and assigning interface option as 'Tw0/0/0' successfully and then click Next button. i can now proceed to Summary page in DNAC. 

However, at Summary page, the error message appears 'Error Code: NCWS20028' and Failure reason: PNP claim failed: CLI/SNMPV2 (read/write) or SNMPv3 credentials not found at Site: WLC. See attached screenshot error.

Previously, i understand that without any user credentials, Cisco DNAC should be able to claim new device first and then add the config template with credential later on...

At this moment, i am unable to proceed to claim new device WLC9800.

Do let me know if you come across similar issues, thanks for any information in advance.

Thanks /Sam

claim device error.png

 

 

1 Accepted Solution

Accepted Solutions

Thanks @Torbjørn ...i will review further.

View solution in original post

3 Replies 3

Torbjørn
Spotlight
Spotlight

I must admit that I haven't tried to provision a device without specifying credentials before, but I believe it would be required as the credentials are used by the Catalyst Center for various tasks after device has been onboarded. Your error message also suggest that it is required.

The user guide says this specifically regarding credentials while doing pnp onboarding:

"We recommend that you define the device credentials (CLI and SNMPv2c/SNMPv3) for the devices you are deploying. If you are using SNMPv2c, both Read and Write credentials must be provided.

Missing credentials will lead to the devices not being able to be added to inventory after they are provisioned."

https://www.cisco.com/c/en/us/td/docs/cloud-systems-management/network-automation-and-management/dna-center/2-3-5/user_guide/b_cisco_dna_center_ug_2_3_5/m_onboard-and-provision-devices-with-plug-and-play.html

Happy to help! Please mark as helpful/solution if applicable.
Get in touch: https://torbjorn.dev

Thanks @Torbjørn ...i will review further.

Hi @Torbjørn thanks issue is resolved and now able to claim new device. Yes, to share that it'll require both the SNMPv3 credential and CLI credentials to be assigned to the site hierarchy as well. Thanks! 

refer to attached screenshot

claim  successful-1.png