cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
37016
Views
0
Helpful
10
Replies

CSR 1000v in Vmware Esxi, can't ping in / out

oliverlag
Beginner
Beginner

Hello, 

I've just installed from ova file a CSR 1000V in my personal lab into an ESXi. 

I followed this link:

http://www.fryguy.net/2013/12/27/cisco-csr1000v-for-home-labs/

I do have an interface Giga 1 in default vlan with adapter type VMXNET3 as it's suggested. 

Whenever I turn on the CSR I configure the interface and I unshut it. Negotiation is auto (I tried to hard link it but w/o success). 

Problem is that from my pc I can't ping the giga1 CSR interface and viceversa. But on both side I see the arp of the interface. 

I tried to change adapter type on vmware (VMXNET2 or E1000) but with no help.. 

If I turn on a debian or Windows VM on the same nic card on the same vlan I can ping it or reach it. 

I've tried to debug the ip packets but nothing shows up some issues.

Config is a default one... there are no acls, not security features, nothing.. just an ip address on the giga1 and the no shut command. 

What could be? 

Thanks in advance

1 Accepted Solution

Accepted Solutions

j.huizinga
Frequent Contributor
Frequent Contributor

Hi,

Can tell you that this was indeed the problem.

I have ESXi 5.5.0 3116895 and I have installed CRS1000V 3.17 and it works perfectly

Bye

View solution in original post

10 Replies 10

j.huizinga
Frequent Contributor
Frequent Contributor

Did you ever find out what was the problem?

JH

nope.. but it was not the CSR. I got the same problem with other VMs (linux or win) in the same vlan on the same cable. At the same time (same vlan, same cables) other VMs were working.. No idea what it was.. Still not resolved btw

j.huizinga
Frequent Contributor
Frequent Contributor

Well maybe I found the issue. I have ESXi 5.5 with update 3 ,and it seems that CSR1000V 3.15 is not supported, it needs 3.16

In the past it was working with 3.13 and ESXi 5.0

So I shall install 3.16 tomorrow, and that should work, at least it is supported

Thanks for your reply

Jan

Jan, please let me know.. 

I put that CSR in stand-by but if that update fixes the issue I will give it a try again.

Thanks!

j.huizinga
Frequent Contributor
Frequent Contributor

Hi,

Can tell you that this was indeed the problem.

I have ESXi 5.5.0 3116895 and I have installed CRS1000V 3.17 and it works perfectly

Bye

Hi J. huizinga,

                         I did try myself with the eESXi 5.5.0 3116895 together with the exact image you provided but i was still unable to ping from the virtual machine to the CSR1000v sub-interface, please can someone explain the reason why is behaving this way.

Thank you

Ben

This problem typically looks like a vmware issue, i did some testing from my physical machine to my virtual csr1000v routers and all pings were successful without a single drop but as soon as I issued pings from the virtual windows 7 machine the pings fails. On the otherhand, if you add the native command to the sub-interface on the csr1000v everything start working which to me defeat the whole purpose of the tagging protocol in vmware.

Eg.

interface gig1.13

encapsulation dot1q 13

ip add 155.1.13.1 255.255.255.0

no shut

!

!

with this command on the csr1000v all pings works without any issue with the exception of the virtual machines.

on the later part:

int g1.13

encapsulation dot1q 13 native

ip address 155.1.13.1 255.255.255.0

no shut

!

!

with this command the vm's will be able to communicate with the csr1000v and if this happens you have add native to all the sub-interfaces you will create for all your topology. Any suggestion or solution or critics will be welcome.

Thank you

Ben

This are the csr1000v and the VM windows 7 screen captures I did for the testing.

I can confirm this solution. 

I was using a CSR1000v 3.13.00 on ESXi 5.5U3.  Ping from VM to VM (or CSR to CSR) would not work.  CDP did not work. 

Oddly, 3.13.00 works perfectly fine on ESXI 6.0U3. 

I tried both CSR1000v 3.16 and 3.17 on ESXi 5.5U3, and pings and CDP works.  This certainly indicates a VMware issue of some type or an odd compatibility issue. 

Version 3.13 is desired for the lab environment due to only consuming 2.5 Gb of RAM per instance of the CSR.  3.16 and 3.17 both request 4 Gb.

It becomes a question of what version of ESXi you are on.  6.0U3 works.

guilherme.niza1
Beginner
Beginner

I Finally Found the issue,

 

on Vmware host > Configuration > Networking > choose the vSWITCH properties, and there see the port group properties. It may show you the VLAN ID option, choose all. Worked for me today.

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers