Showing results for 
Search instead for 
Did you mean: 

License EULA issue on CSR

Level 1
Level 1


I have installed the adv_50M paid subscription license on my CSR 1000v after the evaluation license expiry.

I have succeeded installing the license, but still the EULA is not showing as accepted for this paid subscription, while the evaluation license is.

I tried to clear the evaluation license, but the CSR throws error as below.

"% Error: No license entries with the feature name: prem_eval"

This CSR worked perfect during the evaluation period for IPSec VPN tunnels, but post installing the advanced license, the router is not initiating the negotiation.


AWS-CSR#sh license detail 

Index: 1 Feature: adv_50M                           Version: 1.0
License Type: Paid Subscription
Start Date:         N/A, End Date: Apr 01 2015
License State: Active, In Use
License Count: Non-Counted
License Priority: Medium
Store Index: 0
Store Name: Primary License Storage
Index: 2 Feature: prem_eval                         Version: 1.0
License Type: Evaluation
License State: Active, Not in Use, EULA accepted
   Evaluation total period: 8  weeks 4  days 
   Evaluation period left: 0  minute  0  second  
   Period used: 8  weeks 4  days 
License Count: Non-Counted
License Priority: Low
Store Index: 0
Store Name: Built-In License Storage
AWS-CSR# sh license EULA 
Feature name             EULA Accepted  
------------             -------------  
adv_50M                  n/a
prem_eval                yes
Could somebody help me with this? Any tips much appreciated
1 Reply 1

Cisco Employee
Cisco Employee

Hello Aneesh,

You can try with :

router(config)#license accept end user agreement

If it doesn't help try to remove and add the license again, reload the router in between , use commands in privileged mode, check context help for available options.

router#license clear
router#license purge
router#license remove
router#license install