Showing results for 
Search instead for 
Did you mean: 

**Deprecated - Nagios Plug-Ins for Cisco UCS - Deprecated**


This version of the UCS Manager Nagios Plug-In is deprecated because it used a deprecated Python SDK

The following Nagios Plug-Ins are available for download from Cisco:

Cisco UCS Manager Plugin Release 0.9.4 for Nagios:

Details on this Release

Downloads (deprecated - no support provided for the 0.9.4 release on current Nagios versions):

Download Cisco UCS Manager Plugin Release 0.9.4 for Nagios


User Guide for Cisco UCS Manager Plugin Release 0.9.4 for Nagios


Cisco IMC Plugin Release 0.9.3 for Nagios:

Details on this release


Download Cisco IMC Plugin Release 0.9.3 for Nagios


User Guide for Cisco IMC Plug-In Release 0.9.3 for Nagios

Also available on Nagios exchange:

Note: Support is available only through the Cisco Communities forum.

External customers - For any queries/feedback on Plugins for Nagios, add a discussion to the Cisco Developed Integrations sub-space on Cisco UCS Communities

Internal (Cisco) customers and employees - Contact us at for support questions and or for roadmap questions and feedback.

Cisco Employee

What legacy model is not working? What is the working model? SNS 35xx?

I was told told ISE appliances not supported so would like to learn if that changes since.


Community Member

Sorry... By legacy I meant old devices (installed since 2 years). I was able to make the plugin work with this command :

/usr/local/nagios/libexec/cisco_imc_nagios -u nagiosro --passEnc xxxxx -H -t dn -q sys/rack-unit-1  --useSharedSession  --port 443 --debug  (I removed the inHierarchical option).

Now I can my monitor all of my SNS-3495-K9

Cisco Employee

Are old UCS devices not SNS-3495-K9, then? SNS-3415-K9? ISE appliances are either SNS-34xx-K9 or SNS-35xx-K9. The latter is introduced only recently.

It's a nice surprise to learn you are able to use it with SNS-3495-K9.

Community Member

Why a surprise? SNS-3495-K9 is a rebranded C220 M3. I just modified the validation section within the python code and instead of getting an error message, the connection succeeded.

Community Member

What level of access does the user account need when entered in the following line?

#./ –H <hostname>  -u <username>   -p <password>

Also is this just for the initial autodiscovery or will an account need to have access the whole time?


Community Member

Hi Everyone.

Is 0.9.4 the latest and greatest for monitoring Cisco UCS with Nagios?  Also, we're trying to get it to work with XI.  Is there anything different in the setup?  When we use core, the auto-discovery works and populates the hosts and hosts groups.  When we try the same with XI the autodiscovery creates the config files but the hosts and hosts groups remaine empty.

Any help would be GREAT!





I've successfully deployed the plug-in in one site with Nagios XI.  I stumbled upon a similar issue discussed above with auto-discovery.  For me the solution was to populate the .cfg file rather than using command line parameters.

But I have a new problem.  I'm trying to implement the script in a second data center and I run into an error running  The error is stating that I don't have the prerequisite ucsmsdk installed.  But I do.  I'm able to launch python and import UcsHandle and login to my server.

What could be causing the python script to fail.  To find the particular failure location in the file, search for the error message:

"This Nagios plugin requires Ucs Python SDK to be installed before we can proceed further.

Download the latest Cisco Ucs Python SDK from the following URL"




This worked for me to change Nagios config entries for FI to NAME_fi_A instead of IP_fi_A:

Edit autodiscovery/

Around line 145 change:

            # key = mo.OobIfIp + "_fi_" + mo.Id

            key = self.ucs_ip + "_fi_" + mo.Id

Around line 154 change:

            # self.ucs_dict[key, 'host_ip'] = self.ucs_ip

            self.ucs_dict[key, 'host_ip'] = mo.OobIfIp

I also needed to apply prvashis's patch to allow for "ucs01.sub.dom.local" FQDN entries...

Note, this will create entries like "ucs01.sub.dom.local_fi_A" not "ucs01-A.sub.dom.local", but they will be sorted with other entries - which is good enough for what I needed...



Seeing that this has been deprecated, what is the new suggested direction? I'm not seeing a 0.9.5 version out... are there any plans to move forward with this plugin?


 " I run into an error running  The error is stating that I don't have the prerequisite ucsmsdk installed.  But I do.  I'm able to launch python and import UcsHandle and login to my server."


Software Requirements for Release 0.9(4): This release of the plugin requires Python SDK 0.8.3 to communicate with UCS Manager.

CreatePlease to create content
This widget could not be displayed.