cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1508
Views
0
Helpful
4
Replies
jimstehlik
Beginner

UCS Emulator 2.1.1aPE3 + UCS PowerTool Script + Firmware Update Testing

Hello All,

I'm using the latest version of the emulator.  I have successfully imported my production configuration and I would like to test our planned firmware upgrade to 2.1 (1f) and I am running into a problem.  For whatever reason, the emulator will not import the bin files.  I am using the attached PowerTool script.  In the PowerTool window, it shows a 404 error, so I tried from within the emulator to upload the bin files as you would during a manual upgrade and that is when I discovered that the emulator is preventing this operation.  Is this a glitch or is there a step or something that I am missing for this to work properly?

Please advise.

Thank you,

Jim

1 ACCEPTED SOLUTION

Accepted Solutions
ericwill
Cisco Employee

James:

UCSPE doesn't support importing Binary backups.  It only supports XML based backups (config-all, etc). to be imported into UCSPE.  The underlying infrastructure NXOS normally provides to import the binary backups isn't present in UCSPE, hence the lack of support.

Thanks,

Eric    

View solution in original post

4 REPLIES 4
ericwill
Cisco Employee

James:

UCSPE doesn't support importing Binary backups.  It only supports XML based backups (config-all, etc). to be imported into UCSPE.  The underlying infrastructure NXOS normally provides to import the binary backups isn't present in UCSPE, hence the lack of support.

Thanks,

Eric    

View solution in original post

Eric,

I appreciate your answer and understand that the underlying component is not present.

I need to go back to my session notes from Cisco Live because I thought either I had asked this question during one of the sessions or maybe after one, but the answer was a different and implyed that you could use the emulator to test a firmware upgrade.  It is quite possible I wrote the response incorectly, but I will know for sure once I double check my notes.

Thank you,

Jim

You can use UCSPE to drive the server portion of the upgrade by using either Host Firmware Packs, or using Firmware Auto-install for Servers, not the UCSM / Fabric interconnect upgrade process.  Today, you can only import the XML based configuration backups from a real system into UCSPE.  I apologize if you were led to believe something different, or were misunderstood here, but this is what is supported today.  UCSPE can not have UCSM, fabric interconnect or IOM firmware upgrade process performed on it.  It is something we could potentially add in a future release of UCSPE, but isn't present on any current or past UCSPE release.

Eric,

Sorry, forgot to login on the other one.

Not a problem.  I was learning a ton the whole week.  So, as I eluded to above, I could have heard wrong or maybe was adding more into the capabilities because Of something I was looking for in it.

Thanks again,

Jim

Content for Community-Ad
This widget could not be displayed.