Showing results for 
Search instead for 
Did you mean: 

Cisco DNA LAN Automation



I am trying to use LAN automation from DNAC and discover the devices connected to my seed and peer seed devices. The IS-IS config and other necessary part is done for seed and peer-seed but for the downlink connection to the PnP agent device(9300 switch) which has to be LAN automated, it acquires the DHCP IP from the temporary VLAN 1 DHCP pool but later is stuck into "Autoinstall trying DHCPv6 on Vlan1" this prompt. For another set of 4500-X switches, they don't go even till the DHCP. The setup is for lab demo, routing is good and the IP pool is reachable to the DNAC as I have tried testing it by assigning one of the IP to a SVI on my seed as mentioned in the LAN Auto Cisco document.

Any one faced similar issue or can someone help here!!

Thanks in advance!

3 Replies 3


4500-X are not supported devices.

For the 9300 did you ever stopped the LAN Automation? IS-IS configuration is done through the process of stopping the LAN Automation.

Do you mean not supported for LAN automation? Because 4500-x are supported for SDA and I am trying to use it as Intermediate nodes. For 9300, it is working for me now and I had something wrong with the routing but its fixed now.

This device is supported but still stuck in the same process where 4500-X is stuck in error state when checked in DNAC GUI PnP menu. Also, TAC provided relevant commands equivalent to "pnpa service reset" along with deletion of crypto trustpoint was also tried but still no luck.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers