cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco DNAC 1.3 not showing any clients

Skjoedt
Beginner
Beginner

Hello

I am using Cisco DNAC 1.3.1.6 to do studies for CCIE Wireless.
- The Lab uses 1.3.1.3...

When I integrate with CMX 10.6.2-57, sometimes my clients show up on the map in DNAC and sometimes not.
When the clients don't show up on the map in DNAC, then it seems like it's because DNAC doesn't see any clients at all...
- But my clients ALWAYS! show up in Detect & Locate on the CMX, that part always works...

Does anybody have an idea as to why this is happening? Is it a bug?

Best Regards
Frederik

2 REPLIES 2

Tomas de Leon
Cisco Employee
Cisco Employee

You mention that you are running:

  • Cisco DNA Center version 1.3.1.6
  • CMX Version 10.6 (incomplete version information)

Note: What version of CMX are you running?

 

  • Possible Workaround of your issue.
You can try the following commands on the CMX Console or via SSH:

cmxctl stop location
cmxctl start location

 

 Please Refer to the following:

Cisco DNA Center - Release Notes
https://www.cisco.com/c/en/us/support/cloud-systems-management/dna-center/products-release-notes-list.html

 

Release Notes for Cisco DNA Center, Release 1.3.1.x

https://www.cisco.com/c/en/us/td/docs/cloud-systems-management/network-automation-and-management/dna-center/1-3-1/release_notes/b_cisco_dna_center_rn_1_3_1.html

 

Support for Cisco Connected Mobile Experiences
----------------------------------------------
Cisco DNA Center supports Cisco Connected Mobile Experiences (CMX) 10.6.2.
Earlier versions of CMX are not supported.

Note: While configuring the CMX settings, do not include the # symbol in
the CMX admin password. The CMX integration fails if you
include the # symbol in the CMX admin password.

 

!EDIT! After changing my client back and forth between fabric and non-fabric and doing this/waiting for 45-60min, the client has suddenly appeared on the map in DNAC while connected to the non-fabric and non-provisioned AireOS WLC...

Hello Tomas

Thank you for getting back to me
I am running CMX 10.6.2-57, just like in the CCIE Lab.
- I have updated my original post with the complete version number now...

I have now tried to stop and start the location service, without any luck...
I have even tried to disconnect and re-connect several times to "provoke" updates, but my client is still only visible in CMX and not in DNAC.

A strange detail is that i am not seeing any clients in DNAC, despite being connected to an AP, which i have just placed on the map i am looking at...
So far today i have had 1 time where i could successfully see my client on the map in DNAC and 2x "builds"/lab runs, where i could not see my client on the map in DNAC.

I have been testing with a non-fabric and non-provisioned AireOS WLC, which is only in DNAC because of location.

I have also tried to provision a 9800-CL with CMX and then connect my client via Fabric, which didn't change the results unfortunately i still can only see my client in CMX Detect & Locate, but only sometimes in DNAC despite being connected via Fabric...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: