cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
522
Views
5
Helpful
5
Replies
angelest
Beginner

DNAC and ISE integration assistance

I'm setting up our DNAC lab. We are trying to integrate ISE into DNAC but we hit some issue that we cant figure out why.

DNAC version 1.3.1.0

ISE version 2.7.0.356 (VM)

 

Issue:

@ISE:

ISE is active on DNAC (LAB_DNAC) on ISE under PXgrid it creates 2 new entries as below

lab_dnac_ndp shows online

lab_dnac        shows offline (Capabilities(0 Pub, 0 Sub)   )   

 

@DNAC:

Shows both Primary and PXgrid available.

 

Also not seeing any SGT's into our DNAC.

I'm a newbie in DNAC thus appreciate any help.

DNAC-ISE.jpg

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Damien Miller
VIP Advisor

I would recommend upgrading your DNAC, but take a look at the "web clients" tab of the ISE pxgrid page. DNAC uses pxg v2 as you pointed out, xmpp is actually for pxg v1. I looked in my lab and the pxg v1 xmpp client entries for dnac is also offline for me, but the web client is "on". My lab is working as expected. 

View solution in original post

5 REPLIES 5
Damien Miller
VIP Advisor

I would recommend upgrading your DNAC, but take a look at the "web clients" tab of the ISE pxgrid page. DNAC uses pxg v2 as you pointed out, xmpp is actually for pxg v1. I looked in my lab and the pxg v1 xmpp client entries for dnac is also offline for me, but the web client is "on". My lab is working as expected. 

View solution in original post

Hi Damien,

Appreciate your help. I dont see any web entry in Web Clients under PXgrid. WIll try to upgrade DNAC to 1.3.3.9 and patch ISE to patch 2 of version 2.7

Hi Damien,

I upgraded DNAC to Version 1.3.3.9 and ISE to 2.7.0.356 patch 3.

I can see SGT groups and policies becomes synchronize to ISE when I created this at DNAC.

Just want to confirm since in ISE still it shows offline. Is this an expected behavior?DNAC-ISE2.jpg

Thanks and appreciate your help.

Mike.Cifelli
VIP Advocate

I am currently running a 2.1.2.5 cluster in a production environment & I have the same scenario.  As @Damien Miller mentioned, as long as your web client appears as ON you should have no issues with sharing data between ISE/DNAC via the pxv2 connection.  To speak to your question, this is expected behavior AFAIK.  Not 100% sure if Cisco has it roadmapped to remove the pxv1 subscribers to aide in eliminating confusion.  HTH!

angelest
Beginner

Thank you