cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
507
Views
10
Helpful
2
Replies
Tala_Ali
Beginner

Dnac onboarding templates configuration

Hello everybody, 

 

I tried to deploy my access switch using PnP 0-day provision. I prepared my template using Cisco Guide i make 0-day provision; 

 

All things are happend as expected : 

 

* PnP descovery and all PnP opération, connectivity

* Image update, template provision

* Credantials, vlans configuration and shared services. 

Now the directed interface connected to the upstream device is configured as expected, but the other interfaces where i had specify either Trunk or access are not configured. 

When i issue show run interface or th Sh inter g1/0/X command i find the following default congifuration ( same for all interfaces except for the uplink interface where the managed device is connected forwword DNA Center) : 

 

interface GigabitEthernet1/0/25
device-tracking attach-policy IPDT_MAX_10
!
interface GigabitEthernet1/0/26
device-tracking attach-policy IPDT_MAX_10
!
interface GigabitEthernet1/0/27
device-tracking attach-policy IPDT_MAX_10
!
interface GigabitEthernet1/0/28
device-tracking attach-policy IPDT_MAX_10

 

Is anyone have the same issue? i will be gracefull if someone can help to ressolve this problem and being able to set the correct configuration? 

 

Here my original templates : 

 

ostname $hostname
!
!

vlan ${Mgmt_Vlan}
name mgmt
!
vlan ${Data_Vlan}
name Data
!
vlan ${Secure_Vlan}
name Security
!
vlan ${Voice_Vlan}
name Voice
!
vlan ${Wifi-LAN_Vlan}
name WiFi_LAN
!
vlan ${Wifi-VIP_Vlan}
name WiFi_VIP
!
vlan ${Wifi-Apple_Vlan}
name WiFi_Apple
!

ip ssh version 2
snmp-server community Community RO
snmp-server community Golden123 RW
!
!
line vty 0 4
login local
transport input ssh
!
!
line vty 5 15
login local
transport input ssh
!
ntp source Vlan99
ntp server 192.168.200.100
ntp server 192.168.210.16
!
interface GigabitEthernet1/1/1
description Connect-to-Uplink
switchport trunk native vlan ${Mgmt_Vlan}
switchport trunk allowed vlan ${Mgmt_Vlan},${Data_Vlan},${Secure_Vlan},${Voice_Vlan},${Wifi-LAN_Vlan},${Wifi-VIP_Vlan},${Wifi-Apple_Vlan}
switchport mode trunk
no shutdown
logging event trunk-status
!
interface range $interface_type1 $port_range1
description Connect-USER_ToIP
switchport access vlan ${Data_Vlan}
switchport mode access
switchport voice vlan ${Voice_Vlan}
spanning-tree portfast
no shutdown
!
interface range $interface_type1 $port_range2
description Connect_to_WiFi
switchport trunk native vlan ${Mgmt_Vlan}
switchport trunk allowed vlan ${Mgmt_Vlan},${Wifi-LAN_Vlan},${Wifi-VIP_Vlan},${Wifi-Apple_Vlan}
switchport mode trunk
no shutdown
!
interface range $interface_type2 $port_range3
description Connect-to-Uplink
switchport trunk native vlan ${Mgmt_Vlan}
switchport trunk allowed vlan ${Mgmt_Vlan},${Data_Vlan},${Secure_Vlan},${Voice_Vlan},${Wifi-LAN_Vlan},${Wifi-VIP_Vlan},${Wifi-Apple_Vlan}
switchport mode trunk
no shutdown
logging event trunk-status
!
interface vlan${Mgmt_Vlan}
ip address ${Mgmt_IPAddr} 255.255.255.0
no shutdown
!
ip default-gateway ${Dafault_GW}
ip http server
ip http secure-server
ip http client source-interface Vlan${Mgmt_Vlan}
ip ssh source-interface Vlan${Mgmt_Vlan}

!
pnp profile pnp-zero-touch
transport https ipv4 172.16.128.200 port 443 source Vlan${Mgmt_Vlan}

 

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Mike.Cifelli
VIP Advocate

Any update on discoveries for this issue? Is it possible that maybe the device got re-provisioned? Have you configured the ports for proper host onboarding assignment? It seems as if they are not configured properly within DNAC. Have you added to site and provisioned to fabric?

View solution in original post

Hello Mike, 

 

I don't use a fabric. it is a classical nework with PnP automation. The problem is solved, Thank you. 

 

The issue was with my template : I missed the caracter  "!" at the end of my template. 

 

Now i had deployed about 10 devices. 

 

Thanks

 

 

View solution in original post

2 REPLIES 2
Mike.Cifelli
VIP Advocate

Any update on discoveries for this issue? Is it possible that maybe the device got re-provisioned? Have you configured the ports for proper host onboarding assignment? It seems as if they are not configured properly within DNAC. Have you added to site and provisioned to fabric?

View solution in original post

Hello Mike, 

 

I don't use a fabric. it is a classical nework with PnP automation. The problem is solved, Thank you. 

 

The issue was with my template : I missed the caracter  "!" at the end of my template. 

 

Now i had deployed about 10 devices. 

 

Thanks

 

 

View solution in original post