cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
166
Views
0
Helpful
3
Replies
Beginner

Location field is always blank in DNA-C Network device API response

Hi All

We want to fetch the list of all network devices at any site in my DNA-C. 

We are accessing API -'api/v1/network-device/' and below is API response. Location field always returns null value.

We also tried accessing site-health API, it is giving consolidated health but not for individual device.

 

Please help me in getting value in location field.

 

"memorySize": "NA",
"family": "Routers",
"type": "Cisco 4331 Integrated Services Router",
"softwareType": "IOS-XE",
"softwareVersion": "3.16.4",
"hostname": "11V1R01.vspllab.in",
"platformId": "ISR4331/K9",
"reachabilityFailureReason": "",
"reachabilityStatus": "Reachable",
"series": "Cisco 4300 Series Integrated Services Routers",
"snmpContact": "",
"snmpLocation": "",
"tagCount": "0",
"tunnelUdpPort": null,
"waasDeviceMode": null,
"apManagerInterfaceIp": "",
"associatedWlcIp": "",
"bootDateTime": "2019-08-19 13:10:21",
"collectionStatus": "Managed",
"inventoryStatusDetail": "<status><general code=\"SUCCESS\"/></status>",
"serialNumber": "FDO2110A0KQ",
"lastUpdateTime": 1566981801063,
"errorCode": null,
"errorDescription": null,
"interfaceCount": "0",
"lastUpdated": "2019-08-28 08:43:21",
"lineCardCount": "0",
"lineCardId": "",
"locationName": null,
"managementIpAddress": "10.122.1.8",
"collectionInterval": "Global Default",
"upTime": "8 days, 19:33:37.62",
"roleSource": "AUTO",
"location": null,
"role": "BORDER ROUTER",
"macAddress": "70:d3:79:ed:27:50",
"instanceTenantId": "5c20e7257dce69004cf08e97",
"instanceUuid": "c1630432-164e-435d-90f7-4459165a0575",
"id": "c1630432-164e-435d-90f7-4459165a0575"
Everyone's tags (1)
3 REPLIES 3
Highlighted
Cisco Employee

Re: Location field is always blank in DNA-C Network device API response

This is a known issue with the /network-device API in the existing DNAC releases. You can use "Get Device Detail", it should provide the location.

Beginner

Re: Location field is always blank in DNA-C Network device API response

If I make API call to get device_details for every device (to get device_details) I will hit rate limit:

 

"error": "Rate Limit exceeded; BapiName: Get Device Detail, RateLimit config details: RateLimitContext{rate=5, windowUnit='minute', windowDuration=1, maxConcurrentExecutionsPermitted=0}",

 

Is there any way to edit the RateLimitContext? 

 

Thank you

Cisco Employee

Re: Location field is always blank in DNA-C Network device API response

Sorry. Not today. Did you want to Make a wish?
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.