cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
779
Views
0
Helpful
1
Replies

Unable to claim device with template

rasmus.elmholt
Level 7
Level 7

Hi,

 

I have created a pretty simple template:

hostname {{ HOSTNAME }}
!
ip domain-name mgmt.net
!
!###### Clock&Timezone&NTP ######
!
clock timezone CET 1
!
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
service timestamps log datetime show-timezone localtime 
!
ntp server {{ NTPSERVER }}
!
!###### SNMP ######
!
snmp-server group "GroupName" v3 priv write v1default
snmp-server user "Username" "GroupName" v3 auth sha "SHAPASSWORD" priv aes 128 "AESPASSWORD"
snmp-server host "SNMP-POLL-IP" version 3 priv "Username"
!
!###### Error checks and recovery ######
!
Spanning-tree loopguard default
!
!###### Spanning-tree Non-root ######
!
spanning-tree mode rapid-pvst
spanning-tree vlan 1-4094 priority 36864
!
!###### Management ######
!
lldp run
cdp run
!
line con 0
 exec-timeout 15 0
 logging synchronous
!
line vty 0 4
 exec-timeout 15 0
logging synchronous
transport input ssh
access-class 23 in
!
line vty 5 15
 exec-timeout 15 0
logging synchronous
transport input ssh
access-class 23 in
!
no ip http server
ip http secure-server
!
access-list 23 permit 10.110.0.0 0.0.255.31
access-list 23 permit 10.110.0.0 0.0.255.31
access-list 23 permit 10.110.0.0 0.0.255.31
access-list 23 permit 10.110.0.0 0.0.255.31
access-list 23 permit 10.110.0.0 0.0.255.31
access-list 23 permit 10.110.0.0 0.0.255.31
access-list 23 deny log
!
!###### Access interface #####
!
{% set vlans = ['10;admin', '20;stud', '50;print', '99;mgmt'] %}
{% for vlan in vlans %}
{% set vlanInfo = vlan.split(';') %}
 vlan {{ vlanInfo[0] }}
  name {{ vlanInfo[1] }}
{% endfor %}
!###### Access interface #####
!
{% for interface in __interface %}
  {% if 'e1/0/' in interface.portName %}
    int {{ interface.portName }}
    description *** Client access port ***
    switchport mode access
    switchport access vlan {{ ACCESSVLAN }}
    ip dhcp snooping limit rate 100
    storm-control broadcast level 01.00 00.90
    storm-control multicast level 01.00 00.90
    spanning-tree bpduguard enable
    spanning-tree portfast
  {% endif%}
{% endfor %}

!###### Uplink port ######
Interface G1/1/1
 description *** Uplink to ****
 switchport mode trunk
 switchport nonegotiate
 switchport trunk native vlan 1024
 switchport trunk allowed vlan 1-1024
 storm-control broadcast level 10.00 5.00
 storm-control multicast level 10.00 5.00
 ip dhcp snooping trust
!
!###### Downlink port ######
Interface range G1/1/2-4
 description *** Downlink 2 XXXXX ****
 switchport mode trunk
 switchport nonegotiate
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1-1024
 storm-control broadcast level 10.00 5.00
 storm-control multicast level 10.00 5.00
!

!###### VTP ######
!
vtp mode transparent
! 
!###### Source interface ######
!
ip ssh source-interface {{ MGMTVLAN }}
!
ip tacacs source-interface {{ MGMTVLAN }}
!
ip radius source-interface {{ MGMTVLAN }}
!
ip http client source-interface {{ MGMTVLAN }}
!
ntp source vlan {{ MGMTVLAN }}
!
!###### DHCP Snooping ######
!
ip dhcp snoopoing
ip dhcp snooping vlan 1-4094
!
!###### AAA ######
!
aaa authentication attempts login 3 
!
!###### Logging #####
!
logging Buffered 4000000
logging Buffered notifications
!

I have now plugged in a switch and it is in the initialized state in PnP. But when I try to clain it, it just stoppes when I want to apply the template.

Skærmbillede 2021-08-29 201027.png

 

When I press the next button, nothing happens. Not even an error message.

 

1 Accepted Solution

Accepted Solutions

rasmus.elmholt
Level 7
Level 7

Went to System -> Settings -> debugging logs and changed the logging level for 30 mins to debug on the onboarding-service.

After som magctl service logs -rf onboarding-* | tee onboarding.log. I found an interesting entry:

2021-08-29 20:05:25,210 |  DEBUG | qtp1807648168-20          |  | c.c.p.a.s.impl.TemplateServiceImpl | response object recieved: {"templateId":"57095a67-5771-4587-a226-18476c18b44d","cliPreview":null,"deviceId":null,"validationErrors":[{"type":"RUNTIME","lineNumber":78,"message":"Cannot resolve property 'portName' in ''"}]} |

This brought be further in the tshoot and I am not getting errors that make sence.

View solution in original post

1 Reply 1

rasmus.elmholt
Level 7
Level 7

Went to System -> Settings -> debugging logs and changed the logging level for 30 mins to debug on the onboarding-service.

After som magctl service logs -rf onboarding-* | tee onboarding.log. I found an interesting entry:

2021-08-29 20:05:25,210 |  DEBUG | qtp1807648168-20          |  | c.c.p.a.s.impl.TemplateServiceImpl | response object recieved: {"templateId":"57095a67-5771-4587-a226-18476c18b44d","cliPreview":null,"deviceId":null,"validationErrors":[{"type":"RUNTIME","lineNumber":78,"message":"Cannot resolve property 'portName' in ''"}]} |

This brought be further in the tshoot and I am not getting errors that make sence.