cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
104
Views
0
Helpful
2
Replies
Highlighted

Failed to install package.tar on CAT 9300 IOS 16.12.4

Hi, Expert

 

     After upgrading my CAT 9300 IOS image from 16.6.6 to 16.12.4, all my old error messages have disappeared. But the installation of the IOx docker app still had problem. This time, it is this one.

 

zbmvsw9300-01#app-hosting install appid hello_app100 package flash:package.tar

 

*Oct 16 16:28:28.653: %IM-6-INSTALL_MSG: Switch 1 R0/0: ioxman: app-hosting: Install failed: guestshell_setup.sh returned error: 255, message: Installing apps on system flash is not allowed.

 

zbmvsw9300-01#show ver
Cisco IOS XE Software, Version 16.12.04
Cisco IOS Software [Gibraltar], Catalyst L3 Switch Software (CAT9K_IOSXE), Version 16.12.4, RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2020 by Cisco Systems, Inc.
Compiled Thu 09-Jul-20 21:49 by mcpre

 

 

Thanks

 

Steve

 

2 REPLIES 2
Highlighted
VIP Mentor

A Guest Shell installed via bootflash does not allow you to do resource resizing using application hosting configuration commands.)

 

follow the guide :

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/prog/configuration/1610/b_1610_programmability_cg/guest_shell.html

BB
*** Rate All Helpful Responses ***
Highlighted

It turns out that you need to have USB3.0 SSD in the CAT 9300 in order to run application hosting.

 

This widget could not be displayed.