cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
773
Views
4
Helpful
2
Replies
vbeckers
Cisco Employee

Is this a supported Configuration ?

Hi Guys,

I am trying to use a bridge group for interface gig 5 so the can obtain an ip address. The OS seems to get an ip address and I can ping it but I see this message come up once I add gig 5 to the bridge-group.

000416: *Oct 17 17:41:40.580: %IOX-6-HEARTBEAT_TIMER_EXPIRED: IOX Heartbeat timer expired.

interface GigabitEthernet5

no ip address

ip virtual-reassembly in

duplex auto

speed auto

ipv6 enable

bridge-group 1

interface BVI1

description Kit Wireless Data

ip address 10.1.1.200 255.255.255.240

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1000

bridge 1 protocol ieee

bridge 1 route ip

show iox host list detail   - OS status showing as Unknown

IOX Server is running. Process ID: 327

Count of hosts registered: 1

Host registered:

===============

    IOX Server Address: FE80::242:68FF:FE85:D5EC; Port: 22222

    Link Local Address of Host: FE80::1FF:FE90:8B05

    IPV4 Address of Host:       10.1.1.201

    IPV6 Address of Host:       fe80::1ff:fe90:8b05

    Client Version:             0.4

    Session ID:                 3

    OS Nodename:                kit-6926-GOS-1

    Host Hardware Vendor:       Cisco Systems, Inc.

    Host Hardware Version:      1.0

    Host Card Type:             not implemented

    Host OS Version:            1.1.2.0

   OS status:                  UNKNOWN

    Interface Hardware Vendor:  None

    Interface Hardware Version: None

    Interface Card Type:        None

    Applications Registered:

    =======================

        Count of applications registered by this host: 0

Thanks


Victor

2 REPLIES 2
Steve Zhang
Cisco Employee

Hi Victor,

BVI is supported by IR829 IOS/IOx. Do you set the irb, gos-pool, vlan, etc.?

Here is my configure info for your reference. Hope it helps.

ip dhcp pool gospool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 64.104.123.144

bridge irb

interface GigabitEthernet1

switchport access vlan 100

no ip address

interface GigabitEthernet5

no ip address

ip virtual-reassembly in

duplex auto

speed auto

ipv6 enable

bridge-group 1

interface Vlan100

ip address 10.74.69.119 255.255.255.0

ip nat outside

ip virtual-reassembly in

interface BVI1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

Thanks,

Steve

Thanks Steve.

I tried that config and I noticed the following which seems to be an odd behaviour and more like a bug.

1 - Eth0 gets an ip address and its singable from the local interface however as you can see it doesn't show the ip address on the host detail.

kit-6926#ping 192.168.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

kit-6926#show iox host list detail

IOX Server is running. Process ID: 327

Count of hosts registered: 0

    IOX Server Address: 0.0.0.0; Port: 22222

2 - Once I remove interface gig 5 from the Bridge-group 1 the heartbeat seems to work and I also get get an output from the host list

kit-6926(config)#int gi5

kit-6926(config-if)#no bri

kit-6926(config-if)#no bridge-group 1

kit-6926(config-if)#

004106: *Oct 18 12:17:20.674: %LINK-3-UPDOWN: Interface BVI1, changed state to down

004107: *Oct 18 12:17:21.332: %IOX-6-SOCK_CONNECT: Received socket connection request from IOX Client

004108: *Oct 18 12:17:21.674: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to down

004109: *Oct 18 12:17:22.346: %IOX-6-SOCK_MESSAGE: Received IOX_REQUEST message with opcode IOX_REQUEST_REGISTER from IOX Client

004110: *Oct 18 12:17:23.350: %IOX-6-SOCK_MESSAGE: Received IOX_REQUEST message with opcode

IOX_REQUEST_GET_TIME from IOX Client

kit-6926#show iox host list detail

IOX Server is running. Process ID: 327

Count of hosts registered: 1

Host registered:

===============

    IOX Server Address: FE80::242:68FF:FE85:D5EC; Port: 22222

    Link Local Address of Host: FE80::1FF:FE90:8B05

    IPV4 Address of Host:       192.168.1.3

    IPV6 Address of Host:       fe80::1ff:fe90:8b05

    Client Version:             0.4

    Session ID:                 6

    OS Nodename:                kit-6926-GOS-1

    Host Hardware Vendor:       Cisco Systems, Inc.

    Host Hardware Version:      1.0

    Host Card Type:             not implemented

    Host OS Version:            1.1.2.0

    OS status:                  RUNNING

    Interface Hardware Vendor:  None

    Interface Hardware Version: None

    Interface Card Type:        None

    Applications Registered:

    =======================

        Count of applications registered by this host: 0

and obviously once I remove the bridge-group command the server no longer responds to pings

kit-6926#ping 192.168.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

kit-6926#

If you could help me debug or send me some about how the heartbeat works I would appreciate it.

Thanks

Victor

Content for Community-Ad

This widget could not be displayed.