cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Community
2558
Views
0
Helpful
2
Replies
Beginner

Unable to start IOx service on C819

I'm on a C819 running c800-universalk9_iox-mz.SPA.156-3.M5.bin trying to do some experiments on IOx.

 

All IOx-related config commands and show commands run very slowly and sometimes fail, while other config commands work very well. After configured everything according to the documentation, I'm unable to access IOx local manager.

 

I can ping IOx host IP from both the router and my computer, and I can access IOx host IP 443 port (though it replies a 404) but 8443 port is not open. Telnet to IOx host IP doesn't work. Tried reloading multiple times or iox reset, they didn't work.

 

What should I do to make it work?

 

System version:

iox-test#show ver
Cisco IOS Software, C800 Software (C800-UNIVERSALK9_IOX-M), Version 15.6(3)M5, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Tue 31-Jul-18 08:25 by prod_rel_team

ROM: System Bootstrap, Version 15.2(2r)T1, RELEASE SOFTWARE (fc1)

iox-test uptime is 35 minutes
System returned to ROM by reload at 17:17:59 UTC Fri Jan 11 2019
System image file is "flash:c800-universalk9_iox-mz.SPA.156-3.M5.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command

 

IOx status:


IOx Infrastructure Summary:
---------------------------
Services State : FAIL
Networking Configured : OK
IOS Network Reachable : OK
Host Infrastructure State : FAIL

System Information:
-------------------
Build Date : Mon Dec 19 16:15:52 IST 2016
Version : cwan_mizuno_dev/218
Uptime : 0d 0h 40m 21s
Disk Space Usage : 50% (490MB)
Memory Usage : 41% (207MB)
CPU Utilization : 0%

Networking Information:
-----------------------
IP Address : 192.168.3.2
IP Gateway : 255.255.255.0
IP Netmask : 192.168.3.1

IOx Host Agent:
---------------
Debug Level : WARNING

IOx Processes State:
--------------------
caf : Not Running
crond : Running
ioxhad : Running
libvirtd : Running
monit : Running

 

Config: 

Current configuration : 2251 bytes
!
! Last configuration change at 17:46:11 UTC Fri Jan 11 2019
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname iox-test
!
boot-start-marker
boot system flash:c800-universalk9_iox-mz.SPA.156-3.M5.bin
boot-end-marker
!
aqm-register-fnf
!
!
aaa new-model
!
aaa session-id common
!
ip inspect WAAS flush-timeout 10
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
license boot module c800 level advipservices
!
username cisco privilege 15 password 0 cisco
!
redundancy
notification-timer 120000
!
controller Cellular 0
lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
interface Cellular0
no ip address
encapsulation slip
shutdown
!
interface Cellular1
no ip address
encapsulation slip
shutdown
!
interface Ethernet1
ip address 192.168.3.1 255.255.255.0
ip virtual-reassembly in
!
interface FastEthernet0
no ip address
shutdown
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface GigabitEthernet0
ip address dhcp
duplex auto
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Vlan1
no ip address
!
iox
host ip address 192.168.3.2 255.255.255.0
host ip default-gateway 192.168.3.1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
access-list 1 permit any
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
vstack
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
no exec
line 8
no exec
line vty 0 4
transport input all
!
scheduler allocate 20000 1000
!
end

 

 

2 REPLIES
Highlighted
VIP Advocate

Re: Unable to start IOx service on C819

Networking Information:
-----------------------
IP Address : 192.168.3.2
IP Gateway : 255.255.255.0 <-- this is subnetmask
IP Netmask : 192.168.3.1 - <-- This is Gateway

check the IP address information you configured on the interface also. 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Unable to start IOx service on C819

I think there is a bug for some IOx versions that gateway and netmask are displayed inverted. According to some thread in this forum, it is only a display issue.

I've checked the interface IP addresses. I can ping the IOx IP address from a host on Gi0.
CreatePlease to create content