cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

IOx Configuration on IR829

22245
Views
16
Helpful
33
Comments

IR829 router is similar to CGR routers. And IR809 is same as IR829.

IR829 has one GE0 wan interface which needs an Ethernet SFP for connecting the WAN Ethernet cable in our LAB switch, four LAN switch ports and 2 serial interfaces.

Access the console of IR829:

IR829 is using a mini-USB port for the serial interface. Please use a Mini-USB cable to connect to your PC. You may need to install the driver for the console. Here is the link for the drive. The default baud rate is 9600. For details, please refer to Cisco IR829 Industrial Integrated Services Router Hardware Installation Guide - Connecting the Router [Cisco 800 Series ….

Bundle image installation on the 829:

bundle image can be used to upgrade the 829 - ir800-universalk9-bundle.SPA.156-1.T1.bin -- which has IOS, guset OS , Hypervisor from ir800-universalk9-bundle.SPA.156-1.T1.bin. You need to download the bundle image from CCO and uploaded it for IR829 flash by SCP, HTTP, TFTP, etc. For example:

copy scp://username@10.10.10.10//home/username/ir800-universalk9-bundle.SPA.156-1.T1.bin flash:

bundle install flash:ir800-universalk9-bundle.SPA.156-1.T1.bin

The image can be upgraded using the 829 bundle image available here Cisco Systems CCO. You can upgrade the images individually also.

Please notify, the 15.6 or later can be upgraded from 15.5.3 only. All the other version such as 15.5.2 or earlier must be upgrated to 15.5.3 first, and then upgraded to 15.6 or later.

IR829 Configuration:

  • Step1: Configure the wan interface of the 829 router GE0.

===========================================

Set the GE interface with the specific IP address and network mask.

"ip nat outside" to specify that the interface is connected to the outside network. If your GOS is assigned with a publish IP address, you don’t need to set the NAT related in all the configurations below.

interface GigabitEthernet0

ip address 72.163.206.123 255.255.255.0

ip nat outside

ip virtual-reassembly in

[NOTE]: Here GLC-T SFP for GE0 is supported. The OS version on which it is officially supported is 15.5(3)M0a or above. And you need to add the below CLI.

config terminal

service internal

service unsupported-transceiver

And you may also use the GE interfaces (GE1-4) instead of WAN interface to access internet. Here we use GE1 and Vlan999 as an example.

interface GigabitEthernet1

switchport access vlan 999

no ip address

!

interface Vlan999

ip address 10.75.189.144 255.255.255.0

ip nat outside

ip virtual-reassembly in

!

  • Step2: Configure the "ip route" and "ip default gateway"

=======================================

ip default-gateway 72.163.206.1                              //or 10.75.189.1 if you are using GE1 as example

ip router 0.0.0.0 0.0.0.0 72.163.206.1                      //or 10.75.189.1 if you are using GE1 as example

  • Step 3: Configure the GOS and IOS connectivity interface - GE5

=============================================

ip nat inside  -  Enter ip nat inside to specify that the interface is connected to the inside network and

ipv6 enable   -  IPv6 must be enabled also have to configured

interface GigabitEthernet5

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

ipv6 enable

  • Step 4: To assign an IP address to the Guest OS, configure a Local DHCP pool:

============================================================

ip dhcp excluded-address 192.168.1.1 192.168.1.5

ip dhcp pool gospool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1                                 <<<<<<<<<<<<<<<,GE5 is the gateway to GOS

dns-server 64.104.123.144

  • Step 5: Nat configurations:

====================

ip nat inside source list NAT_ACL interface GigabitEthernet0 overload

ip nat inside source static tcp 192.168.1.6 22 interface GigabitEthernet0 2222

ip nat inside source static tcp 192.168.1.6 8443 interface GigabitEthernet0 8443

ip access-list standard NAT_ACL

permit 192.168.0.0 0.0.255.255

[NOTE]: Please replace the GigabitEthernet0 with Vlan999 in case the GE1-4 is used for connecting internet.

ip nat inside source list NAT_ACL interface Vlan999 overload

ip nat inside source static tcp 192.168.1.6 22 interface Vlan999 2222

ip nat inside source static tcp 192.168.1.6 8443 interface Vlan999 8443

ip access-list standard NAT_ACL

permit 192.168.0.0 0.0.255.255


Make sure 8443 is enabled for further deployment of applications. Verifying GOS is running and got the IP address from the DHCP pool with “show iox host list detail”.

And you should have “privilege 15” to access the Web interface (such as IOx Local Manager) for IR829. The IOS command is: username yourusername privilege 15 password 0 yourpassword

Verifying GOS is running and get the IP address from the DHCP pool:

=================================================

IR800#show iox host list detail

IOX Server is running. Process ID: 261

Count of hosts registered: 1

Host registered:

===============

    IOX Server Address: FE80::86B8:2FF:FE9C:ED8C; Port: 22222

    Link Local Address of Host: FE80::1FF:FE90:8B05

    IPV4 Address of Host:       192.168.1.6                                      <<<<<<<<<<<<<<<<<<<<<<ip address got from the DHCP Pool.

    IPV6 Address of Host:       fe80::1ff:fe90:8b05

    Client Version:             0.1

    Session ID:                 1

    OS Nodename:                IR800-GOS-1

    Host Hardware Vendor:       Cisco Systems, Inc.

    Host Hardware Version:      1.0

    Host Card Type:             not implemented

    Host OS Version:            1.28

    OS status:                  RUNNING

    Interface Hardware Vendor:  None

    Interface Hardware Version: None

    Interface Card Type:        None

    Applications Registered:

    =======================

        Count of applications registered by this host: 0                        <<<<<<<<<<<<<<<<<<<<<<<< applications running on the GOS

IR800#

Starting Guset OS :

===========

IR800#guest-os 1 start

Stopping GOS:

============

IR800#guest-os 1 stop

Upgrade of guest OS:

============

Copy Guest OS image to IOS flash partition

guest-os 1 stop

guest-­os 1 image uninstall

guest-os 1 image install flash:<GOS image in falsh> verify

guset-os 1 start

If you want to install the original Guest OS from the bundle image, you may run the below command:

bundle install flash:<bundle image in falsh> exclude HV-IOS

All the cartridges and applications for IOx are stored in the specific partition in IR829, and will not be impacted by the upgrade of Guest OS. If you have installed the cartridges and applications for the old Guest OS, all the cartridges and applications will be still there after the upgrade with the new Guest OS. (Please notify: for some early versions, due to the modification of CAF framework, there is some impact for the applications. You'd better remove all the cartridges and applications before upgrade of Guest OS to avoid the incompatibility, and then re-install them accordingly after upgrade.)

FOR THE LATEST INFORMATION AND CONFIGURATION, PLEASE REFER TO https://developer.cisco.com/docs/iox/#ir-800-series

Comments
Beginner

Hi  ,

Thanks a lot for these instructions . saved me a lot of time .  I still having trouble accessing IOx local manager webUI on IR 829. I have the privilage mode 15 enabled but still cannot browse to https://<gig0>:8443  .  Not sure if local manager webUI is  really running in guestOS or may be its not supported in my version of image.

Cisco IOS Software, ir800 Software (ir800-UNIVERSALK9-M), Version 15.5(3)M, RELEASE SOFTWARE (fc1)

Cisco Employee

Please use the version of 15.6.

Enthusiast

Hi

These instructions could be usefully accompanied by a diagram showing the physical network configuration. There is an implication that there is a switch in the network, in addition to the switch ports in the IR829.

It is, in practice, unlikely that one would have the required adaptor for the GE0 interface, so it is unlikely that people will be using the GE0 port.

A more likely configuration would be a laptop connected, via an ethernet cable, to GE1-4. Instructions for how to enable that form of connectivity would be very helpful. That would be simpler than requiring an additional switch.

Regards

Nathan

Beginner
Beginner

Hi,

Good info. Thanks! Wondering what type of IoT devices IR929 supports. Do we have a list somewhere ?

Also, IoT device can connect directly to IR829 USB right?

Thanks!

Regards,

Edgar

Cisco Employee

Hi Edgar,

For the supported platform for IOx, please refer to Platforms --> Supported Platforms in https://developer.cisco.com/site/iox/documents/developer-guide/?ref=quickstart

For IR829 USB access, currently it only supports USB storage for GOS. You may use serial interfaces, wireless, or GE interfaces to connect IoT devices.

Hope it helps.

Steve

Cisco Employee

Hi Steve,

On the article you mentioned:

Please notify, the 15.6 or later can be upgraded from 15.5.3 only. All the other version such as 15.5.2 or earlier must be upgrated to 15.5.5 first, and then upgraded to 15.6 or later.

Why is this not possible? I ask this because I have currently an IR829 which I cannot downgrade from 156-2.T to 155-3.M4a.

When I try to do so I get my router stuck in an unrecoverable boot loop. I wish to understand what's involved in a bundle downgrade so that I am able to perform it without issues.

Cisco Employee

Hi Gerardo,

If the current version is 156-2T and want to upgrade to the latest version, you don't need to downgrade the version to 155-3.M4a. You can use bundle upgrade to the latest version directly. Just as Steve mentioned, for 15.5.2 or earlier version, we might use interim version (15.5.5) to upgrade to 15.6.

Jun

Cisco Employee

Thanks for the info, however I wish to downgrade my IOS from 156-2T to 155-3.M4a.

Perhaps doing only the IOS downgrade, and not the whole bundle downgrade would solve my issue, but I am really worried about why a downgrade causes my router to go into such a nasty state. I had to RMA it because I could not even go into ROMMON.

Cisco Employee

I just want to know more about what is it that the bundle does that it makes these upgrades/downgrades non-reversible.

Beginner
Beginner

Upgrading Cisco routers should be straight forward but it does not seem for this case.

I can't find this info from this article.

I connected IR829 Ge2 to my work laptop. I configured static IP address between two devices.

IR829 does not take IP address at first with something about layer 3. Fine, I configured vlan 1 with an IP address but still I can't ping from IR829 to my laptop but I can ping from my laptop to IR829.

I removed vlan 1 ip address and created a new vlan like vlan 222 but still. I can't ping IR 829 to my laptop. RIght now

I can't download new images to the IR829.

IR800#sh run int gig2

Building configuration...

Current configuration : 77 bytes

!

interface GigabitEthernet2

switchport access vlan 222

no ip address

end

IR800#sh run int vlan 222

Building configuration...

Current configuration : 107 bytes

!

interface Vlan222

ip address 210.210.210.2 255.255.255.0

ip nat outside

ip virtual-reassembly in

end

IR800#ping 210.210.210.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 210.210.210.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

As mentioned, I can ping from my laptop to Gig 2.

Please help.

Thanks,

Edgar

Cisco Employee

Hi Edgar,

GE2 is a LAN port thus it cannot assign an IP address.

Can you ping your laptop by specifying the source IP:

#ping 210.210.210.1 source interface vlan 222

If not, please share us your routing table:

# show ip route

Beginner
Beginner

Hi Chun Li,

It still does not work-.

IR800#ping 210.210.210.1 source vlan 222

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 210.210.210.1, timeout is 2 seconds:

Packet sent with a source address of 210.210.210.2

.....

Success rate is 0 percent (0/5)

IR800#sh vlan ?

% Ambiguous command: "sh vlan "

IR800#sh sw

IR800#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

a - application route

+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

210.210.210.0/24 is variably subnetted, 2 subnets, 2 masks

C 210.210.210.0/24 is directly connected, Vlan222

L 210.210.210.2/32 is directly connected, Vlan222

IR800#sh run int vlan 222

Building configuration...

Current configuration : 107 bytes

!

interface Vlan222

ip address 210.210.210.2 255.255.255.0

ip nat outside

ip virtual-reassembly in

end

From my laptop

=============

C:\Users\evo>ping 210.210.210.2

Pinging 210.210.210.2 with 32 bytes of data:

Reply from 210.210.210.2: bytes=32 time<1ms TTL=255

Reply from 210.210.210.2: bytes=32 time<1ms TTL=255

Reply from 210.210.210.2: bytes=32 time<1ms TTL=255

Reply from 210.210.210.2: bytes=32 time<1ms TTL=255

Ping statistics for 210.210.210.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

Thanks,

Edgar

Beginner
Beginner

Hi Chun Li,

Please don’t worry, I was able to download the two images.

Not sure why but it looks like Ping does not work from IR829 to my laptop but tftp works.

I have a question.. as I can purchase sensors like action sensors and connect them/it to USB.

Will it recognize ?

Thanks!

Regards,

Edgar

Beginner
Beginner

Hi All,

We would like to have motion sensor connected to the IR829.

Any recommendation ? can we connect it directly to IR829 through USB ? or through its wireless ?

Thanks!

Regards,

Edgar

Cisco Employee

Hi Edgar,

USB in IR829 is mapped to Guest-OS. The driver of USB device is needed. Currently, the motion sensor's driver is not integrated on IR829. You have to deal with driver in your side.

Regards

Jun

CreatePlease to create content
Content for Community-Ad
Cisco Community April 2020 Spotlight Award Winners
This widget could not be displayed.