cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
352
Views
5
Helpful
5
Replies
Beginner

Dataflow issue in EFM 1.6 on IR829

I have IR829 (15.8(3)M1) with IoX (1.7.0.7) and deployed EFM 1.6 app. When I create a new dataflow:

  • I don't see any values in any table
  • I'm unable to import or export dataflow

Older version without C++ broker work fine. Do you know possible cause of these issues? 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Dataflow issue in EFM 1.6 on IR829

Hi Dominik,

 

There are some known issues with interactions between dataflow and the EFM 1.6 broker.  Some of those were resolved with the 1.6.1 Broker.  So first, I would recommend moving to 1.6.1, if not 1.7 which was recently released.  Once upgraded, you may still see the occasional issue but these are dataflow editor only and do not affect running dataflows.  The workaround is usually to close the dataflow, then expand the dataflow node on the data tree on the left side of the editor to expose all the blocks within the dataflow, then reopen the dataflow.  The dataflow should correctly display at that point.

 

Regards,

marc

5 REPLIES 5
Highlighted
Cisco Employee

Re: Dataflow issue in EFM 1.6 on IR829

Hi Dominik,

 

Could you elaborate on the issues you are seeing?

Screenshots will also help :-)

 

--Naveen

Beginner

Re: Dataflow issue in EFM 1.6 on IR829

Hi Naveen,

 

in the picture below you can see of table view in a dataflow. Due to this is necessary to implement dataflow elsewhere and then move it to EFM 1.6 on IR829.

 Screenshot 2019-07-25 at 11.15.33.png

 

Dominik

Everyone's tags (1)
Cisco Employee

Re: Dataflow issue in EFM 1.6 on IR829

Hi Dominik,

 

There are some known issues with interactions between dataflow and the EFM 1.6 broker.  Some of those were resolved with the 1.6.1 Broker.  So first, I would recommend moving to 1.6.1, if not 1.7 which was recently released.  Once upgraded, you may still see the occasional issue but these are dataflow editor only and do not affect running dataflows.  The workaround is usually to close the dataflow, then expand the dataflow node on the data tree on the left side of the editor to expose all the blocks within the dataflow, then reopen the dataflow.  The dataflow should correctly display at that point.

 

Regards,

marc

Beginner

Re: Dataflow issue in EFM 1.6 on IR829

Hi Mark,

 

thank you very much for your help. Your tips helped. However, the trouble with tables still remains. Therefore, it isn't possible to develop a dataflow with tables directly on IR829 and it must be developed elsewhere.

 

I have one more comment here. With my dataflow, EFM 1.6 on IR829 works fine (except issues above) and in broker.log I see just this type of message: 

[2019-07-25 09:14:50.213274] ERROR(3019): Internal error, could not find callback for request, 4702

However, with the same dataflow, EFM 1.2 and EFM 1.5 work just several days and then the EFM crashes and must be restarted. During the running part I see in broker.log this type of messages:

2019-07-24 21:34:12 INFO [broker] - DSLink `CeskyKrumlovEdgeNode-VkN6lQ_q17-WEEPageZHDTwGyLOA3nphoktRn5OaE5s` has disconnected

2019-07-24 21:34:12 INFO [upstream] - reconnect in 1 seconds

2019-07-24 21:34:14 INFO [upstream] - Successfully connected to the upstream broker 'SimacPrgFogNode'

 

 

I'm looking forward to test EFM 1.7.

Dominik

Everyone's tags (1)
Cisco Employee

Re: Dataflow issue in EFM 1.6 on IR829

Hi Dominik,

 

EFM 1.7 is now available.

If possible, please upgrade to it and re-test to see if the issue persists.

 

Thanks,

Naveen

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.