cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
275
Views
0
Helpful
1
Replies
Frank57510
Beginner

Issues with uploaded custom images

Hi all,

 

I've been trying to follow David Bombals video to upload and use custom Windows 10 images to the CML2 lab environment.

Everything went just fine until I tried to create the new Image Definition, after hitting create it returned an error stating it was unable to create it and thats it. The uploaded image is gone from the browser and I can see in the browser the file is still present on the CML server, as the storage used is still the same after uploading.

 

So the steps I followed to this point were:

- Download Win10 Dev VM;

- Converted to qcow2 image;

- Upload the image with scp to the server;

- Created a Node Definition;

- Tried to create a Image Definition which fails stating its unable to.

 

After this, the uploaded image disappears in the browser under the tab Uploaded Images. Restarting the browser or the server for that matter doesn't bring it back. 

 

So I basically have 2 questions:

1. Did anybody encounter this before and how did you manage to fix this?

2. Where can I find those uploaded images on the CML server, as I would like to remove these but I can't find them at the moment.

 

Thanks in advance!

1 REPLY 1
shin.sterneck
Beginner

Hi Frank57510,

 

I did not have this issue, so can only advise you to have a look at the CML system logs while you are creating the image definition.

 

Just in case the image conversion is causing this problem, I used the following command to convert the vmdk file to qcow2:

qemu-img convert -c Win10-disk001.vmdk win10-disk001.qcow2 -O qcow2

BTW: How much space do you have left on the server? You can also compress the qcow image with the '-c' flag.

 

then used:

qemu-img info win10-disk001.qcow2

 

You might also want to do a qemu-img check (consistency check).

Other than that I also simply uploaded it using SCP and attached it to the image definition config.

 

2. On your second question on where you can find the uploaded images:

The files you upload will be located in the dropfolder:

/var/local/virl2/dropfolder

I simply uploaded a test file and ran a search to identify the location.

 

Let me know if you need any further help.

 

Regards,

Shin