cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
693
Views
5
Helpful
10
Replies

DHCP server bug on Cisco WS-C3850-12XS-E

madnanhassan
Beginner
Beginner

Hi Guyz,

I have configured Cisco WS-C3850-12XS-E work as DHCP Server and created multiple DHCP pools. All the pools were working normal for one week. Then some of the stop giving IP address to the device. after troubleshooting I found out all IP address is being reserve it self. I tried to create new pool but all 254 addresses reserve by default. Only two DHCP pool is working. Also when I create 172.16.x.x range pool it start to giving ip conflict error for multiple IP and we don't have 172.16 range in our network. Another problem I found all the lights of the ports blink as orange color since start even we don't have any configuration on the switch. Is there any bug fix for this issue? 

10 Replies 10

anboom
Cisco Employee
Cisco Employee

Good morning! What version of IOSXE are you using: show version 

https://www.cisco.com/c/en/us/td/docs/ios/fundamentals/command/reference/cf_book/cf_s4.html

and what is the DHCP configuration?

show run | i dhcp

Also, check wha the dhcp bindings are:

show ip dhcp binding

Please replace any public IP info with private addresses such as 10.0.0, 172.16, or 192.168.

 

Below is the partial configuration. 

 

Building configuration...

Current configuration : 11530 bytes
!

ip dhcp excluded-address 192.168.11.1 192.168.11.20
ip dhcp excluded-address 192.168.21.1 192.168.21.50
ip dhcp excluded-address 192.168.31.1 192.168.31.20
ip dhcp excluded-address 192.168.32.1 192.168.32.20
ip dhcp excluded-address 192.168.41.1 192.168.41.20
ip dhcp excluded-address 192.168.51.1 192.168.51.20
ip dhcp excluded-address 192.168.61.1 192.168.61.20
ip dhcp excluded-address 192.168.71.1 192.168.71.150
ip dhcp excluded-address 192.168.31.222 255.255.255.0
!
ip dhcp pool manage
network 192.168.11.0 255.255.255.0
default-router 192.168.11.1
dns-server 8.8.8.8
!
ip dhcp pool Camera
network 192.168.21.0 255.255.255.0
default-router 192.168.21.1
dns-server 8.8.8.8
!
ip dhcp pool WIFI_GF
network 192.168.31.0 255.255.255.0
default-router 192.168.31.1
dns-server 8.8.8.8
!
ip dhcp pool WIFI_1F
network 192.168.32.0 255.255.255.0
default-router 192.168.32.1
dns-server 8.8.8.8
!
ip dhcp pool Network_Data
network 192.168.41.0 255.255.255.0
default-router 192.168.41.1
dns-server 8.8.8.8
!

!
ip dhcp pool IOT
network 192.168.71.0 255.255.255.0
default-router 192.168.71.1
dns-server 8.8.8.8
!
!
!


!
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!

!
!

!
!
!
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
shutdown
negotiation auto
!
interface TenGigabitEthernet1/0/1
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/2
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/3
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/4
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/5
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/6
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/7
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/8
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/9
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/10
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/11
switchport trunk native vlan 11
switchport trunk allowed vlan 11,21,31,32,41,51,61,71
switchport mode trunk
!
interface TenGigabitEthernet1/0/12
description Point to Point Connection Firewall
no switchport
ip address 192.168.201.1 255.255.255.0
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface Vlan1
no ip address
!
interface Vlan11
ip address 192.168.11.1 255.255.255.0
!
interface Vlan21
description Camera
ip address 192.168.21.1 255.255.255.0
!
interface Vlan31
description WIFI_GF
ip address 192.168.31.1 255.255.255.0
!
interface Vlan32
description WIFI_1F
ip address 192.168.32.1 255.255.255.0
!
interface Vlan41
description Network_Data
ip address 192.168.41.1 255.255.255.0
!
interface Vlan51
description IP_Phone
ip address 192.168.51.1 255.255.255.0
!
interface Vlan61
description Armah_Guest
ip address 192.168.61.1 255.255.255.0
!
interface Vlan71
description IOT
ip address 192.168.71.1 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.201.2
!
!
!
!
!
!
control-plane
service-policy input system-cpp-policy
!

!
!
!
!
!
!
!
end

MLK1CORE01#

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

What firmware is the switch running on?

if you using ip tracking then this issue can be arise. 
do you use ip tracking ?

no I am not using IP tracking. This is fresh site there is no user right
now we are in the process of deployment. One week before i have created 4
vlan and DHCP pool for those vlan subnet which was working fine. Yesterday
suddenly one of the subnet stop giving IP address.
There was no configuration change. When I check ip binding non of the ip
showing belong to that subnet.
When i check ip dhcp pool is was showing all 254 ip reserved on two of dhcp
pool.
Then the created an other new dhcp pool with new subnet address then run
show ip dhcp pool surprisingly new pool also showing all ip reserved.


see above comment

ip dhcp excluded-address 192.168.31.222 255.255.255.0 <<<<<- remove this line this is source of issue 

192.168.31.XX subnet is working fine. when I configure same port in 31 vlan my PC getting IP address but same port change to vlan32 not getting ip address. Only subnet 11, 31 and 21 is working and DHCP end device getting IP address.

I think you are asking about connectivity. I can ping default gateway for all the interface vlan and if i give my Laptop or end device static ip i am able to ping all network.

255.255.255.0 <<- this is issue it include all ip, remove it and check again.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers