12-10-2023 01:51 PM - edited 12-10-2023 01:52 PM
Configuration for the switch (SW). Three interfaces configured: two access interfaces (GigabitEthernet0/0 and GigabitEthernet0/1) and one trunk interface (GigabitEthernet0/2). Additionally, I have two VLAN interfaces (Vlan10 and Vlan20) for Layer 3 routing.
# Access Interfaces
interface GigabitEthernet0/0
switchport access vlan 10
switchport mode access
negotiation auto
spanning-tree portfast edge
!
interface GigabitEthernet0/1
switchport access vlan 20
switchport mode access
negotiation auto
spanning-tree portfast edge
!
# Interface g0/2 in SWL3 To Interface g0/2 in vEdgeCloud
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
!
# SVI Configuration
interface Vlan10
description L3 DATA WAN Handoff
ip address 10.13.10.126 255.255.255.0
ip mtu 1496
interface Vlan20
description L3 DATA WAN Handoff
ip address 10.13.20.126 255.255.255.0
ip mtu 1496
Configuration for a vEdge device, I have two VPNs (VPN 10 and VPN 20) each with a subinterface representing a VLAN. Here's an overview and a few points to consider:
vpn 10
name "VPN10 LAN Service - DATA VLAN"
interface ge0/2.10
description "VPN10 LAN Interface"
ip address 10.13.10.253/24
mtu 1496
no shutdown
!
ip route 10.13.10.0/24 10.13.10.126 253
omp
advertise connected
advertise static
!
vpn 20
name "VPN20 LAN Service - VOICE VLAN"
interface ge0/2.20
description "VPN20 LAN Interface"
ip address 10.13.20.253/24
mtu 1496
no shutdown
!
ip route 10.13.20.0/24 10.12.20.126 253
omp
advertise connected
advertise static
!
Note: I add Template Lan Parent for interface g0/2 in vEdge but not connectivite
In cEdge with c8000v my config is correct but in vEdge not ping between SWL3 and vEdge what is this problem (dot1q ?)
Solved! Go to Solution.
01-23-2024 03:35 PM
For vEdge Cloud (non-5000, etc.), it does not support switchport mode (dot1q encapsulation for creating sub-interfaces). However, it is possible to create sub-interfaces by adding a parent interface with an MTU of 1504 belonging to vpn0. The sub-interfaces can then be added to their respective VPNs, for example, vpn10 or vpn20.
I have tested all possibilities, but nothing has changed. In my opinion, the issue lies in using vEdge Cloud in EVE-NG, which restricts the addition of other vEdges such as vEdge 5000 because the image is binary. I tried converting it to iOS and then to QEMU, but there were no results on EVE-NG.
The solution is to add two physical links as shown in the photo."
Configuration SW & vEdge cloud
Testing Connectivity
01-23-2024 03:35 PM
For vEdge Cloud (non-5000, etc.), it does not support switchport mode (dot1q encapsulation for creating sub-interfaces). However, it is possible to create sub-interfaces by adding a parent interface with an MTU of 1504 belonging to vpn0. The sub-interfaces can then be added to their respective VPNs, for example, vpn10 or vpn20.
I have tested all possibilities, but nothing has changed. In my opinion, the issue lies in using vEdge Cloud in EVE-NG, which restricts the addition of other vEdges such as vEdge 5000 because the image is binary. I tried converting it to iOS and then to QEMU, but there were no results on EVE-NG.
The solution is to add two physical links as shown in the photo."
Configuration SW & vEdge cloud
Testing Connectivity
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide