cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1100
Views
0
Helpful
8
Replies
Cisco Employee

Installation failed as it cannot remove previous installation (Windows 7)

Proximity was loaded on my Windows 7 machine and when I tried to open it today (haven't used it in a few weeks) the program would not initialize. I tried upgrading (using latest version) but it encounters an error saying that it cannot uninstall the previous version. I then cleaned out any instances of "Proximity" on my hard drive and registry but the installation still fails. Looking for a way to completely clean Proximity off my laptop so that I can install a working instance of the app.

I am Cisco internal.

8 REPLIES 8
Highlighted
Cisco Employee

Sorry about missing your post

Sorry about missing your post. If you are still experiencing errors, please follow the steps detailed in https://supportforums.cisco.com/discussion/13120371/proximity-setup-error so we can help you debug!

Cisco Employee

Thanks! I ran the first

Thanks! I ran the first command and got:

C:\>wmic path win32_product where 'Name = "Proximity"' call Uninstall
No Instance(s) Available.

Ran the second command:

C:\>msiexec /l*vx! install.log /qb! /i Proximity.msi ALLUSERS=2 MSIINSTALLPERUSE
R=1

and I got the same error message as before "The older version of Proximity cannot be removed. Contact your technical support group."

I attached the install.log (changed the file extension to .txt so it would upload).

Cisco Employee

There appears to be some

There appears to be some invalid or corrupt entries in your registry:

MSI (s) (50:40) [15:49:33:947]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKU\S-1-5-21-1708537768-1303643608-725345543-917831\Software\Microsoft\Installer\Products\646ACB579A1BFA84FBE9883D3E8D536A\SourceList'

https://www.experts-exchange.com/questions/26784932/net-windows-service-installation-error.html#answer34762613 appears to have worked for someone that had the same problem. Note that I have no experience using the “Windows Installer CleanUp Utility” nor with this particular issue.

If this works, or if it doesn't we're interested in hearing about it. If you remember exactly how you ended up in this situation, that would be great as well!

Cisco Employee

Appreciate your time on this.

Appreciate your time on this.

I gave that a shot, and pointed the registry key to the latest package on my C:\. Install now fails with an error that says that this install package is not a valid install package for the product. I'm guessing it's looking for the last installer I successfully used, but I don't have that one anymore. Any way to get my hands on previous versions?

I tried the two commands as well, attached the latest install.log file.

Cisco Employee

The old installation msi

The old installation msi might still exist under your temp directory, did you look there? Try to look there for filenames like proximity-[something].msi

C:\Users\aceccato\AppData\Local\Temp\

If you can't find it, did you try the cleanup utility mentioned in the article?

Cisco Employee

I just tried the cleanup

I just tried the cleanup utility, it didn't see anything for Proximity so it was no help unfortunately.

However, I went through the registry (searched for "Proximity) and removed all entries. After that, I ran the two commands again and Proximity installed. It's complaining about my audio settings but maybe it just wants a reboot (my audio device settings look good according to the Proximity website).

Thanks for spending time with me on this!

Cisco Employee

Excellent! If you have any

Excellent! If you have any details regarding how you ended up with a non-working Proximity installation, we'd love to hear them.

Cisco Employee

My original posts details

My original posts details that as exactly as I can. Hoping that it is clear enough for you to understand the history, let me know if not?

Thanks again, I'm one of the ACE engineers, so we're always testing Proximity and other collaboration products/services in our EFT environment. It's very helpful to have this on my Windows laptop for testing and providing feedback to the BU.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards