Showing results for 
Search instead for 
Did you mean: 

Cisco ASR 1004 Rommon Upgrade Issue

Level 1
Level 1

Hello community,


I don't know it's right place for discuss this problem. Sorry for that. I'll be very grateful if you help me in this case.


My task was:
1) Upgrade Rommon Image

2) Upgrade IOS-XE Image


The problem is that when I upgraded Cisco ASR 1004 Rommon Image from 15.0(1r)S version to 16.3(2r) version I was successful in 2 components (0 and F0) and failed in 1 component (R0). I provided show platform command output in the attachment. I used upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg command and there was no error or fail during Rommon upgrade. After that I reloaded Router. When the Router booted I saw that SIP and ESP components upgraded, but Route Processor component not upgraded. I don't know why Route Processor component not upgraded. After that I tried to upgrade IOS-XE Image from asr1000rp1-adventerprisek9.03.08.00.S.153-1.S.bin to asr1000rp1-adventerprisek9.03.13.10.S.154-3.S10-ext.bin and failed again.


In addition I provided show version command output in the attachment. Please help.

16 Replies 16

Leo Laohoo
Hall of Fame
Hall of Fame
Did you verify if the new firmware is not corrupt?

I verified the hash file and its MD5 Checksum is the same in the cisco download site.

@bagiyevramin wrote:
upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg 

If I remembered correctly, the correct syntax should be 

upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg ALL

The last option, "all", instruct to push the ROMMON to all the components.

Yeah sure, I also did all, but forget write here. The command was like below:
upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg all

i see in the sho platform that it is an old RP1, and the v16.3 rommon might not be supported for the rp1.

and as far as upgrading the image, if you have access to the console, please capture the whole reboot to a text file. That should lead somewhere as to why the upgrade did not work.

@cmarva wrote:

and as far as upgrading the image, if you have access to the console, please capture the whole reboot to a text file. That should lead somewhere as to why the upgrade did not work.

I have access to the console. Unfortunately, I didn't capture the whole reboot process. I will take this into account next time.

v16.3 rommon image is supported, because I downloaded this image from Cisco Official Site.
Before this command (upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg all) in addition to RP1 SIP10 and ESP10 components were in v15.0.

that's not the point I was making. sure, 16.3.2r is avaiable, but if you look BASED on hardware for the asr1004, rp1, the available rommon image only goes up to 15.5.3r-s1. That leads me to believe, that for an rp1, that is the newest that is supported on an rp1.


have you been able to capture output from the console when you've tried upgrading to 16.3.2r? From experience, there is a very good chance there will be a message as to why it is failing.


but I would try going to 15.5.3r-s1 for the route processor because I believe that will work.

After SIP and ESP were successfully upgraded to version 16.3(2r), I tried upgrade Route Processor separately in different times to versions 15.4(2r)S and 15.5(3r)S1, but failed again. The commands was like below:
upgrade rom-monitor filename bootflash:asr1000-rommon-155-3r.S1.pkg R0
upgrade rom-monitor filename bootflash:asr1000-rommon.154-2r.S.pkg R0

But i didn't tried to do these:
upgrade rom-monitor filename bootflash:asr1000-rommon-155-3r.S1.pkg all
upgrade rom-monitor filename bootflash:asr1000-rommon.154-2r.S.pkg all

Try this: 

upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg r0

And then reboot the router. 

I also tried this:

upgrade rom-monitor filename bootflash:asr1000-rommon.163-2r.pkg r0

and rebooted Router, but there's no result. 

Contact Cisco TAC.
The R0 line card may need to be manually reset.