Showing results for 
Search instead for 
Did you mean: 

Cisco ASR920-12 usb problem.

yo, i have a problem when trying to upgrade the ROMMON & Software via USB-stick. when i connect the usb to the Cisco it dosent show and i cant copy the files from usb to the cisco.

i dont seem to have any usb_modem when i hit #dir bootflash

the usb stick is a FAT32 and have worked completley fine until we got this last bunch of new ciscos.

it feels like the usb port is dead.

anyone had the same problem?

Leo Laohoo
VIP Community Legend

Either the USB stick is unsupported (you'll see the error message in the logs) or someone has disabled the USB ports.

The USB stick was working yesturday, but we got a new delivery of ciscos, and half of them are working fine, and the rest not responding when we connect the USB stick. Do you know how to enable the usb ports?

Have a look at CSCvd78451.

Maybe check out CSCvn69017 ?




@martinOsbourne8382 wrote:

Maybe check out CSCvn69017 ?

Thanks for the tip, unfortunately, this Bug ID is "internal" only.

Ah obviously internal for a reason. I am still chasing Cisco for a solution will keep you informed 



i hit the command sh usb_status now and it was enabled. so i still can't understand why it dosent show when i insert the usb stick.

If USB is enabled, what does the logs say? 

When anyone inserts a USB stick, whether it works or not, something will be generated in the logs. 

Another option, try a different model/brand of USB stick.  Maximum size:  16 Gb.

i have tried 4 diffirent new usb sticks. and nothing shows up in sh log, i still have 71 messeges in logs when i have usb connected and disconnected. i feel like the light's about to fade, im out of ideas.

What firmware is the router running on?

it is running on 15.6(17r)s

@Generalen123 wrote:

it is running on 15.6(17r)s

15.6(17r)S is the ROMMON version. 
Show us the complete output to the command "sh version".



I have this issue as well , I am beginning to think that this is a feature (*read* bug), I received a number of ASR920 routers manufacturing date January 2021, placed my well used USB stick in and it did not automatically load, I have used the same USB stick for the last year and it doesn't work on these new routers when the IOS is loaded however if I go into rommon I can see the USB drive and its contents, my older ASR routers still recognize my USB stick when running IOS. 


Has something changed in the linux OS ? 


rommon 2 > dev
Devices in device table:
id name
bootflash: Internal disk
usb0: USB disk
rommon 3 > dir usb0:
Checking USB devices..
scanning USB bus for devices..
2 USB Device(s) found
scanning bus for storage devices...

USB Mass Storage device detected
1 Storage Device(s) found
File System: FAT32

3 0 drw- System Volume Information
6 13844 -rw- ASR920 Licentie update.docx
7 1586124 -rw- asr920_15_6_32r_s_rommon.pkg
104 446536100 -rw- asr920-universalk9_npe.16.09.04.SPA.bin
27359 32 -rw- asr920-universalk9_npe.16.09.04.SPA-MD5.txt
rommon 4 >




Ok, two people reporting exactly the same thing ... Sounds like an "undocumented feature" alright. 

So the router is currently running 16.9.4, right? 
Can you try to DOWNGRADE the IOS-XE?  Any version will do fine.  

@martinOsbourne8382 & @Generalen123, I strongly encourage the two of you (&/or anyone else) to raise a TAC Case.  Something does not smell right.  This is either a software bug or a hardware issue.  Either way, not good. 

Content for Community-Ad