cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1556
Views
10
Helpful
5
Replies

isr4300-universalk9.16.12.05.SPA.bin really s**t with LACP?

Is this 4331 really start after reload with LACP enabled per-vlan load-balance?

port-channel load-balancing vlan-manual

interface Port-channel1
 no ip address
 no negotiation auto
 lacp fast-switchover
 lacp max-bundle 2

interface Port-channel1.54
 encapsulation dot1Q 54 primary GigabitEthernet0/0/2 secondary GigabitEthernet0/0/1
 ip vrf forwarding VOIP
 ip address 2.2.2.2 255.255.255.240
 ip broadcast-address 2.2.2.15
 no ip proxy-arp
 service-policy output QOS_POLICY

interface Port-channel1.55
 encapsulation dot1Q 55 primary GigabitEthernet0/0/1 secondary GigabitEthernet0/0/2
 ip vrf forwarding ISP1
 ip address 1.1.1.1 255.255.255.248
 ip broadcast-address 1.1.1.7
 no ip proxy-arp
 ip nat inside
 service-policy output INTERNET_INBOUND_POLICY


interface GigabitEthernet0/0/1
 no ip address
 no ip proxy-arp
 media-type rj45
 speed 1000
 no negotiation auto
 service-policy output AGGREGATE_MEMBER_LINK
 channel-group 1 mode active

interface GigabitEthernet0/0/2
 no ip address
 no ip proxy-arp
 media-type sfp
 speed 1000
 no negotiation auto
 service-policy output AGGREGATE_MEMBER_LINK
 channel-group 1 mode active
1 Accepted Solution

Accepted Solutions

Thanks for the idea. I got desperate - not 17.3.2 not 17.2.2 releases did not help. I already thought: "Horrible piece of s**t", back to the bridge IRB. And Torvalds in my head said: take a closer look at this code ... After 15 minutes I wrote an EEM script, it works.

event manager applet BOOTUP authorization bypass
 event timer cron cron-entry "@reboot"
 action 1.0 syslog msg "Applying port channel configuration"
 action 1.1 cli command "enable"
 action 1.2 cli command "configure terminal"
 action 2.1 cli command "interface GigabitEthernet0/0/1"
 action 2.2 cli command "no channel-group 1"
 action 2.3 cli command "channel-group 1 mode active"
 action 2.4 cli command "exit"
 action 3.1 cli command "interface GigabitEthernet0/0/2"
 action 3.2 cli command "no channel-group 1"
 action 3.3 cli command "channel-group 1 mode active"
 action 3.4 cli command "end"

 

View solution in original post

5 Replies 5

balaji.bandi
Hall of Fame
Hall of Fame

Sorry we are not able to understand the issue here - is the LB is not working, or is the command is the issue ?

port-channel load-balancing vlan-manual

 

Load Balancing on Port Channels

GEC interfaces can use either dynamic flow-based load balancing or VLAN-manual load balancing. You can configure the load-balancing method globally for all port channels or directly on specific port channels. The global configuration applies only to those port channels for which you have not explicitly configured load balancing. The port-channel configuration overrides the global configuration.

Flow-based load balancing is enabled by default at the global level. You must explicitly configure VLAN load balancing or the load-balancing method is flow-based.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

After restart HW (reload) configuration changed from:

interface GigabitEthernet0/0/1
channel-group 1 mode active

to:

interface GigabitEthernet0/0/1
channel-group 1

Can you post show version complete output.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help


@SystemEngineer32313 wrote:

After restart HW (reload) configuration changed from:

interface GigabitEthernet0/0/1
channel-group 1 mode active

to:

interface GigabitEthernet0/0/1
channel-group 1

Raise a TAC Case.  
This is a known bug:  CSCvw74609

Also, be aware of CSCvx32090.

Thanks for the idea. I got desperate - not 17.3.2 not 17.2.2 releases did not help. I already thought: "Horrible piece of s**t", back to the bridge IRB. And Torvalds in my head said: take a closer look at this code ... After 15 minutes I wrote an EEM script, it works.

event manager applet BOOTUP authorization bypass
 event timer cron cron-entry "@reboot"
 action 1.0 syslog msg "Applying port channel configuration"
 action 1.1 cli command "enable"
 action 1.2 cli command "configure terminal"
 action 2.1 cli command "interface GigabitEthernet0/0/1"
 action 2.2 cli command "no channel-group 1"
 action 2.3 cli command "channel-group 1 mode active"
 action 2.4 cli command "exit"
 action 3.1 cli command "interface GigabitEthernet0/0/2"
 action 3.2 cli command "no channel-group 1"
 action 3.3 cli command "channel-group 1 mode active"
 action 3.4 cli command "end"

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: