キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
告知

 MayCL_topbanner.JPG

 

JPNE 「v6プラス」固定IPサービス への IOS-XEルータ サンプルコンフィグ (ひかり電話を契約している場合 DHCP-PD編)

659
閲覧回数
0
いいね!
0
コメント
日本ネットワークイネーブラー株式会社(JPNE)が提供する「v6プラス」固定IPサービスへCisco IOS-XEルータを接続するためのサンプル設定を公開します。
※ 「v6プラス」固定IPサービスについては、こちら: https://www.jpne.co.jp/service/v6plus-static/
 
本設定例では下記を使用しております。
※IOS-XEルータ C1111X-8P
※WAN側に Gi0/0/0、LAN側にSwitchport(Gi0/1/x)を使用。
IOS-XEルータをHGWに接続します。(ひかり電話ホームゲートウェイ)
DHCP-PDによりIPv6 Prefixを取得します。
生成されたIPv6アドレスをSourceにしたIPv4 over IPv6トンネルを構成します。
 
ご契約された回線事業者より下記情報を入手します。
-固定 IPv4 アドレス 
-インターフェースID
-BRアドレス
以下はオプション
-再設定ユーザID
-再設定パスワード
 
 
=============
 Sample Config
=============
 
### ipv6 unicast routing 設定  (Global Configuration Mode) ###
ipv6 unicast-routing
 
### LAN側デバイスに対するIPv6サーバー設定 ###
ipv6 dhcp pool STATELESS
import dns-server
import domain-name
 
### WAN側物理インターフェース設定 ###
interface GigabitEthernet0/0/0
description 'WAN side'
no ip address
negotiation auto
ipv6 address FE80::(ISPより指定されたインターフェースID) link-local
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd PREFIX
!
 
### トンネルインターフェース設定 ###
interface Tunnel0
description 'ipv4 over ipv6 tunnel
ip address (ISPより指定された固定IPv4アドレス x.x.x.x) (サブネットマスク y.y.y.y)
ip nat outside
ip tcp adjust-mss 1300
tunnel source GigabitEthernet0/0/0
tunnel mode ipv6
tunnel destination  (BRのIPv6アドレス)
!
### LAN側物理インターフェース設定 ###
interface Vlan1
ip address 198.51.100.254 255.255.255.0 (LAN側のIPアドレス)
ip nat inside
ip tcp adjust-mss 1300
ipv6 address PREFIX ::1:0:0:0:1/64
ipv6 dhcp server STATELESS
!
 
### NAT(PAT)設定 NAT対象のLAN側のデバイス(PC等)のIPアドレスを指定 ###
ip nat inside source list 23 interface Tunnel0 overload
ip access-list standard 23
10 permit 198.51.100.0 0.0.0.255
 
### ルーティング設定 IPv4トラフィックをTunnel0 (IPv4 over IPv6トンネル)にルーティング###
ip route 0.0.0.0 0.0.0.0 Tunnel0
 
 
==========
 オプション 
==========
※割り当てられた IPv6 Prefix に変更が発生する場合があります。
・割り当てられたIPv6Prefixが変更された場合、すぐには変更に追従できなことがあります。
・IPv6Prefix変更のタイミングで、プロバイダより指定されたURLへ指定のIDとパスワードでアクセスするとIPv6とIPv4固定アドレスが再設定されます。
・下記の通り手動設定、自動設定のいずれかの方法により任意のタイミングで再設定が可能です。
・自動再設定の場合、10分以上の間隔での指定URLへのアクセスをお願いします。
 
a) 手動再設定
Webブラウザによる IPv6 Prefix 再設定 
プロバイダーより提供される設定通知のURLにブラウザからアクセス ※v6プラス回線のIPv6からのみアクセス可能  
指定されたユーザID/パスワードを入力し [再設定]をクリックします。
 
b) 自動再設定
CE機器(ルータ)による IPv6 Prefix 再設定
※ルータで下記スクリプトを設定します。IPv6 Prefix変更発生後、指定のタイミング(*)で再設定されます。
指定のタイミング = 10分以上の間隔で指定します。
 
### TCL設定 ###
IOS-XE#tclsh
IOS-XE(tcl)#puts [open bootflash:/v6plus.tcl w+] {
+> set result [exec {more http://(ISPから指定されたURL)/update?user=(ISPから指定の再設定ユーザID)&pass=(ISPから指定の再設定パスワード)}]
+>}
IOS-XE(tcl)#exit
 
### kron(スケジューラ)設定 (Global Configuration Mode) ###
※下記サンプルは、上記 TCLで設定したHTTP getを10分間隔でスケジューリングします。(10分以上で設定します)
kron occurrence v6plus_update in 10 recurring system-startup
policy-list v6plus_policy
!
kron policy-list v6plus_policy
cli tclsh bootflash:v6plus.tcl
!
 
### HTTP 出力インターフェース指定  (Global Configuration Mode) ###
ip http client source-interface GigabitEthernet 0/0/0
 
 
Content for Community-Ad



このウィジェットは表示できません。