キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
告知

JTAC-Mid-Career-Recruitment-2021.8

 

マルチ PPPoE クライアントを設定する

6603
閲覧回数
0
いいね!
0
コメント

1 つの物理 WAN インターフェイスに複数の PPPoE クライアント論理インターフェイスを設定する、マルチ PPPoE クライアントの設定例について紹介します。この設定例で想定しているシナリオは次のとおりです。

  • 営業部門(VLAN10)からはプロバイダ 1 でインターネットに接続
  • 人事部門(VLAN20)からはプロバイダ 2 でインターネットに接続


ルータの基本設定を開始します。

ステップ①:CLI にアクセスしてログイン、グローバル コンフィギュレーション モードに移行

yourname#configure terminal

ステップ②:ホスト名を設定(本シナリオでは Router

yourname(config)#hostname Router

ステップ③no ip domain lookup コマンドを入力

Router(config)#no ip domain lookup

【メモ】
シスコ ルータにはデフォルトで、認識できない文字列が入力された場合にネットワーク上の DNS サーバにブロードキャスト(255.255.255.255)で問い合わせる機能があります。問い合わせの間、コマンドの入力ができない状態が続くため、no ip domain lookup コマンドで、この機能を無効化することを推奨します。

続いて、ルータの LAN 設定を開始します。
このシナリオでは、GigabitEthernet0/1 および GigabitEthernet0/2 でLAN に接続しています。それぞれに VLAN を設定します。

ステップ④:VLAN を作成

Router(config)#vlan 10
Router(config-vlan)#name SALES
Router(config-vlan)#vlan 20
Router(config-vlan)#name HR

【メモ】
このシナリオでは、VLAN10 を営業部門ネットワーク(SALES)、VLAN20 を人事部門ネットワーク(HR)としています。

ステップ⑤:インターフェイスを設定

Router(config-vlan)#interface GigabitEthernet0/0
Router(config-if)#no ip address
Router(config-if)#interface GigabitEthernet0/1
Router(config-if)#description to_SALES
Router(config-if)#switchport access vlan 10
Router(config-if)#no ip address
Router(config-if)#interface GigabitEthernet0/2
Router(config-if)#description to_HR
Router(config-if)#switchport access vlan 20
Router(config-if)#no ip address
Router(config-if)#interface GigabitEthernet0/3
Router(config-if)#no ip address

【メモ】
このシナリオでは、GigabitEthernet0/1 が営業部門ネットワークに、GigabitEthernet0/2 が人事部門ネットワークに接続しています。GigabitEthernet0/1 インターフェイスを営業部門ネットワークの VLAN10 アクセス ポートに設定し、GigabitEthernet0/2 インターフェイスを人事部門ネットワークの VLAN20 アクセス ポートに設定します。

ステップ⑥:VLAN インターフェイスを作成および設定

Router(config-if)#interface Vlan10
Router(config-if)#description to_SALES-LAN
Router(config-if)#ip address 192.168.10.254 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#ip virtual-reassembly in
Router(config-if)#interface Vlan20
Router(config-if)#description to_HR-LAN
Router(config-if)#ip address 192.168.20.254 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#ip virtual-reassembly in

【メモ】
このシナリオでは、VLAN10 のネットワーク アドレスを 192.168.10.0/24、VLAN20 のネットワーク アドレスを 192.168.20.0/24 として、それぞれアドレス変換(NAT/PAT)における内部(LAN 側、プライベート ネットワーク側)であると定義します。

続いて、ルータの WAN 設定を開始します。
このシナリオでは、GigabitEthernet0/4 で WAN に接続しています。GigabitEthernet0/4 に、プロバイダに接続するための論理インターフェイスを設定します。

ステップ⑦:インターフェイスを設定

Router(config-if)#interface GigabitEthernet0/4
Router(config-if)#description to_ISPs
Router(config-if)#no ip address
Router(config-if)#duplex auto
Router(config-if)#speed auto
Router(config-if)#interface GigabitEthernet0/5
Router(config-if)#no ip address
Router(config-if)#shutdown
Router(config-if)#duplex auto
Router(config-if)#speed auto

【メモ】
物理インターフェイス GigabitEthernet0/4 に IP アドレスは設定しません。

ステップ⑧:PPPoE を有効化

Router(config-if)#pppoe enable group global
Router(config-if)#pppoe-client dial-pool-number 1
Router(config-if)#pppoe-client dial-pool-number 2
Router(config-if)#no shutdown

【メモ】
物理インターフェイス GigabitEthernet0/4 で、あとで作成する論理インターフェイス Dialer1 および Dialer2 を使用して、PPPoE セッションを確立するための設定です。pppoe-client dial-pool-number 1 は Dialer1 にあとで設定する dialer pool 1 とマッピング、pppoe-client dial-pool-number 2 は Dialer2 にあとで設定する dialer pool 2 とマッピングされます。

ステップ⑨:論理インターフェイス Dialer1 を作成および設定

Router(config-if)#interface Dialer1
Router(config-if)#description to_ISP1

【メモ】
このシナリオでは、プロバイダ 1 との PPPoE セッションは、論理インタフェース Dialer1 の動作によって確立要求されます。

Router(config-if)#ip address negotiated
Router(config-if)#ip nat outside
Router(config-if)#ip virtual-reassembly in

【メモ】
PPP セッションの確立時に IP アドレスがダイナミックにアサインされます。アドレス変換(NAT/PAT)における外部(WAN 側、グローバル ネットワーク側)であると定義します。

Router(config-if)#encapsulation ppp

【メモ】
PPP カプセル化によって、パケットが入出力されます。

Router(config-if)#dialer pool 1

【メモ】
dialer pool 1 は、物理インターフェイス GigabitEthernet0/4 にステップ⑧で設定した pppoe-client dial-pool-number 1 とのマッピングです。

Router(config-if)#dialer-group 1

【メモ】
あとで定義するトラフィック パターン dialer-list 1 を使用して、このパターンにマッチするトラフィックをダイヤル対象として認識して PPPoE セッションの確立要求を起動するための設定です。

Router(config-if)#ppp authentication chap callin
Router(config-if)#ppp chap hostname ISP1@cisco.com
Router(config-if)#ppp chap password 0 cisco

【メモ】
プロバイダとの認証方法を CHAP に指定します。callin パラメータによって、プロバイダによるユーザ認証の片方向でのみ認証されます。このシナリオでは、プロバイダ 1 から提供されるユーザ名を ISP1@cisco.com、パスワードを cisco としています。

Router(config-if)#ppp ipcp dns request accept
Router(config-if)#ppp ipcp route default

【メモ】
DNS サーバ アドレスを PPP 接続時に自動取得するように設定し、BAS(Broadband Access Server)のアドレスをネクスト ホップとしたデフォルト ルートを自動生成するように設定します。

ステップ⑩:論理インターフェイス Dialer2 を作成および設定

Router(config-if)#interface Dialer2
Router(config-if)#description to_ISP2

【メモ】
このシナリオでは、プロバイダ 2 との PPPoE セッションは、論理インタフェース Dialer2 の動作によって確立要求されます。

Router(config-if)#ip address negotiated
Router(config-if)#ip nat outside
Router(config-if)#ip virtual-reassembly in

【メモ】
PPP セッションの確立時に IP アドレスがダイナミックにアサインされます。アドレス変換(NAT/PAT)における外部(WAN 側、グローバル ネットワーク側)であると定義します。

Router(config-if)#encapsulation ppp

【メモ】
PPP カプセル化によって、パケットが入出力されます。

Router(config-if)#dialer pool 2

【メモ】
dialer pool 2 は、物理インターフェイス GigabitEthernet0/4 にステップ⑧で設定した pppoe-client dial-pool-number 2 とのマッピングです。

Router(config-if)#dialer-group 2

【メモ】
あとで定義するトラフィック パターン dialer-list 2 を使用して、このパターンにマッチするトラフィックをダイヤル対象として認識して PPPoE セッションの確立要求を起動するための設定です。

Router(config-if)#ppp authentication chap callin
Router(config-if)#ppp chap hostname ISP2@cisco.com
Router(config-if)#ppp chap password 0 cisco

【メモ】
プロバイダとの認証方法を CHAP に指定します。callin パラメータによって、プロバイダによるユーザ認証の片方向でのみ認証されます。このシナリオでは、プロバイダ 2 から提供されるユーザ名を ISP2@cisco.com、パスワードを cisco としています。

Router(config-if)#ppp ipcp dns request accept
Router(config-if)#ppp ipcp route default

【メモ】
DNS サーバ アドレスを PPP 接続時に自動取得するように設定し、BAS(Broadband Access Server)のアドレスをネクスト ホップとしたデフォルト ルートを自動生成するように設定します。
なお、プロバイダ 2 でも DNS サーバ アドレスを取得する目的は、プロバイダ 1 の DNS サーバ アドレスが許可する DNS 要求が、論理インタフェース Dialer1 経由の通信に限定される可能性が高いからです。多くのプロバイダでは、DDoS 攻撃などの温床となることを予防するため、許可する DNS 要求を PPPoE 認証で割り当てた IP アドレスからの要求に制限しています。 

ステップ⑪:PPPoE セッション確立要求のトリガーとなるトラフィックを定義

Router(config)#dialer-list 1 protocol ip permit
Router(config)#dialer-list 2 protocol ip permit

【メモ】
dialer-list 1 および dialer-list 2 で適用させるトラフィックを指定します。このシナリオでは、すべての IP トラフィックをダイヤル対象に設定します。

ステップ⑫:アドレス変換(PAT)を設定

Router(config)#access-list 1 permit 192.168.10.0 0.0.0.255
Router(config)#access-list 2 permit 192.168.20.0 0.0.0.255


【メモ】
ネットワーク 192.168.10.0/24 および 192.168.20.0/24 を送信元とするトラフィックがマッチするアクセス リストです。

Router(config)#ip nat inside source list 1 interface Dialer1 overload
Router(config)#ip nat inside source list 2 interface Dialer2 overload

【メモ】
access-list 1 にマッチするトラフィックは Dialer1 インターフェイスの IP アドレスをグローバル アドレスとして利用してアドレス変換(PAT)されて、access-list 2 にマッチするトラフィックは Dialer2 インターフェイスの IP アドレスをグローバル アドレスとして利用してアドレス変換(PAT)されます。

以上で、本シナリオの設定は完了です。

作成
推薦したいメンバーがいます
Content for Community-Ad