Showing results for 
Search instead for 
Did you mean: 

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files


For me it had to do with the

For me it had to do with the port being used for the SIP trunk between Expressway-C and CUCM. We were overlapping the default 5060 which it didn't like. It wasn't clear in the documentation. But in my case Phone Services never connected through Expressway but worked internally.


It working sometimes but not others will probably require you to look at logs to find out why it's not always connecting.

Yes Jakub,I have sorted out

Yes Jakub,

I have sorted out it by changing the port from 5060 to 5065 and it worked and now checking the ports 2776 and 2777 on firewall as it seems they are blocked between expressway-C and E.




Glad it worked out :)

Glad it worked out :)


Hopefully this can help someone else out in the future. I remember spending a lot of time on this problem. IM was working but phone services would not connect.

Hi Gents,As i have shared the

Hi Gents,

As i have shared the info every thing is workign fine including voice which was not working due to ports 2776 and 2777 was blocked on firewall. Now i am facgin another challenge.

I have two IM servers in HA mode and now all the users from IM pub can login while all the users which are associated with IM subs are getting error on Jabber that can not locate to the server. When i have checked their confign on Jabber Iphone i have found the automatic configuration is routing to only IM Pub server and not checking both servers. 

Any help would be great.

Hi Sheraz.Did you configure ,

Hi Sheraz.

Did you configure , on user service profile both IM&P servers?

Are all users able to login while inside the corporate LAN?


Please let me know






Please rate all helpful posts "The more you help the more you learn"

Hi Carlo,Where can i check

Hi Carlo,

Where can i check this on user service profile settings. Yes internally all users are able to login regardless of their users registration server.




Hi Sheraz.You can check it on

Hi Sheraz.

You can check it on 

"User Management" -->> "User Settings" --->> "UC Service" to check if both IM&P servers were defined.

 "User Management" -->> "User Settings" --->> "Service Profile" to see if a Service Profile has been defined and both server are there as Primary and Secondary.


Once all above is fine, check that all interested users have a Service Profile defined on "User Management" -->> "End User"

Select one user and check "UC Service Profile" value.









Please rate all helpful posts "The more you help the more you learn"

Hi Carlo,Okay i have checked

Hi Carlo,

Okay i have checked the both IM servers are added in also in UC service profile IM subscriber is also added as secondary server but the status is same. When i make both IM servers UP all the users which are associated to IM server 2 doesn't get login.




Hi Jakub.I upgraded to 8.5.2

Hi Jakub.

I upgraded to 8.5.2 from 8.5.1 with no issue, but I found this issue after an upgrade from 8.5.2 to 8.5.3.

I think that 8.5.1 is the most stable release till now.





Please rate all helpful posts "The more you help the more you learn"

I tried 8.5.3 this morning

I tried 8.5.3 this morning and reverted back to 8.5.1


I was unable to reach my CUCM from Expressway C anymore. Reverting fixed the issue again. I think I might just stick with 8.5.1 since it just works

Hi all,i start a new

Hi all,

i start a new installation for a my custoemer with cucm 10.5.2 and expressway 8.5.2, upgraded in a second step to 8.5.3

I have complete the MRA configuration without any warnings, but form intenternet  the Jabber can't login.

the jabber client  says "wrong user or pwd".

from the Exp-c logs i can see:


2015-06-19T13:42:05+02:00 expc UTCTime="2015-06-19 11:42:05,761" Module="developer.edgeconfigprovisioning.uds" Level="INFO" CodeLocation="udsmanager(593)" Service="UDSManager" Detail="Found user cluster" Identity="('username', 'carlo.michelotti')" Cluster=""
2015-06-19T13:42:05+02:00 expc edgeconfigprovisioning: Level="WARNING" Service="UDSManager" Detail="User cluster not found" Identity="('username', 'carlo.michelotti')" Cluster="" Reason="UC node not found" UTCTime="2015-06-19 11:42:05,761"
2015-06-19T13:42:05+02:00 expc edgeconfigprovisioning: Level="WARNING" Service="ECS" Detail="Request failed" User="('username', 'carlo.michelotti')" Reason="Home CUCM not available - Tried all available UDS" UTCTime="2015-06-19 11:42:05,761"
2015-06-19T13:42:05+02:00 expc edgeconfigprovisioning UTCTime="2015-06-19 11:42:05,761" Module="network.http.edgeconfigprovisioning" Level="DEBUG" Action="Send" Local-ip="" Local-port="22110" Src-ip="" Src-port="32151" 
|HTTP/1.1 401 Unauthorized
 WWW-Authenticate: Basic realm="Cisco-Edge"
 Server: CE_C ECS

not sure that I'm in the same case of other user there, but I'll try to downgrade to 8.5.1

I will update you..





I'm having this exact problem

I'm having this exact problem after upgrade from 8.5.1 to 8.5.3. The users are getting the invalid username or password.

I will try to downgrade to version 8.5.1.

2015-06-23T18:07:35-04:00edgeconfigprovisioning: Level="WARNING" Service="ECS" Detail="Request failed" User="" Reason="Home CUCM not available - Tried all available UDS" UTCTime="2015-06-23 22:07:35,870"
2015-06-23T18:07:35-04:00edgeconfigprovisioning: Level="WARNING" Service="UDSManager" Detail="User cluster not found" Identity="" Cluster="" Reason="UC node  not found" UTCTime="2015-06-23 22:07:35,870"

The issue is still remains at

The issue is still remains at 8.5.3 if you are using split/multiple domains, please see the following the 

links from bug tool search. From my experience 8.5.1 version is more stable for the MRA deployment.


What version of CUCM are you

What version of CUCM are you running? 10.5(1) is not compatible with X8.5.3. If you upgrade CUCM to 10.5(2) everything works as intended.

Great suggestion Jakub+5;)

Great suggestion Jakub








Please rate all helpful posts "The more you help the more you learn"
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards