cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
21534
Views
4
Helpful
26
Replies
Highlighted
Beginner

Call option not appearing in jabber for windows client.

I have set up a CUCM cluster 9.1, a Unified IM and Presence server 9.1 and an LDAP server as well.

I can login as the users that i have created in the AD, can also chat with them and see their presence status. But i don't get a 'call' option when i right click on them.

I have enclosed a screenshot of the jabber client.

Is there something that am not doing? Kindly help if you have an idea.

26 REPLIES 26
Highlighted
Cisco Employee

have you created a csf device in CUCM and assigned it to the user?

Highlighted

yes, its done. But it wasnt registering. I just reviewed it and found that in the uc profile for IM and presence, i was pointing towards the ad and not presence.

Highlighted
Beginner

I have the same problem.

Already create the CSF and its assigned. We also reviewed the user licensing and the corresponding settings in the Presence Server.

Vamsy do you have all the pc in the same windows domain?

Thanks

Highlighted

The users are in the same domain, if thats what you mean. Try assigning the associated user to the csf profile in the phone profile page. There is a field called owner user id. Make it point to the appropriate user.
My calling is working fine now but am not really sure as to what was exactly wrong. Ill get back as soon as i figure it out.

Highlighted

Hello Vamsy

Thank you so much for your quick answer.

I reviewed and the owner user id its already assigned to the appropiate user.

I've got some user outside the domain, but for some of them the calls are working. That's why I don't think that could be affecting the other users that cannot make calls.

If you could figure it out please be so kind to let me know.

Regards

Highlighted

Have u created a UC profile in your CUCM? For IM and Presence? which server is it pointing to?
Please comment which version of CUCM, Presence and Jabber you using?

Highlighted

HI Vamsy,

You should be able to create a CTI - UC Profile and point it to the CUCM IP Address not CUPS because CUPS does not handle calls, one that is assigned you must assign it to the service profile. The CSF must be able to register, however if you don't see it registered you may want to go to CUPS and under Application and Legacy Clients go to settings and check if you have the right TFTP Address and CCMIP profile created and assigned to the user.

Highlighted

Hey Joshua,

My problem has been fixed. Though am not sure what exactly went wrong. Maybe you can help me figure out.

  1. The UC profile/CCMCIP profile are not the resons. As i said, am using IM and Presence server, not cups and jabber 9.2. CCMCIP applies only for Jabber 8.X. 
  2. As for the service profile, thpugh i have created UC services and asigned them to the profile, i haven't made it the default profile. The users still have 'none' in the UC service profile option.
  3. Am using jabber as a softphone only, so am eliminating CTI - profile as the problem.
  4. There is a jabber-config .xml file that tells the AD IP address, the credentials and the search base.

With these configurations everything works fine.
The only thing that must have been wrong in my case is the owner user ID field. Apart from that i dont know why this was happening.

Highlighted

It might have been that the end users did not have the default profile assigned to them, that's the only thing that crosses my mind now.

Highlighted

Hello Guys!

Thats great Vamsy, I also could make this work. In my case the remedy was the jabber-config.xml file that I deployed only in the users that are outside the domain.

I change de EDI integration for UDS adding the next xml file, so the user will not search the credentials in the AD instead it will do the lookup in the CUCM

  UDS

 

true

  presence

And  I add this XML file in the following file of each user outside the domain:

C:\Users\mrios\AppData\Roaming\Cisco\Unified Communications\Jabber\CSF\Config

Highlighted
Beginner

Hi Guys,

I'm currently experience this issue, when i right click on my contact the call option is not appearing. I'm using Jabber for Windows 9.2.1, CUCM 9.1 and IM&P 9.1

I've the UC profile assigned to the user as well as the jabber-config.xml list.

Any idea?

TIA

Highlighted

Hi,

probably your Jabber is not connected to any phone system - CSF or normal phone.

In Help - Connection Status you have 2 informations:

- Softphone

- Deskphone

one of them should be with green mark on rights side if you are connected.

Also when you click on 'View profile' do you see any phone number assigned to user?

Cheers

Highlighted

Hi Lukasz,

Nope. I can see Jabber is registered on the CSF in CUCM. Also, i can switch the phone mode to be either Softphone or Desktop with no issue.

When i right click on the contact and view profile, i didn't see any phone number assigned to that user.

TIA

Highlighted

Hi,

then you have answer why you don't have Call option.

Don't know what type or Integration you are using (UDS/EDI) ... assign some phone number to this 51901 user and you should have "Call".

Cheers

Content for Community-Ad