cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1031
Views
0
Helpful
5
Replies
Highlighted
Participant

Cannot Communicate with Server when HA is enabled for IMP Servers

Have two IMP Servers. In standalone mode users can log into both IMP Servers without issues.

 

When enabling HA (presence redundancy Group in CUCM), users can lo longer log into the subscriber IMP Server. Error: Cannot communicate with server.

 

No errors on the IMP Topology etc.

 

**Jabber Logs found the below.**

 


2015-10-21 12:43:49,947 INFO  [0x000017cc] [rx\jwcpp\LoginMgr\LoginCUPState.cpp(204)] [csf.jwcpp] [CLoginCup::HandleCupHA] - @LoginMgr: #0, CLoginCup::HandleCupHA ha, HandleCupHA
2015-10-21 12:43:49,948 WARN  [0x000017cc] [erx\jwcpp\LoginMgr\LoginContext.cpp(843)] [csf.jwcpp] [CLoginContext::GetHASoapServer] - @LoginMgr: ha, invalid HA soap server index:2
2015-10-21 12:43:49,948 INFO  [0x000017cc] [rx\jwcpp\LoginMgr\LoginCUPState.cpp(222)] [csf.jwcpp] [CLoginCup::HandleDnsSrv] - @LoginMgr: #0, CLoginCup::HandleDnsSrv dns, HandleDnsSrv
2015-10-21 12:43:49,948 INFO  [0x000017cc] [erx\jwcpp\LoginMgr\LoginContext.cpp(271)] [csf.jwcpp] [CLoginContext::ChangeState] - @LoginMgr: #0, CLoginContext::ChangeState now:0 auto:0
2015-10-21 12:43:49,948 INFO  [0x000017cc] [rx\jwcpp\LoginMgr\LoginStopState.cpp(43)] [csf.jwcpp] [CLoginStop::OnStateChanged] - @LoginMgr: #0, CLoginStop::OnStateChanged CLoginStop::OnStateChanged11
2015-10-21 12:43:49,948 INFO  [0x000017cc] [rwerx\jwcpp\xmppsdk\XmppClient.cpp(2035)] [csf.jwcpp] [CXmppClient::FinalCleanData] - @XmppSDK: CXmppClient::FinalCleanData, bReconnect:1
2015-10-21 12:43:49,948 INFO  [0x000017cc] [rx\jwcpp\LoginMgr\LoginStopState.cpp(78)] [csf.jwcpp] [CLoginStop::OnStateChanged] - @LoginMgr: #0, CLoginStop::OnStateChanged conn, canceled due to no needs. supposed:0, signning-on:0, signed-on:0
2015-10-21 12:43:49,948 INFO  [0x000017cc] [erx\jwcpp\LoginMgr\LoginContext.cpp(102)] [csf.jwcpp] [CLoginContext::ClearExternalLoginData] - @LoginMgr: #0, CLoginContext::ClearExternalLoginData
2015-10-21 12:43:49,948 INFO  [0x000017cc] [erx\jwcpp\LoginMgr\LoginContext.cpp(125)] [csf.jwcpp] [CLoginContext::ClearInternalLoginData] - @LoginMgr: #0, CLoginContext::ClearInternalLoginData login, clear login data. deep:1
2015-10-21 12:43:49,948 ERROR [0x000017cc] [berwerx\jwcpp\loginmgr\LoginMgrCPC.h(34)] [csf.jwcpp] [CLoginMgrConnectionPointContainer::Fire_OnError] - @LoginMgr: #0, CLoginMgrConnectionPointContainer::Fire_OnError login, OnError, 11
2015-10-21 12:43:49,948 ERROR [0x000017cc] [jwcpp\JabberWerxCPP\JWLoginSink.cpp(102)] [csf.jwcpp] [JabberWerxCPP::JWLoginSink::OnLoginError] - @JabberWerxCPP: JWLoginSink::OnError, lerr:11
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [ts\adapters\imp\components\Login.cpp(95)] [imp.service] [CSFUnified::IMPStackCap::Login::OnLoginError] - Entry
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [ts\adapters\imp\components\Login.cpp(97)] [imp.service] [CSFUnified::IMPStackCap::Login::OnLoginError] - ****************************************************************
2015-10-21 12:43:49,948 INFO  [0x000017cc] [ts\adapters\imp\components\Login.cpp(98)] [imp.service] [CSFUnified::IMPStackCap::Login::OnLoginError] - OnLoginError: (data=0) LERR_CUP_UNREACHABLE <11>:
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [ts\adapters\imp\components\Login.cpp(99)] [imp.service] [CSFUnified::IMPStackCap::Login::OnLoginError] - ****************************************************************
2015-10-21 12:43:49,948 INFO  [0x000017cc] [\impl\system\UserProfileManager.cpp(131)] [UserProfileManager] [CSFUnified::UserProfileManager::Impl::getCredentialsForAuthenticator] -  for authenticator: 1201
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [apters\imp\components\LoginUtils.cpp(88)] [imp.service] [CSFUnified::IMPStackCap::LoginErrortoErrorCode] - LoginErrortoErrorCode: 11 mapped to: UnableToConnectToTheServer
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [isteners\LoginEventListenerImpl.cpp(112)] [imp.service] [CSFUnified::LoginEventListenerImpl::OnLoginError] - errCode: UnableToConnectToTheServer
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [ers\imp\lifecycle\LoginExecutor.cpp(391)] [imp.service] [CSFUnified::LoginExecutor::OnSignOn] - Entry
2015-10-21 12:43:49,948 INFO  [0x000017cc] [ers\imp\lifecycle\LoginExecutor.cpp(392)] [imp.service] [CSFUnified::LoginExecutor::OnSignOn] - OnSignOn: false
2015-10-21 12:43:49,948 ERROR [0x000017cc] [ers\imp\lifecycle\LoginExecutor.cpp(400)] [imp.service] [CSFUnified::LoginExecutor::OnSignOn] - OnSignOn failed while in starting state...
2015-10-21 12:43:49,948 DEBUG [0x000017cc] [pters\imp\lifecycle\LoginExecutor.cpp(0)] [imp.service] [CSFUnified::LoginExecutor::OnSignOn] - Exit

 

 

 

**XCP Auth Log for IMP Server**


10:29:29.715 | error| TokenAuthUtils::authencateUsingOTP(): ExecuteAuthQuery() return authentication failure for userid: [bmorgan]
10:29:29.715 | error| SXComponent::_processRequest(): Authentication failed due to internal issue
10:29:29.715 | error| SXComponent::_sendAuthFailure(): Auth component sending Failure
10:29:32.093 | error| TokenAuthUtils::authencateUsingOTP(): ExecuteAuthQuery() return authentication failure for userid: [bmorgan]
10:29:32.093 | error| SXComponent::_processRequest(): Authentication failed due to internal issue
10:29:32.093 | error| SXComponent::_sendAuthFailure(): Auth component sending Failure

 

**Presence Engine Log for IMP Server**

09:22:29.579 |system.pe.hafsm 529978 ERROR HA_fsm::processRouterEvent(): Session interface object not initialized

 

Any advice would be appreciated.

Ben

5 REPLIES 5
Highlighted
Beginner

Hi Ben,

Hi Ben,

Did you resolve this issue ???

 

Even I am facing the same issue whenever there is problem with HA.

Highlighted
Participant

I disabled Built-in bridge

I disabled Built-in bridge for the Jabber Devices, seems to work ok now.

Highlighted

Try this sequence:

Try this sequence:

Disable HA

Reboot IMP Pub

Reboot IMP Sub

Re-enable HA

Built-in bridge is for conferencing, nothing to do remotely how Jabber connects to IMP

Also check from cli on IMP pub,  "utils dbreplication runtimestate" ensure everything looks good there.

Go to the IMP cluster status and make sure servers are not on red X.

Highlighted
Beginner

I came across this issue

I came across this issue after I upgraded 11.5.1Base to 11.5.1SU2 in one of my clusters. I followed the fix and it worked for me. But not sure it fixes everyone of my users with issue as there is one more login which will not work. Thanks.

Highlighted
Contributor

I am having the same issue. I

I am having the same issue. I can log into one of the IMP Subscribers but not the other.  Disabling HA did not fix my issue.  Did you make any progress?

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey