Showing results for 
Search instead for 
Did you mean: 


Cisco jabber for iphone 9.6.1 and jabber for android not working with VCS Expressway

Dear support community,


I have installed VCS Expressway C and E and I am able to register jabber for windows and jabber for ipad and I can make calls from outside the corporate network successfully. With jabber for iphone and jabber for android I can register both devices to CUCM and they work fine while inside the corporate network. If the iphone or android phone is outside the corporate network the following happens: I can receive calls and everything works fine, but if I make a call signaling works but rtp media does not. Expanding a little on this issue, when I make a call the remote phone rings as expected, when remote phone picks up the call there is no audio, the connection times out and sip signaling ends up the call. I have checked everything and this weird behavior keeps showing up. I wonder if this could some kind of bug. I am using VCS Expressway 8.1.0.  I would like to know if someone has faced the same problem.


Best Regards,



Are you you using the "Cisco Expressway" model or the VCS? They are two different solutions. in X8.1 it is easy to confuse the and misconfigure them. The "Cisco Expressway" model is actually not even actually a supported model yet but it is operational if you configure it properly. By Jabber for Windows and Jabber for Mac are you actually referring to those clients or are you referring to the "Movi" brand or rather "Jabber Video for Telepresence" as those are completely separate solutions.


If you are referring to actual J4W and J4M then the first thing I would look at is if the devices are actually registered to CUCM, and then look deeper into your expressway deployment model. There are multiple ways to deploy the expressway (VCS or "Cisco Exprewway") in terms of DMZ, Public, Dual NIC etc. If you are running a "3-port firewall" model, you may have success from the inside but not from the outside due to a lack of NAT reflection being enabled on your firewall. Also, one-way media traffic can be due to incorrect firewall configurations so I would revisit those.


Can you post your xConfig from both VCSc and VCSe and elaborate a bit on the deployment model in terms of Cisco Expressway vs. VCS expressway as well as CUCM version?

I guess to be more clear, are your Jabber for Windows and Jabber for Mac clients actually "Jabber Video for Telepresence" clients and your iPhone and Jabber clients are still the UCM based clients? Are you using TMS? or are your J4W and J4M clients actually registering to CUCM via the Expressway? What version clients are you running?

I have simillar issue with Jabber for Android/Iphone 9.6.1 with CUCM 9.1.2 and VCS 8.1.0

JFW works perfectly, iPod also, I have problem with incomming calls to the iPhone and Android in MRA mode. Could you please share bug ID for this with us.





Someone mentioned that you need to have CUCM 9.1(2) SU1 and I have only 9.1.2 so this will be probably the root cause if the issue. Could you please tell me

Yes this is exactly the same problem the rest of us on this comments trail had - if JFW works perfectly in both directions over MRA but iPhone and Android only work in one direction - then you have the same issue. The fix is simply to upgrade to CUCM 9.1(2) SU1.

Once you've done this check that your SIP trunk ports are still set up correctly on CUCM (for some reason mine reset to default ports and stopped working), and then the issue will be resolved like magic.

I've read through all the release notes for 9.1(2) SU1 and I couldn't see specifically what was causing the fix, but it definitely works 100%.


I have a collaboration edge with endpoints registering back to CUCM  which seems to be the same issue with version 8.1.1


My scenario is iPhone can register externally initiate a call to an internal party but any calls initiated from internal to the externally registered iPhone it appears but pressing answer media/establishment does not seem to occur as the desk phone remains ringing.


iPads and Jabber for Windows clients work perfectly fine in both directions.


The environment is a single Expressway-C and Expressway-E with dual NIC, inside on the same segment as the Expressway-C while the outside is behind a one-to-one NAT.


Attached are the xconf

I have exactly the same issue using Expressway 8.1.1 with Jabber 9.6.1 on iPhone registered over MRA.

The MRA iPhone can call into the internal network just fine with all media and signalling, but calls from internal network (have tried SX20 running TC 7.1 and Jabber For Windows 9.7) to the iPhone on MRA don't connect properly.

The call rings on the iPhone but when I answer it, no signalling or media is sent back to the internal network, so the internal endpoint doesn't realise a call has connected.

Jabber for iPad 9.6.1 works perfectly over MRA, as does Jabber for Windows 9.7, only Jabber for iPhone is the problem (I haven't tried Jabber for Android yet).

We have exactly this same issue on our lab network and on our customer network, it appears to perhaps be a software bug?


This worked fine before upgrading to Expressway 8.1.1 and Jabber for iPhone 9.6.1, and also before implementing CUCM changes required for B2B calls, so it could be related to any of those variables potentially.


To clarify my situation with questions below from Shawn - all clients are Jabber, no Jabber for Telepresence involved here.

All are registered to UCM including the SX20 endpoint running TC 7.1.

No TMS on this network, only CUCM, IM&P, Expressway-C and Expressway-E.


Hi DaneBlack

What version of call manager are you running?

I upgraded to CUCM 9.1(2) SU1 now and all works perfectly as well, thanks guys!

Probably fair to say this is a definitive fix to this problem.

Funny though as it changed my SIP Security Profile settings, which broke my SIP trunk to Expressway-C.

Easy to fix, just needed to change the settings back, but it is something to note for anyone else who does this upgrade.

Dear all,

I did open a TAC case and it ended up being that I was hitting a bug in my CUCM version. I need to upgrade to version 9.1.2SU1. I will be doing this in the next couple of weeks and I will let you know the outcome.



Thanks Roberto. Was your issue the same as mine, and as "heathrw" below?

We can successfully make calls from an iPhone using MRA into the internal network, but we can't receive them. Call signalling and media doesn't appear to flow correctly from internal UCM clients through to MRA on Jabber for iPhone.

Your issue described above appears to be the other way around, is that right?


Yes, it is the same issue.

I am glad to hear that upgrading the CUCM has solved the issue.

Best regards,


Hi All,


I just performed this upgrade and it is looking good so far 9.1(2)SU1 appears to be fully functional.


Check out the following documentation:






Great thanks for the update Heath, I think I'm just on 9.1 without the (2)SU1. I'll upgrade today and see what happens. Strange that this would fix the bug, but great if it works.

Recognize Your Peers
Content for Community-Ad