Showing results for 
Search instead for 
Did you mean: 

Cisco Jabber for Windows 9.6.1 - Installer switches


Hi All,

I am attempting to use the _cisco-uds SRV record to auto discover services in Jabber for Windows 9.6.1 using CUCM/IM&P 9.1.1

Our internal DNS servers are on a internal AD domain (example.local) which is different to our SIP ( or Email domain ( Based on the Cisco Jabber for Windows 9.6 installation and configuration documentation, I believe I should be using the SERVICES_DOMAIN installer switch

"Use the SERVICES_DOMAIN installer switch to specify the value of the domain where DNS records reside if you wish users to bypass the email screen during the first login of a fresh installation".

I uninstalled a previous Cisco Jabber for Windows 9.2.4 on the PC, therefore I used the "CLEAR" installer switch to remove any previous bootstrap information that might have been on the PC


Specifies if the client overrides any existing bootstrap file from previous installations. The client saves the arguments and values you set during installation to a bootstrapfile.The client then loads settings from the bootstrap file at startup"

"If you do not specify CLEAR, the client checks for existing bootstrap files during installation

  • If no bootstrap file exists, the client creates a bootstrap fileduring installation
  • If a bootstrap file exists,the client does not override that bootstrap file and preserves the existing settings".

Opened a command prompt

Changed the prompt to the location of the jabber msi file and performed the following command:

msiexec.exe /i CiscoJabberSetup.msi CLEAR=1 SERVICES_DOMAIN=example.local

After installation and launch of Jabber for Windows, I receive "Cannot communicate with the server" on the Jabber for Windows client

I ran wireshark during the launch of Jabber for Windows and I see ONLY the following DNS queries to the name server:


The SIP domain, which I suspect is cached from the previous install is being used instead of the SERVICES domain.

Am I doing something wrong?

Any assistance is appreciated.

NSlookup seems to show the SRV is setup correct.

Default Server:  nameserver.example.local

> set type=srv
> _cisco-uds._tcp.example.local

_cisco-uds._tcp.example.local  SRV service location:

          priority       = 1

          weight         = 5

          port           = 8443

          svr hostname   = cucm2.example.local

_cisco-uds._tcp.internal.local  SRV service location:

          priority       = 2

          weight         = 20

          port           = 8443

          svr hostname   = cucm3.example.local

_cisco-uds._tcp.internal.local  SRV service location:

          priority       = 6

          weight         = 30

          port           = 8443

          svr hostname   = cucm1.example.local

2 Replies 2

Rising star
Rising star


This community does not provide technical support and is not staffed with technical support experts. I recommend you post this and future technical support questions to the Cisco Support Community ( where our Cisco technical support experts provide assistance. Another option is to open a ticket with the Cisco Technical Assistance Center ( to get expert debugging assistance.

We do encourage you to participate in the Cisco Collaboration Community and to also join our Cisco Collaboration User Group program!  In the community, we encourage your discussion/sharing around collaboration topics and Cisco Collaboration Solutions, including business and IT requirements, industry trends, process, culture/organization issues, how collaboration can be used to transform businesses, vendor selection, adoption, training, architecture, licensing, and product features/functionality. If you are a customer or partner, you can also join the user group program to be eligible for member-only events and influence product direction.

We hope to hear from you again.

Kelli Glass

Moderator for the Cisco Collaboration Community

Stephen Harrison

I have just used

msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=CUP CUP_ADDRESS=cup-server-name SERVICES_DOMAIN=example.local

To install the 9.6.1 client which has worked to install Jabber and when logging in it has worked using just username and password.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: