cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
144
Views
5
Helpful
9
Replies
Highlighted
Beginner

Cisco removing the dependence on Internet Explorer

We have endless issues with Cisco Jabber using Internet Explorer for any kind of account authentication.

 

This includes using the Calendar option in Jabber needs the user to login to their account via Internet Explorer.

Same with SSO using Internet Explorer to authenticate with your SSO Provider.

 

Our Global Teams block users form using IE to login to Jabber where it automatically opens Google Chrome when the user tries to sign in. This means the user is unable to authenticate and the Calendar does not work.

 

SSO was not able to work for some of our users and we needed to delete IE cache to re-enable the user to try and login.

 

Is there anyway of changing the default browser Cisco Jabber uses?

Any feedback will be appreciated.

9 REPLIES 9
Highlighted
VIP Advocate

What version of Jabber do you use? I've never seen Jabber default to any browser, from my experience it would use what is set as the default on the computer. Sounds like you might have some specific configuration in-place in your Jabber XML (file) as the calendar login isn't something I ever seen either. Would you mind to share you configuration so that we can have a look at it?

Please rate all useful posts
Highlighted

Hi Roger,

 

I'm currently using Jabber version 12.9.1 but can upgrade at anytime.

 

Please also note we use Google Mail as our main email at our Business.

I will attached images of the process:

 

So when choosing Google Calendar and restart Jabber the following happens.

1. Refer to image GC Sign in Page
2. Refer to image GC SSO Page ( This our internal SSO authentication for Google to work)
3. Refer to image GC Error

Please note before our Company decided to force any client trying to login into their Google Account via Internet Explore, where they automatically close IE and open Chrome.
I was then able to login to my Google Account in IE and once I run through the steps on Jabber it would connect Jabber to my calendar and it would work fine.

The reason why I know its dependant on IE because I am logged into Google in Chrome but the application fails to connect.

 

Down below is the XML file I use, I have removed any confidential IP's:

 

<config version="12.0">
<Client>
<spell_check_enabled>true</spell_check_enabled>
</Client>
<Options>
<StartCallWithVideo>false</StartCallWithVideo>
<Location_Enabled>false</Location_Enabled>
<Location_Mode>DISABLED</Location_Mode>
</Options>
<Policies>
<EnableSIPURIDialling>true</EnableSIPURIDialling>
<ClickToCallProtocolPermissionEnabled>false</ClickToCallProtocolPermissionEnabled>
<ContactCardonHover>false</ContactCardonHover>
<ServiceDiscoveryExcludedServices>WEBEX</ServiceDiscoveryExcludedServices>
<Persistent_Chat_Enabled>true</Persistent_Chat_Enabled>
<EnableP2PDesktopShareOverEdge>TRUE</EnableP2PDesktopShareOverEdge>
<EnableReverseConnectionForP2PDesktopShare>TRUE</EnableReverseConnectionForP2PDesktopShare>
<disable_im_history>true</disable_im_history>
<CalendarIntegrationType>1</CalendarIntegrationType>
<CalendarAutoRefreshTime>0</CalendarAutoRefreshTime>
<EnableHuntGroup>true</EnableHuntGroup>
</Policies>
<Directory>
<DirectoryServerType>EDI</DirectoryServerType>
<PrimaryServerName>XX.XX.XX.XX</PrimaryServerName>
<ServerPort1>3268</ServerPort1>
<UseWindowsCredentials>0</UseWindowsCredentials>
<LdapSupportedMechanisms>PLAIN</LdapSupportedMechanisms>
<LDAP_UseCredentialsFrom>CUCM</LDAP_UseCredentialsFrom>
<SearchBase1>ou=</SearchBase1>
<SearchBase2>ou=</SearchBase2>
<SearchBase3>ou=</SearchBase3>
<SearchBase4>ou=</SearchBase4>
<SipUri>mail</SipUri>
<UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
<CommonName>cn</CommonName>
<DisplayName>displayName</DisplayName>
<FirstName>givenName</FirstName>
<LastName>sn</LastName>
<BusinessPhone>ipPhone</BusinessPhone>
<UserAccountName>sAMAccountName</UserAccountName>
<PhotoSource>url</PhotoSource>
<PhotoUriSubstitutionEnabled>True</PhotoUriSubstitutionEnabled>
<PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
<PhotoUriWithToken>http://jabberpictures.Domain/sAMAccountName.jpg</PhotoUriWithToken>
</Directory>
</config>

 

 

#EDIT#

Even by copying the link from the Jabber Calendar authentication screen and manually logging in via Google Chrome does not work. The screen just hangs even though I have allowed Jabber to view my Calendar as seen in the last imaged uploaded. As I said they only way I could get it working is if I login to my Google account using IE. Even changing y default browser in Win10 does not resolve the issue. 

Highlighted

If your using Google as your calendar your Jabber configuration for CalendarIntegrationType is not correct.

Snag_11bd234.png

See this picture from the parameter reference guide on the values you can use for this.

Snag_964cbe.png

I believe that the issue you face is not accounted to Jabber needing to use IE for the authentication, it's likely something in the setup in your system landscape that is at fault for this. Just guessing, but something with the setup along what is supported with your Google setup and the steering for what browser to allow to use for what. I would recommend you to start investigating at that end.

Please rate all useful posts
Highlighted

Hi Roger,

 

Like I stated before if I ask our IT to remove the script from automatically moving me over to Chrome when trying to login via IE in to Google. I can get the calendar to work with the current settings. I did get it working but because of the complexity we did not advertise to Business as viable. 

I will go ahead and make the adjustment to the XML File but I can positively say this will not resolve it.

 

If there is anyway I can force Jabber to use Chrome in that initial startup that will fix the issue.

Highlighted

Not from within Jabber AFAIK. As I wrote before it uses the settings on the PC that controls what browser to use for what. To be clear I don't expect that the change in the XML configuration would have any effect related to this, it's merely to point out that there is something that isn't accurate in your file for your specific setup with Google Calendar.

Please rate all useful posts
Highlighted

Recommend you to also have a look at the parameter preference guide for this part of the settings as it's not really per what would be the current recommendations.
Snag_9c435b.png

No at all related to your questions as such, just an observation that it's not current or best practice. If I'm not wrong the recommended way to define directory services for Jabber would be via UC Services in CUCM.

Snag_a23d62.png

Snag_a31d53.png

Please rate all useful posts
Highlighted

Hi Roger,

 

So I have made the change to my XML file and I can confirm this only changes the behaviour of Jabber.

 

So basically when it was set to 0 it does not automatically choose a Calendar, the user needs to manually go to settings and select a Calendar option and restart Jabber for it too take effect.

With this option added, Jabber now automatically chooses Google Calendar from the start and the user is prompt to follow the step to login. 

Because we can't get it to work, in regards to the IE issue users will now keep seeing this pop up everytime until they manually switch it off.

 

I will need to remove it in order for users not be bombarded by this. Hope this answers your question.

 

Thanks for the headsup with my outdated XML configuration, will definitely look at that as well.

Highlighted

In your XML that you posted before you had it set to 1, not 0.

Snag_121fe96.png

One (1) would mean that the integration type is set to Microsoft Outlook.

Please rate all useful posts
Highlighted

Hi Roger,

 

I get you, but like I said after changing it to >3< Cisco Jabber start automatically with Google Calendar as active so I just removed it again.

I think the best option will be to log a TAC Case to find out why it's using IE to login and why it can't simply use Chrome.

Content for Community-Ad