cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
14377
Views
15
Helpful
4
Replies
JP Babiera
Enthusiast

Deskphone unable to connect in Jabber

Hi everyone,

I've been reading the existing posts regarding this issue, but i'm still not having much success in getting the deskphone to be controlled by Jabber.  This is for a non-ldap environment, with CUCM 9.1.2, CIMP 9.1.1 and Jabber v11.0.1.  I don't want the soft phone capability enabled, just IM and deskphone control.  Below is the check list I've put together from my readings.

 
CUCM Services Check list
1) Cisco CTI Manager Service is activated 
Cisco Unified Serviceability >> Tools >> Service Activation
 
User Check list
1) The phone is associated under the End User
End User config page >> controlled devices >> user's phone's mac address listed
Registered phone is 7960 SCCP
 
2) The End User has permissions
Groups
Standard CCM End Users
Standard CTI Enabled
'Standard CTI Allow Control of All Devices' needed?
Roles
Standard CCM End Users
Standard CCMUser Admin
Standard CTI Enabled
 
3) The correct UC Service Profile is assigned
Service Profile:  IM&P and CTI (TCP/2748)
 
4) User has checked Allow Control of Device from CTI
 
5) The End User is licensed for IM & P.
IM&P >> User Management >> End User
 
 
Device Check list
1) Allow Control of Device from CTI is enabled on the phone
 
2) Allow Control of Device from CTI enabled in the phone's line DN
 
 
Am I missing anything else?  Jabber is giving me an Error CJ:109:3 error code.
 
Thank you all in advance,
 
JP
 
4 REPLIES 4
Dennis Mink
Advisor

did you associate the line on the device with the user?

 

 

'Standard CTI Allow Control of All Devicesneeded?   no, not on cucm 10.x

Please remember to rate useful posts, by clicking on the stars below.

Hi Dennis,

You're talking about the "users associated with line" under the phone's DN, right?

I just tried this, but I'm still getting the Unable to Connect.

Ah, I was missing 2 things on the Presence side.  

- CCMCIP profile under Application

- Primary TFTP server wasn't set under Legacy Client Settings

 

 

This now works

Thank you.

My Problem Solved ...

Content for Community-Ad

Spotlight Awards 2021