Showing results for 
Search instead for 
Did you mean: 

Extend and Connect and Remote Destination

Hey all,

I'm playing around with the Extend and Connect feature within Jabber and have a couple of questions. 

1) When I configure my Extend and Connect number, a Remote Destination is created.  Now, when my phone rings, it always rings through to my cell phone, even when I am "Using my desk phone for calls" within Jabber.  Is there any way to have this not happen by default other than messing with the timers?


2) When I am using Extend and Connect to my cell phone I do not hear the phone ringing on my cell phone.  In other words, I dial from Jabber, it rings my cell phone, I answer, but between the time that I answer and the called party picks up, I hear silence.  Once the called party picks up, the call is normal, but I don't hear the normal ringing tone as if I dialed someone directly from my cell phone.

I am sure both of these are simple things that I've over looked, but both have pumped the brakes on a more wide scale deployment.

Thanks for anything you can provide.



Hey Mark, any luck with this?  I posted a similar question to your #1 in the Collaboration User Group just today.  I would like the RD to stop ringing when I'm set to control my desk phone, use the softphone, or if Jabber is closed.

I've also noticed that the RD that gets created by Jabber has the Delay Before Ringing timer set to 4000 ms.  I'd prefer that was 0 (especially for cell phones)... I wonder if there's a way to manage the timers in a template or something before it gets created.




I did not get a response to the question, which was a bit annoying.  I went ahead and adjusted the timers, and everything seems to be working fine.  When I want to redirect to my cell phone, it does, and when I don't, it doesn't.  My Delay Before Ringing is set to 30000, and it rings my cell phone after only one ring on my desk phone.  I think that setting is what was making my cell phone ring when I didn't want it to.  When using extend and connect, it will always ring your cell phone immediately.  At least, that is how I've noticed it working for me.


Your delay before ringing timer is 30000?  If I did that with a normal RD, my cell phone would never ring.  It sounds to me like it's doing something like this:

  • Extend and Connect active - it rings your cell phone immediately, and the one ring on your phone is the delay it takes the mobile carrier to connect the call
  • Other setting, it uses the Delay Before Ringing timer in the RD, therefore it never calls you before the call goes to voicemail.

That accomplishes the task, but would require an end user to go and edit their RD timers whenever they used the Jabber client to create the Extend and Connect destination.  My users can't handle that :^)

I did receive a reply in the Collaboration User Group, suggesting that it should work as you described (where it simply doesn't ring the RD when Jabber is not configured to do so, or not open).  He said some versions of CUCM had a bug that prevented this from working properly.  I'll let you know if I hear anything back.  Here's a link to the discussion, I think the CUG is free to join, you just have to fill out a longish questionaire.

Thanks for the replay,



Thank you for that input.  I thought that might be a bug as well, but it was driving me crazy, so I just edited the timer.

No, my timer was not 30000 by default, I don't recall what it was, maybe 4000 or something.  In my case though, I am the only one using Extend and Connect, I'm honestly not sure if our users can handle turning Extend and Connect on, let alone adjusting their timers as well. 

I will follow your thread as well for some further input, and hopefully the bug is fixed now.  I am at V 9.1(2) now on CUCM, and 9.1(1) on CUPS.


lol... I don't know if my users can handle it either.  We have the odd person with terrible internet connectivity, so I need to try to get it going, but our help desk is going to have a fun time explaining it to people, that's for sure!