cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1236
Views
5
Helpful
8
Replies
Frequent Contributor

Jabber 10.5 with HA problem

Hi,

 

I have two CUCM 10.5 and two IM&P 10.5 and jabber 10.5

I'm using balance method for user assignment

I have two problems

 

1- When jabber is logged to the first IM&P. then I disconnect the network connection for this IM&P

Jabber isn't moved to the second IM&P correctly

Only can make calls

 

But presence show offline and so you can't also make chat

I check show connection status and found presence disconnected

I doesn't work until logout and login again from jabber so presence come back to work

 

 

2- The second problem is after I re-login to IM&P 2 while IM&P 1 is disconnected

When I try to check "use my Desk phone for calls" , most of times it fail and can use only softphone and sometimes connect but with long delay

Note that the user have 3 devices which is the ip phone SEP and J4w CSF and Jabber for iphone TCT

I don't know if deleting TCT could affect this or not

 

Thanks for pointing me to any trials

 

Regards

1 ACCEPTED SOLUTION

Accepted Solutions
Participant

I figured out the issue. When

I figured out the issue.

 

When one of the IM & Presence nodes fails, or a user is manually reassigned, the Jabber client selects a random relogin time between 90 and 1370 seconds and wont attempt to relogin to the healthy node until this time expires.

 

I manually changed the lower and upper limit times to 1 and 10 seconds and Jabber now logs in straight away. This setting can be found under IM & Presence service parameters -> Cisco Server Recovery Manager. This will need to be changed on both nodes.

There is obviously an impact with setting these timers low as all clients will attempt to relogin straight away which will impact the server.

I wonder if our upgrade from 8.6 to 10.5 reset these values or its a new 10.5 feature.

 

8 REPLIES 8
Hall of Fame Cisco Employee

And exactly how did you

And exactly how did you configure redundancy???

HTH

java

if this helps, please rate
Frequent Contributor

Hi Jaime, Thanks for your

Hi Jaime,

 

Thanks for your reply

The second issue is solved. it wasn't related to HA

 

For the first issue, it is the current scenario, I don't know if it related to HA or missing configuration

 

I found that when a user is assigned to IM&P1 and I make re-assign for the user for IM&P2. the presence become disconnected and all other services is connected [CTI,deskphone,VM,Direcroty]

Only presence give disconnected

When logout then login again. it become connected to the new IM&P2 node

and the user presence show green as available

 

This exactly what happen with HA, that when I disconnect IM&P1 while a user is assigned to it, the user isn't moved auto to IM&P2. but need to relogin . the same scenario as when re-assign the user from node to node

 

I think it isn't related to HA or what you think ?

 

Thanks

Frequent Contributor

Hi, Any one face this

Hi,

 

Any one face this issue

That when you move one user from a presence server to another. the user must logout then login again !!

 

 

Participant

Hi, I'm experiencing this

Hi,

 

I'm experiencing this exact same issue after upgrading CUPs 8.6 to 10.5 a few weeks ago. Everything works ok except HA which requires the user to logout and back in again.

 

What version of IM & Presence are you running? I'm running SU1 and I have just noticed that SU2 was released last week.
 

Frequent Contributor

Hi, I'm running 10.5.1 

Hi,

 

I'm running 10.5.1

 

Participant

I figured out the issue. When

I figured out the issue.

 

When one of the IM & Presence nodes fails, or a user is manually reassigned, the Jabber client selects a random relogin time between 90 and 1370 seconds and wont attempt to relogin to the healthy node until this time expires.

 

I manually changed the lower and upper limit times to 1 and 10 seconds and Jabber now logs in straight away. This setting can be found under IM & Presence service parameters -> Cisco Server Recovery Manager. This will need to be changed on both nodes.

There is obviously an impact with setting these timers low as all clients will attempt to relogin straight away which will impact the server.

I wonder if our upgrade from 8.6 to 10.5 reset these values or its a new 10.5 feature.

 

Frequent Contributor

Great willscottyYou got it

Great willscotty

You got it and it solved my issue

 

 

Thanks

Highlighted

+ 5 !!!

+ 5 !!!

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards