cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
137
Views
0
Helpful
2
Replies
Highlighted
Beginner

Jabber & IM&P Not Authenticating LDAP

I just started to manually sync CUCM to secure LDAP. I still have local users that can login to Jabber.

 

However, I cannot login to IM&P or Jabber via LDAP users. I have been working with TAC over a week and still no results. I'd like to see if anyone else has run into this issue?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Jabber & IM&P Not Authenticating LDAP

I figured this out.

 

I accessed the Cisco IM&P Administration page Diagnostics Tab - System Troubleshooter

 

There is a field:

Verify that the LDAP server authentication has been successful

 

It indicated the following:

 

Authentication between the IM and Presence Service Server and LDAP server does not seem to be working correctly

 

*Error while connecting to ldap://xxxx:636,javax.netssl.SSLException:Certificate not verified"

 

It provided me a "FIX" link, which just brought me to the CUCM LDAP Configuration. I knew this information was all correct because CUCM is synchronizing just fine.

 

I then accessed the IM&P OS Page - Certificate Management. Most certificates on this page are imported from CUCM. I did not see my ROOT LAP Certificate.

 

Because we are using Secure LDAP I had previously uploaded the root cert from my AD to CUCM. I went ahead and added this Cert to IM&P Certificate List and it is now working

 

 

 

 

2 REPLIES 2
Beginner

Re: Jabber & IM&P Not Authenticating LDAP

I figured this out.

 

I accessed the Cisco IM&P Administration page Diagnostics Tab - System Troubleshooter

 

There is a field:

Verify that the LDAP server authentication has been successful

 

It indicated the following:

 

Authentication between the IM and Presence Service Server and LDAP server does not seem to be working correctly

 

*Error while connecting to ldap://xxxx:636,javax.netssl.SSLException:Certificate not verified"

 

It provided me a "FIX" link, which just brought me to the CUCM LDAP Configuration. I knew this information was all correct because CUCM is synchronizing just fine.

 

I then accessed the IM&P OS Page - Certificate Management. Most certificates on this page are imported from CUCM. I did not see my ROOT LAP Certificate.

 

Because we are using Secure LDAP I had previously uploaded the root cert from my AD to CUCM. I went ahead and added this Cert to IM&P Certificate List and it is now working

 

 

 

 

Beginner

Re: Jabber & IM&P Not Authenticating LDAP

I am running into a secondary issue, Jabber can connect locally, I can connect to my IM&P server. I cannot connect via my Jabber Mobile Client. Maybe a firewall issue? I'm looking into it.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards