Showing results for 
Search instead for 
Did you mean: 

Jabber contacts not showing up in contact list

Random LDAP-integrated users are not added to the contact list even though the Jabber for Windows client successfully finds the user in the search criteria.  The users are shown with CUPS capability under CUPS 8.6.4 and CUCM 8.5 in our on-prem environment.

We are using Jabber for Windows 9.1.0 for some users and version 9.1.2 for others.  Both have the same issue.  Other users are being added to the contact list without a problem and are fully operational.  The users that cannot be added to some can be added to others.  There does not seem to be a pattern I can identify.

Any ideas?  Thanks for your help.



could you check if the users that can add contacts are assigned on the same server ?

the version of your CUPS is 8.6.4-11900-1 ?

I have an issue with contacts. I can see them when my user is assigned to PUB but not if they assigned to another server




Yes, we are using CUPS 8.6.4-11900-1.  We have two CUPS servers in our cluster.  Users are balanced between them.


I'm seeing a similar thing on our 9.1.1 cluster using client 9.1.2. Did you get anywhere with this?


Sorry, no not yet.  Let me know if you figure it out please.




I have a similar Issue with Jabber 9.1.2 and CIMP 9.0.1. I can search the Directory, but after seleting add to contacts, very few actually display in the list. Any help  is appreciated.

Hi All,

Seeing this in JfW 9.1.2 as well. Not tried 9.1.3 which is just released.

I looked at a user today who cannot to add a user.

This user was a Lync user and now moved to Jabber. I can see the issue isn't Lync related though - its the way Jabber is caching the entry OR finding the presence address for a contact.

If you add someone to your contacts and thier IM presence address is wrong i.e. say you add someone from your local contacts that has the presence field populated with (say) his email address instead of being added from the DIR (AD) which has the correct IM address in.

JfW adds the user in.

I may want this for external federation but say I don't and I need to change this Im address i.e. to pick up the contact details from the DIR as this has the correct info in.

So I delete him but when I try to add him back in - the serach brings up his name but from the RECENTS which still has the incorrect Presence field. Whats worse is Jabber appears to let me add him but then he does not show up in my contacts.??

I can fix this sometimes but delete / reload client / add him back but not always. The JfW search won't show me the AD results - just recents and address book.

I had one contact (today) and I could not add him. I tried deleting the contact from JfW / deleting the conacts from the CSF directory etc but no joy.

I have a relaod on the CUPS tonight and will check tomorrow before I try 9.1.3. I have also a TAC rasied on this.

I did get around this by adding the contact from my ipad which always gives you the choice of local/contacts/DIR when searching a user.


Concerning the problem I had (contact on PUB and not n SUB), we solved the problem by changong the way the CUPS works. We were in MDNS mode. We changed to Router-to-router mode and it is ok now.

I'm not sure this solved your problems but you can try .....



Thanks for the idea Olivier however we are already in router-to-router mode and still have the issue.



Was there ever a fix / configuration guideline for this. I am having the same issue for contacts not being able to add in JFW if they belong to different nodes within the same cluster

Recognize Your Peers
Content for Community-Ad