cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
12568
Views
30
Helpful
17
Replies

Jabber CTI problem

                   Hello all,

I have installed CUCM 9.1.1 and presence 9.1.1.10000-8 on BE600

Presence server is integrated successfully with CUCM by the book.

All services are running and state of all them marked with green color (when I check presence ---> topology)

Axluser and CTIGw users are created and associated. 3 end users I’ve created in CUCM (I don’t’ use LDAP) successfully transferred to Presence server

So when I start my Jabber client ( Win 7, 32 bit, jabber version 9-2-4) I experience at least two problems:

•1.       I can’t take control of my hard phone ( I use 6941 and 9971 ), actually I can use it only as a softphone.Also Jabber client is close itself when i start some    call ( from time to time)

•2.       Chat is not available and I can’t find other users

Additional info:

I have upgraded presence server to the latest version 9.1.1.31900-1- no changes.

I use temporary license for CUCM that I got from cisco go license site and have installed into ELM. The capacity of temp.license covers my LAB users and phones.

If I change my status on Jabber for instance, from available to DND the status of line ( DN ) on my hard phone also changed appropriate ( DND).

I use "domain.not.set" in domain field.

Any idea?

I will appreciate your help.

Thank you an advance,

George

17 REPLIES 17
Jaime Valencia
Hall of Fame Cisco Employee

1.Most usually that's related to problems with user/device/line association and the roles the user needs for this, check that.

2. Did you configure the .xml file to use UDS??? A directory is mandatory, if you're not using LDAP, then you're using UDS and you need to configure it.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

Hi Jaime

Thank you for your answer.

I have done LDAP connection and upgraded user service profile, but the problem is still exist

All user and devices associated with CTI

Any other idea ?

BR,

Check If you configured on the user/phone with the problem:

1) Under Cucm Serviceability Is there the service CTI manager running?

2) In order to work the chat you have to set the domain!

3) Under End User -> the device associations with the hard phone has been done, the primary ext selected, allow control Cti flagged, Service Settings you have to flag "enable user for Unified CM Im & P.." and UC Service profile that you must previously created contain the service type "CTI" and at the end of the end user page there's the Permission group "Standard Cti Enable".

4) under the Hard Phone must be the flag "allow controll from Cti"

There's something further more to check, but you can start with this.

Please rate If It's helpful

Thanks

Hi Francesco.

Thank you for your help.

I set the correct real domain name , after that all others sections you written me,

everything is ok, but the problem still exist.

The chat is not available and i can't control my hard phone...

BR,

George

kornev.yuriy
Beginner

Good day!

I have a similar problem.

CTI connection in my jabber for windows does not establish. So, I can't use my desk phone as a primary device for placing calls.

I have found out, that this problem originates only if I use SSL for LDAP authentication in my CUCM. If I switch-off SSL - all works fine.

Any ideas?

Yuriy,

I didn't check SSL change yet.

Do you experience also chat issue ?

BR,

George

Georgi, Yuriy!

Hello from Russia!

Did you find the solution for these CTI problems? I've got the same sad story after upgrade from 8.6 to 9.1

Hello guys.

I found the problem :

Under service profile in CUCM, UC service of CTI  should be ip address of CUCM instead Presence server

Once i have changed it i can control my Cisco hard phone.

BR,

George

Hi!

I have the same problem

I tried both addresses CUCM and CUP but it still doesn't work. In Jabber I see error "Unable to connect to server".

Artem

This configuration solved my problem.

Thank you!

My pleasure

German Zamora
Beginner

By the way:

If you are using any 69XX, 89XX, 99XX phone model or 7975 or 7931, you need to add 2 additional roles to the end user configuration:

"Standard CTI Allow Control of Phones supporting Rollover Mode" and "Standard CTI Allow Control of Phones supporting Connected Xfer and conf."

Hope this hepls!

Thanks this solved my issue when rolling out 8800 series phones.  Users were working ok with 7900 series, but when we swapped phones for these users, these extra permissions were needed for CTI to work.

Had the same issue with 8800 phone series. Works for us now! Thank you

Content for Community-Ad

Spotlight Awards 2021