cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
21111
Views
93
Helpful
25
Replies
navdipatwal
Enthusiast

Jabber DeskPhone Mode Issue

Im using CUPS 8.6 with CUCM 8.6 with Jabber 9.0.1

I have an issue with Deskphone mode and selecting Use my phone for calls option below.

When I select use my Computer for calls, everything is fine, i can make calls using my PC and my Deskphone is working in synch.

When I select Use my Phone for Calls, most of the time it fails to select this option, When it does choose the option the option it takes a long time and the the Call users is greyed out.

Please see screenshot.

Can somebody please advise why this is happenning or help me troubleshoot?

This was working fine with CUPC 8.5, with Jabber I am having this issue.

To select use my Deskphone option shoud be pretty quick, in this mode should softphone calling functionailty be disabled as in the screenshot below.

25 REPLIES 25
navdipatwal
Enthusiast

I suspect this is a firewall issue between PC and CUCM and various ports being blocked.

Im getting a list of all ports and will get these opened up and then test, if someone can confirm list of all ports used between PC and CUCM for Deskphone mode

Hi Navdip,

Ports and Protocols used by Jabber for Windows can be found in the Admin Guide. Port 2748 is used to connect to CTI gateway of call manager. Regarding,

"When I select Use my Phone for Calls, most of the time it fails to  select this option, When it does choose the option it takes a  long time and the the Call users is greyed out."

the switch should be pretty quick and the option to click to call a user should be available. Can you provide a problem report to investigate this?

Thanks,

Maqsood

How do I upload the problem report files (.rar)?

In reply window click on "Use advaced editor" in the top right corner. You will have the option to upload a file there.

Thanks,

Maqsood

navdipatwal
Enthusiast

Problem trouble shoot files attached

Hi Navdip,

This is a configuration problem somewhere in your setup. Jabber is trying to connect to Cti server 45.9.110.100 for deskphone control but the connection is timing out. Is this the correct Cti server? Is it up and running properly and accessible from your machine? For softphone client is connecting to 45.9.110.125 and connection works fine.

Main problem is that the CTI server is not accessible to Jabber to switch to deskphone control mode.

Thanks,

Maqsood

Hi there,

Many thanks for the quick reply.

The Cluster Publisher IP address is 45.9.110.100, this will not have the CTI Service Running.

The CCMCIP Defined IP addresses with CUPS of Primary Call Managers for Jabber CSF Devices are 45.4.12.1 and 45.9.110.101 and should have the CTI Service running.

The profile of the Jabber end user has the correct CCMCIP profile.

The Softphone Device is accessing another CallManager (45.9.110.125) which is not listed in the CCMCIP Profile.

Where should I change the setting to reference the correct CTI Server?

Hi Navdeep,

Check the section Setup a CTI gateway of Jabber for Windows admin guide to find the location and process of specifying this setting.

Thanks,

Maqsood

Hi there,

The CTI Gateways that are referenced were set-up automaticaly when CUPS was tested in a mock-up environment.

I have removed these references and changed user profiles to use the correct CTI Servers.

It is still not working so I am assuming that some services need to be re-started for these settings to take effect.

Can you please confirm whhich services need to be re-started.

I am not sure about any services that need to be restarted. Did you restart client after making the changes? If that did not help then please open a TAC case for further assistance.

Thanks,

Maqsood

Hi there,

I have re-started client, and restarted SIP Proxy and Presence Engine but it is still not working.

Already raised issue with TAC and awaiting for the right level of engineer to help.

Hello Navdip,

I am having the same problem. can you tell me how you fixed this issue ?

your urgent help will be appreciated.

Regards,

Anis

I had the same issue, i solved it changing the LDAP authentication port on CUCM, from 389 to 3268.

(CUCM>System>LDAP>LDAP Authentication)

Hope this helps, bye

Denis Roman Fulin

This also solved the problem for me. Thx,

But could anyone told me why port 389 works for some month and suddenly not? What are the dependencies between LDAP Authentication and control of deskphone?

Create
Recognize Your Peers
Content for Community-Ad