Showing results for 
Search instead for 
Did you mean: 

Jabber DeskPhone Mode Issue


Im using CUPS 8.6 with CUCM 8.6 with Jabber 9.0.1

I have an issue with Deskphone mode and selecting Use my phone for calls option below.

When I select use my Computer for calls, everything is fine, i can make calls using my PC and my Deskphone is working in synch.

When I select Use my Phone for Calls, most of the time it fails to select this option, When it does choose the option the option it takes a long time and the the Call users is greyed out.

Please see screenshot.

Can somebody please advise why this is happenning or help me troubleshoot?

This was working fine with CUPC 8.5, with Jabber I am having this issue.

To select use my Deskphone option shoud be pretty quick, in this mode should softphone calling functionailty be disabled as in the screenshot below.

25 Replies 25


I recently had a similar problem. We're testing Jabber for iPhone using ASA VPN (AnyConnect), after completing the creation of the profile TCT, noted that the windowns Jabber is not transited more so for Desk Phone Mode. 

I have a notice in windows jabber is stating the problem in CTI integration. I have check the Line associate with user and CTI Enable  in the group. Everything is okay.

I figured it might be some port configuration in ASA. So I went to connect the laptop on the local network. And the same problem persisted.

Any sugestion?

Daniel Sobrinho


I had the same problem with Jabber for Windows not working for controlling deskphones. Well, sometimes it worked, sometimes not. Changing the LDAP authentication from 389 to 3268 (followed by a restart of the CTI Service on the CCM!) solved the problem

Here is the explanation from TAC:

The issue is not with the CUCM or Jabber, but with the LDAP server itself.  The real heart of the problem is the time it takes Microsoft to respond back to CUCM on port 389. The port is valid, and the authentication attempts from CTI Manager will work (sporadically as you have seen) but for best practice we would always recommend for customers that are using any CTI or IMAP/VMREST application to use 3268 as this port is more reliable at responding in the correct amount of time. Basic directory connections for user lookups should be fine with 389, as this issue would only effect CTI Authentication for desk phone control and IMAP/VMREST authentication for Unity Conn. Connections.

Hope this information helps.



Thanks for giving correct answer!!

It worked for me as well.

Is there an explanation for this?

Thank you


I think I just figured this one out.

In presence, look under Application>Cisco Jabber>CCMCIP Profile.

Select a user who is not working properly. Make sure that they have a valid CTI Gateway Profile. (Only some of my users did)

It seems that a CTI Gateway Profile is automatically created for each device pool you have in UCM, but there should be a default one. Go to Application>Cisco Jabber>CTI Gateway Profile and look for the default. Check the box that says "

Hope this helps!


Hi David,

The problem have been resolved yestarday.

The user had a device 9971 and his  CCM end user did not have the appropriate CTI Access Group applied?

For Cisco Unfied IP Phone 9900 or 8900 series we need, select the

- Standard CCM End Users

- Standard CTI enable

- Standard CTI Allow Control of Phones Supporting Connected Xfer and Conf

For phones 6900 series need

- Standard CCM End Users

- Standard CTI enable

- Standard CTI Allow Control of Phones Supporting Rollover mode

After apply this, everything backs to work properly.

Thank you guys


Daniel Sobrinho

Thanks! same thing for 78XX phones

Saurabh Sareen


You need to make sure that CTI Gateway Profile is configured correctly in the CUPS.

Also make sure that it is applied to all Users.

The next this is to make sure that CCMCIP profile is created and configured properly and is applied to all users.

Make sure User in the CUCM is having Standard CTI Enabled / Standard CCM End User / Standard EM Proxy Authentication rights. Also make sure that all the Phones / Profiles are associated with the end user.

Logout from Jabber and exit the application. Log back in again, it will work for sure.


I have the same problem and i tryed all above but it's not work.

CUPS and Jabber 9.2.5.

Any idea please ?




I had a similar issue with Jabber client v.11.7(1), I fixed the deskphone issue by downloading the Jabber Desk Phone Services Interface from Cisco Downloads.

can you post the path. could not able to find.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers