cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
37382
Views
40
Helpful
25
Replies
Gordon Ross
Engager

Jabber for Android: Cannot connect to Phone Services

I'm trying to setup a Jabber for Android client IM&P is working fine, but phone services aren't. I just get the error message:

 

"Cannot connect to Phone Services server. Check your network settings."

 

Other Jabber clients (Windows, Mac, iPhone & iPad) can all connect fine from the same WiFi network and get phone services. Any suggestions as to what to look for? Are there any diagnostic logs I can view in the Android Jabber client?

 

Thanks,

 

GTG

Please rate all helpful posts.
25 REPLIES 25
Matthieu Malyga
Beginner

This is an easy one :P

Seriously, I've had the same issue. I managed to made it working by following the workaround found in the release notes of Jabber for Android 10.5 :

Due to an Android kernel issue, Cisco Jabber cannot register to the Cisco Unified Communications Manageron some Android devices. To resolve this problem, try the following:

Set the Cisco Unified Communications Manager to use mixed mode security, enable secure SIP call signaling, and use port 5061. See the Cisco Unified Communications Manager Security Guide for your release for instructions on configuring mixed mode with the Cisco CTL Client. You can locate the security guides in the Cisco Unified Communications Manager Maintain and Operate Guides.

Full document here : http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/Android/10_5_1/JABA_BK_CCE067D6_00_cisco-jabber-for-android-1051.html

 

What it means is that you have to :

- set the CUCM security mode to "mixed-mode". You can do this with the "utils ctl set-cluster mixed-mode". There is no more need of e-token with a 10.0 release (don't know exactly since when, maybe even a 9.0)

- activate CAPF and CTL Provider services

- create a secure phone profile (authenticate is OK, port 5061 for SIP), assign it to the BOT device

- set the CAPF parameter to "Install/upgrade" in the BOT device with a key size that matches the one you set in the secure phone profile

Set the Cisco Unified Communications Manager to use mixed mode security

This is NOT a trivial thing to do and should not be done lightly.

There is no more need of e-token with a 10.0 release (don't know exactly since when, maybe even a 9.0)

No, this came in CUCM 10.0. 9.x still needs the e-token.

 

GTG

Please rate all helpful posts.

I opened a TAC case and the problem was that on the BOT device I had to put the domain

Android has problems connecting to only host names, it is a know issue.

Jan

This fixed our issue. thanks for the reply.

Hi,

I am having the same issue. Where we need to put domain. Please advice

It worked for me. thank you very much.

is it possible , can you send a screen shot

Hi Mathew,

Been struggling with this your method for sometime. So sorry to wake up the thread.

Im confused with this statement, as it doesnt really match what we have on cucm

- create a secure phone profile (authenticate is OK, port 5061 for SIP), assign it to the BOT device

I assume this is under phone security profile. Where do you set authentication, under device secrity mode, or by enabling digest authentication? And what should be under authentication mode under CAPF? See attached

- set the CAPF parameter to "Install/upgrade" in the BOT device with a key size that matches the one you set in the secure phone profile

Should this be null strig or authenticated.

Tshepo
Beginner

Hi

 

Remember sometimes it could boil down to the easiest thing we sometimes forget which is associating the CSF device with the end user account. 

CSF is the windows device name not the android name.  This is a BOT device.

I have the same issue connecting to phone services and just been told this to try

Other reasons I have been told is it could be the device file needs updating Oct 16 2014 is the latest

 

and

https://supportforums.cisco.com/discussion/12306341/jabber-1051-android-wont-connect-phone-services#comment-10043836

Have to change the DNS name to a FQDN

 

 

Jith Thomas
Beginner

In CUCM, under System>server>cucm,  Instead of giving the hostname, just give the IP address of the server. 

 

 

 

 

HTH 

Content for Community-Ad

Spotlight Awards 2021