cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2138
Views
0
Helpful
5
Replies
Highlighted
Beginner

Jabber for iPhone - Config URL to Exclude WebEx

Hi,

 

We are running Jabber 10.5 and our client has WebEx in the cloud and are only using it for Meeting Center, not WebEx Connect/IM services...when we launch Jabber on the iPhone using the config URL to exclude WebEx, it is still attempting to authenticate to the WebEx Connect cloud service and fails because we have no users provisioned there. 

The config URL I am using looks like this, but it seems to ignore the exclude WebEx portion...

ciscojabber://provision?ServicesDomain=abc.com&VoiceServicesDomain=cisco-uc.abc.com&ServiceDiscoveryExcludedServices=WEBEX

 

Anyone else have any issues with this? In the logs, it just shows this:

 

-- 2015-01-06 17:11:16.977 INFO [8b85000] - [service-discovery][getDomain] Getting 'domain'
-- 2015-01-06 17:11:16.977 INFO [8b85000] - [service-discovery][getConfigValue] Getting servicesDomain from ConfigFeatureSet
-- 2015-01-06 17:11:16.977 INFO [8b85000] - [service-discovery][getValue] ServiceDiscoveryConfigStore: getValue() found no value mapped to key: servicesDomain
-- 2015-01-06 17:11:16.978 INFO [8b85000] - [service-discovery][getDomain] Domain is set to: abc.com
-- 2015-01-06 17:11:16.978 INFO [8b85000] - [service-discovery][getVoiceServicesDomain] Getting VoiceServicesDomain from ConfigFeatureSet
-- 2015-01-06 17:11:16.978 INFO [8b85000] - [service-discovery][getConfigValue] Getting VoiceServicesDomain from ConfigFeatureSet
-- 2015-01-06 17:11:16.978 INFO [8b85000] - [service-discovery][getValue] ServiceDiscoveryConfigStore: getValue() found no value mapped to key: VoiceServicesDomain
-- 2015-01-06 17:11:16.978 INFO [8b85000] - [service-discovery][getVoiceServicesDomain] Retrieved VoiceServicesDomain: cisco-uc.abc.com
-- 2015-01-06 17:11:16.978 INFO [8b85000] - [service-discovery][getExcludedServicesList] Getting ServiceDiscoveryExcludedServices from ConfigFeatureSet
-- 2015-01-06 17:11:16.979 INFO [8b85000] - [service-discovery][getConfigValue] Getting ServiceDiscoveryExcludedServices from ConfigFeatureSet
-- 2015-01-06 17:11:16.979 INFO [803b000] - [csfunified.telemetry.TelemetryServiceController][processEvent] TelemetryServiceController processing Command: label: UpdateString
-- 2015-01-06 17:11:16.980 INFO [8b85000] - [service-discovery][getValue] ServiceDiscoveryConfigStore: getValue() found no value mapped to key: ServiceDiscoveryExcludedServices
-- 2015-01-06 17:11:16.980 INFO [8b85000] - [service-discovery][getExcludedServicesList] Retrieved ServiceDiscoveryExcludedServices: 
-- 2015-01-06 17:11:16.980 INFO [803b000] - [service-discovery][getValue] ServiceDiscoveryConfigStore: getValue() found no value mapped to key: TelemetryEnabled
-- 2015-01-06 17:11:16.980 INFO [8b85000] - [service-discovery][getConfigValue] Getting RemoteAccess from ConfigFeatureSet

 

 

5 REPLIES 5
Highlighted
Participant

Hi Bryan 

 

I'm having this issue as well with a customer and I'm struggling to understand how to fix it. If my customer has WEBEX Meeting Center only and no Cloud IM&P. Does this not allow us to use Automatic discovery for Services anymore? Is there something we can ask webex to do to prevent clients from thinking it's a valid place to authenticate for IM&P services? I know there is a switch that we can put in the install files to disable discovery of webex as an option but this is difficult to manage. Automatic discovery is much better.

 

Ryan

Highlighted

Ryan,

I've been told by a few TAC engineers that you should be able to call into WebEx and have them disable the WebEx Connect cloud service from responding. I tried this and we were told it was completed and it still isn't working. No one we talked to on the WebEx team seemed to understand this...we gave up and just used the configuration URL to exclude WebEx as an authenticator.

Highlighted

though I stated success with launching the URL...

turns out I can't get it to work on windows, using IE or Firefox.

also, can't get the URL workaround to work on android phones, no matter what the browser.

we did have success on iPhone with Safari to launch the URL and jabber client.

 

Bryan, any input on how you got android devices to work would be greatly appreciated.

 

 

doesn't seem Cisco TAC or the Webex team are on the same page.

the jabber client once it fails going to webexconnect should then automatically do the next step with the credentials you've already entered.

why does the customer have to do this type of testing.

very frustrating

b

Highlighted

bhough,

To get the configuration URL to work on Android devices, you have to put/host the configuration URL on a website and have the Android device browse to the website and then click on the URL. You can't do it from an email or by simply pasting the configuration URL in a browser on the Android.

Highlighted
Contributor

I was able to get this to work.

currently we only have "_cuplogin._tcp.school.edu IN SRV 0 0 8443 cups-01.school.edu" as an SRV in DNS

ciscojabber://provision?ServicesDomain=school.edu
&VoiceServicesDomain=school.edu&ServiceDiscoveryExcludedServices=WEBEX

 

it no longer asks to enter username and password for Webex Connect.

 

I reset jabber first, then file quit.

then paste this url into browser

it launches jabber and then it prompted for 'phone services' username password.

 

we are still trying to get this to work without a URL and the clients to be able to use username@school.edu

 

everything i've read so far states this is the only way.

we don't believe we should be using webex for authentication anyway.

we don't have SSO with Webex, etc.

we also only use Webex Meeting Center, not webex connect.

bh

Content for Community-Ad