Showing results for 
Search instead for 
Did you mean: 

Jabber for MAC - Can't see address book on domain

I"m working with a customer that is running Jabber.  He can respond to my messages, but can't initiate a conversation.  When he tries to find me by clicking contact or search.. no one shows up.  On my end (Windows) - he shows available all the time.


What settings are we missing?


Jabber on MAC uses BDI for directory lookup, while things work well on Windows, you will need to do some additional work to get things working on the MAC end. it is not too bad thought. 


Here is the config file. Copy the below into a text file. Make sure you update the following with your environmental information 


1. Primary Server Name 

2. Presence Domain 

3. Search Base (This will vary on where on all your users are located in the AD OU's, in my case shown below, all users are in the "Users" OU, hence CN=Users) 

4. Connection User name (you will need a AD account that has read permissions on your Domain) 

5. Connection Password (password for that account) 


once you fill out the relevant information, save the file and rename it to "jabber-config.xml"


now log into CUCM , go to Cisco Unified OS Administration >>Software Upgrades >>TFTP File Management and then click on "upload file"

Now click on choose file, browse and select the jabber-config.xml file that you just created. leave the Directory field/ box empty and click upload file. Perform the same on all of your CUCM Subscriber servers. 

Cycle your CUCM TFTP Server. Ask the MAC Jabber user to log out, log back in and have them go to the following folder on their MAC (remember the nameofuser is whatever the users name is)  


MacOSX ▸ Users ▸ nameofuser ▸ Library ▸ Application Support ▸ Cisco ▸ Unified Communications ▸ Jabber ▸ CSF ▸ Config

in there you will see that Jabber downloaded the jabber-config.xml from the TFTP server. Now things should work better and you should be able to search in both directions and find each other. 



FILE Contents 



<?xml version="1.0" encoding="UTF-8"?>

<config version="1.0">















I have this same issue; I followed the steps above with no results. I can see that the jabber-config.xml file is on the Mac client machine in the correct location, but the directory lookup is still not working.



couple of things; 

1)  can you confirm that the jabber-config.xml file on your mac has the same contents as the file you uploaded to the server. 

2) While I cannot remember if this is required (its been a year since I set up my 10.5 Jabber / Presence Servers), have you checked to make sure that the your AD server schema has been extended for IM/ Presence. While I do not use Lync and use Jabber as my IM solution, I did have to run the Lync setup just so I could extend my schema. I cannot remember what issue this resolved but I do remember I had to do this to resolve an issue with Jabber. I had to run the MS Lync setup file just so I could run the Lync schema extension so that my AD user accounts would have their schema modified to have the additional attributes related to IM/ Presence, If I recall i think it was the msRTCSIP-PrimaryUserAddress. I believe this and a few other attributes do not exist in AD until you extend your AD schema using the Lync set up. once extended, you would also set the value for the msRTCSIP-PrimaryUserAddress for each user to So if your AD alias was dovermenx and your domain was, then it would be I cannot remember now, But I also had to add this directory URI to another attribute for the users which is the proxyAddress attribute for the AD user. So your proxyAddress attribute should also be set to 

Once this is done, you can perform a LDAP sync on CUCM and see if it makes a difference.


Also make sure you perform the proper mapping for your phone fields in my case I use the ipPhone field, if you use a different field for your phone number mapping from AD to CUCM Ldap sync, then use your appropriate mapped field name in your jabber-config.xml file 


As I mentioned, I cannot remember if the above was the cause of my problems for not seeing users on my MAC, but I am certain there were some issues that I resolved with the above (i.e. the  msRTCSIP-PrimaryUserAddress and proxyAddress on AD. 




Yes, the contents of the jabber-config.xml file match those of the one that is uploaded to the tftp. I have tried uploading multiple different versions and it changes every time.


When you say that you had to run the "MS Lync setup file," do you mean on the Mac? Where would I get this file?


As I mentioned, I cannot remember what issue it fixed. In my Lab the Active Directory schema on my Domain was not extended to support SIP URI and presence functionality (whether using Lync or Cisco Presence as your IM solution). When I installed and configured presence I was having several issues including the one you are dealing with. One of the steps I had to take was to extended my Active directory schema on my Domain (your AD Servers) so that the active directory users in your domain have the "new" field / attribute called "msRTCSIP-PrimaryUserAddress". I do remember that Cisco Presence uses this field. After some research I found that I had to run the Microsoft Lync setup on my Domain (not to install Lync Server but the first step in the Lync installation is your domain preparation step which involves extended the active directory schema and adding attributes that are specific to presence and IM into your Active Directory schema). So you just run the Lync setup on your active directory, perform step # 1 which is schema extension and once that step is done, you can exit the Lync setup. In essence you are using the Lync Setup to extend the schema and nothing more. 


Once that was done, I could see the new attribute "msRTCSIP-PrimaryUserAddress" under the AD users (go to Active directory users and computers on your AD, make sure you click on view > select Advanced features. Then pull up one of the users and right click >> properties >>select the attributes editor tab and scroll down and you can find the new attribute "msRTCSIP-PrimaryUserAddress". I am not a AD expert so I manually added the value to the attribute "msRTCSIP-PrimaryUserAddress". I performed this on all users (this was a lab so it was less than 20 users) if this is production, I am sure there is a easier way to do this in bulk. 


As I mentioned, I cannot remember if this was a 100% related to the issue you have. But I suspect this was something I had to do when I had the same issue.