cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1836
Views
4
Helpful
5
Replies
Highlighted
Beginner

Jabber for Windows 9.2 deskphone control issue

Hi experts,

I'm having a problem with the newly installed Jabber for Windows 9.2.0. When I click on the bottom right "control phone" and select my Cisco 7941 it fails. I tried restarting the Cisco CTIManager service with no luck.

Deployment:

IM&Presence: cloud (Webex service)

CUCM version: 8.6(2a)

LDAP integration: full (with authentication)

Deskphone control was working prior the upgrade of Jabber for Windows. Everything else remained the same version.

Using Jabber softphone as a client still works fine.

CUCM ENd User is correctly configured.

Wireshark trace of my Jabber for Windows 9.2 client communicating with CUCM when attempting to control my deskphone shows the following:

Username: filippo.zangheri

Password: checked three times (it is correct because Jabber softphone works fine).

Any hint?

Thanks.

--

Filippo

5 REPLIES 5
Highlighted
Beginner

Jabber for Windows 9.2 deskphone control issue

See below the screen capture of Wireshark's "Follow TCP Stream" window.

Highlighted

Jabber for Windows 9.2 deskphone control issue

A few things to check:

  • You have uppercase characters in your username and aren't putting that into Jabber.
  • The desk phone is not associated to your End User object and/or your Primary Extension is not set.
  • You lack the Standard CTI Enabled user group membership.
  • The phone does not have the Allow CTI Control checkbox selected.
  • The CUCM node you have set in Jabber for CCMCIP/CTI is not the same as the one your phone is registered to.

Please remember to rate helpful responses and identify helpful or correct answers.

Highlighted
Beginner

Jabber for Windows 9.2 deskphone control issue

Hi,

I confirm everything is configured correctly (double checked).

Highlighted
Beginner

Jabber for Windows 9.2 deskphone control issue

Davide,

I know i am kind of late to the party on this one but i have fixed my issue and wanted to give you the information to see if this will work for you. If this is even still an issue?

I too had the same issue and just like you i confirmed everything was correct however I discovered something when I was looking into my End User profile on the CUCM. I had originally swapped my 7971 phone with a new 8945 phone and I had both phones associated with my line for a while before I removed the old 7971.

My End User profile still had both phones associated with my number even though the 7971 phone had been removed from my line. This was not allowing the CTI to connect to my 8945 phone or allow my jabber client to "Control Phone" properly because it couldn't figure out which phone to control. I went into the CUCM and physically deleted the 7971 phone from the system which released the associated phone in my End User profile. Once I did that, I "Control Phone" in my Jabber client and voila it worked like a charm!

To make sure I didn't have any Jabber client issues after doing this i signed out of my Jabber client and deleted the local system profile for the Jabber client and then signed back into Jabber and let it recreate the profile. Once that was done i have not had any issues with my Jabber client controlling my phone and all functions work perfectly.

Hope this helps...

Highlighted
Beginner

Jabber for Windows 9.2 deskphone control issue

Dear Tubin, thanka your answer.

My issue was caused by ldap authenticaion being incorrectly configured on CUCM.

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey